Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
repcmd 641 tcp repcmd Scott Dale Scott Dale
repcmd 641 udp repcmd Scott Dale Scott Dale
invision 1641 tcp InVision Christopher Davey Christopher Davey
invision 1641 udp InVision Christopher Davey Christopher Davey
hdl-srv 2641 tcp HDL Server David Ely David Ely
hdl-srv 2641 udp HDL Server David Ely David Ely
netplay-port2 3641 tcp Netplay Port 2 Predrag Filipovic Predrag Filipovic 2002-11
netplay-port2 3641 udp Netplay Port 2 Predrag Filipovic Predrag Filipovic 2002-11
boe-resssvr4 6410 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
6411-6416 Unassigned
faxcomservice 6417 tcp Faxcom Message Service Albert Leung Albert Leung 2006-04
faxcomservice 6417 udp Faxcom Message Service Albert Leung Albert Leung 2006-04
syserverremote 6418 tcp SYserver remote commands David Ashkenazi David Ashkenazi 2010-03-23
6418 udp Reserved
svdrp 6419 tcp Simple VDR Protocol Klaus Schmidinger Klaus Schmidinger 2010-03-31
svdrp-disc 6419 udp Simple VDR Protocol Discovery Klaus Schmidinger Klaus Schmidinger 2015-05-08
6641-6652 Unassigned
9641-9665 Unassigned
36002-36410 Unassigned
wlcp 36411 udp Wireless LAN Control plane Protocol (WLCP) 3GPP Dongwook Kim 2014-11-14 2026-01-23
36411 tcp Reserved
36412 tcp Reserved
36412 udp Reserved
s1-control 36412 sctp S1-Control Plane (3GPP) Kimmo Kymalainen Kimmo Kymalainen 2009-09-01
36413-36421 Unassigned
nfs-domainroot tcp NFS service for the domain root, the root of an organization's published file namespace. IESG IETF Chair 2012-04-24 RFC 6641 Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
3GPP dongwook.kim&etsi.org 2026-01-23
Albert Leung aleung&biscom.com 2006-04
Christopher Davey niallocl&quay.ie
David Ashkenazi david&synel.co.il 2010-03-23
David Ely dely&cnri.reston.va.us
Dongwook Kim 3GPP dongwook.kim&etsi.org 2026-01-23
Giriraj Harapanahalli giriraj.harapanahalli&sap.com 2026-05-27
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Kimmo Kymalainen kimmo.kymalainen&etsi.org 2017-05-08
Klaus Schmidinger Klaus.Schmidinger&tvdr.de 2010-03-31
Predrag Filipovic pfilipovic&digital5.com 2002-11
SAP Giriraj Harapanahalli 2026-05-27
Scott Dale scott&replicase.com