Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
nntps 563 tcp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
nntps 563 udp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
esro-emsdp 642 tcp ESRO-EMSDP V1.3 Mohsen Banan Mohsen Banan
esro-emsdp 642 udp ESRO-EMSDP V1.3 Mohsen Banan Mohsen Banan
isis-am 1642 tcp isis-am
isis-am 1642 udp isis-am
tragic 2642 tcp Tragic Stu Mark Stu Mark
tragic 2642 udp Tragic Stu Mark Stu Mark
juxml-port 3642 tcp Juxml Replication port Colin Reid Colin Reid 2002-11
juxml-port 3642 udp Juxml Replication port Colin Reid Colin Reid 2002-11
nim-vdrshell 6420 tcp NIM_VDRShell Rik Ditter Rik Ditter 2006-02
nim-vdrshell 6420 udp NIM_VDRShell Rik Ditter Rik Ditter 2006-02
nim-wan 6421 tcp NIM_WAN Rik Ditter Rik Ditter 2006-02
nim-wan 6421 udp NIM_WAN Rik Ditter Rik Ditter 2006-02
6422-6431 Unassigned
36413-36421 Unassigned
36422 tcp Reserved
36422 udp Reserved
x2-control 36422 sctp X2-Control Plane (3GPP) Dongwook Kim Dongwook Kim 2009-09-01 2026-11-10
slmap 36423 sctp SLm Interface Application Protocol 3GPP Dongwook Kim 2015-06-18 2026-11-10
nq-ap 36424 sctp Nq and Nq' Application Protocol 3GPP Dongwook Kim 2015-06-18 2026-11-10
36425-36442 Unassigned

Contact Information

Name Organization Contact URI Last Updated
3GPP info&3gpp.org 2026-11-10
Colin Reid creid&projux.com 2002-11
Dongwook Kim 3GPP info&3gpp.org 2026-10-20
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Mohsen Banan mohsen&neda.com
Rik Ditter managers&generationtechnologies.com 2006-02
Stu Mark fordii&j51.com