Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ldp 646 tcp LDP Bob Thomas Bob Thomas
ldp 646 udp LDP Bob Thomas Bob Thomas
sa-msg-port 1646 tcp sa-msg-port Eric Whitehill Eric Whitehill
sa-msg-port 1646 udp sa-msg-port Eric Whitehill Eric Whitehill
and-lm 2646 tcp AND License Manager Dick van der Sijs Dick van der Sijs
and-lm 2646 udp AND License Manager Dick van der Sijs Dick van der Sijs
xss-srv-port 3646 tcp XSS Server Port Joe Purcell Joe Purcell 2003-01
xss-srv-port 3646 udp XSS Server Port Joe Purcell Joe Purcell 2003-01
dots-signal 4646 tcp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
dots-signal 4646 udp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
vfmobile 5646 tcp Ventureforth Mobile Ventureforth Inc. Blakely Snyder 2011-11-03
5646 udp Reserved
6457-6463 Unassigned
ieee11073-20701 6464 tcp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
ieee11073-20701 6464 udp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
6465-6470 Unassigned
36445-36461 Unassigned
36462 tcp Reserved
36462 udp Reserved
xw-control 36462 sctp Xw-Control Plane (3GPP) Boubacar KIMNBA DIT ADAMOU Boubacar KIMNBA DIT ADAMOU 2015-11-13
36463-36523 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Blakely Snyder Ventureforth Inc. bsnyder&ventureforth.com 2011-11-03
Bob Thomas rhthomas&cisco.com
Boubacar KIMNBA DIT ADAMOU jinba&chinamobile.com 2015-11-13
David Gregorczyk david.gregorczyk&draeger.com 2017-03-02
Dick van der Sijs dick&and.nl
Eric Whitehill Eric.Whitehill&itt.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Joe Purcell jpurcell&ensuretech.com 2003-01
Ventureforth Inc. support&ventureforth.com 2011-11-03