Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
tinc 655 tcp TINC Ivo Timmermans Ivo Timmermans
tinc 655 udp TINC Ivo Timmermans Ivo Timmermans
dec-mbadmin 1655 tcp dec-mbadmin
dec-mbadmin 1655 udp dec-mbadmin
unglue 2655 tcp UNIX Nt Glue Peter Santoro Peter Santoro
unglue 2655 udp UNIX Nt Glue Peter Santoro Peter Santoro
abatemgr 3655 tcp ActiveBatch Exec Agent
abatemgr 3655 udp ActiveBatch Exec Agent
fg-sysupdate 6550 tcp fg-sysupdate Mark Beyer Mark Beyer
fg-sysupdate 6550 udp fg-sysupdate Mark Beyer Mark Beyer
sum 6551 tcp Software Update Manager Jan Dirven Jan Dirven 2007-12-13
sum 6551 udp Software Update Manager Jan Dirven Jan Dirven 2007-12-13
6552-6555 Unassigned
checkmk-agent 6556 tcp Checkmk Monitoring Agent Checkmk GmbH Alexander Wilms 2020-07-14 2024-08-06
6556 udp Reserved
6557 Unassigned
xdsxdm 6558 tcp Brian Tackett Brian Tackett possible contact
xdsxdm 6558 udp Brian Tackett Brian Tackett possible contact
6559-6565 Unassigned
pcs-sf-ui-man 6655 tcp PC SOFT - Software factory UI/manager Jerome AERTS Jerome AERTS 2010-11-30
6655 udp Reserved
pim-port 8471 tcp PIM over Reliable Transport IESG IETF Chair 2008-08-21 RFC 6559
pim-port 8471 sctp PIM over Reliable Transport IESG IETF Chair 2008-08-21 RFC 6559
33436-33655 Unassigned Known Unauthorized Use on ports 33436-33534
37655-37999 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Alexander Wilms Checkmk GmbH alex.wilms&checkmk.com 2024-08-06
Brian Tackett cym&acrux.net
Checkmk GmbH alex.wilms&checkmk.com 2024-08-06
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ivo Timmermans itimmermans&bigfoot.com
Jan Dirven jan.dirven&agfa.com 2007-12-13
Jerome AERTS info&pcsoft.fr 2010-11-30
Mark Beyer mbeyer&freegate.com
Peter Santoro peter&pscomp.com