Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
spmp 656 tcp SPMP Jakob Kaivo Jakob Kaivo
spmp 656 udp SPMP Jakob Kaivo Jakob Kaivo
owamp-control 861 tcp OWAMP-Control IESG IETF Chair RFC 4656
dec-mbadmin-h 1656 tcp dec-mbadmin-h Nick Shipman Nick Shipman
dec-mbadmin-h 1656 udp dec-mbadmin-h Nick Shipman Nick Shipman
kana 2656 tcp Kana Colin Goldstein Colin Goldstein
kana 2656 udp Kana Colin Goldstein Colin Goldstein
turn 3478 tcp TURN over TCP 2019-08-02 RFC 8656
turn 3478 udp TURN over UDP 2019-08-02 RFC 8656
abatjss 3656 tcp ActiveBatch Job Scheduler Ben Rosenberg Ben Rosenberg 2003-01
abatjss 3656 udp ActiveBatch Job Scheduler Ben Rosenberg Ben Rosenberg 2003-01
mupdate 3905 tcp Mailbox Update (MUPDATE) protocol RFC 3656
mupdate 3905 udp Mailbox Update (MUPDATE) protocol RFC 3656
turns 5349 tcp TURN over TLS 2019-08-02 RFC 8656
turns 5349 udp TURN over DTLS IESG IETF Chair 2019-08-02 RFC 7350 This service name was initially created by RFC 8656.
6559-6565 Unassigned
sane-port 6566 tcp SANE Control Port Henning Meier-Geinitz Henning Meier-Geinitz 2002-10
sane-port 6566 udp SANE Control Port Henning Meier-Geinitz Henning Meier-Geinitz 2002-10
6567 Reserved 2007-01 2011-08-26 This entry has been removed on 2011-08-26.
canit-store 6568 tcp CanIt Storage Manager

IANA assigned this well-formed service name as a replacement for "canit_store".
Dianne Skoll Dianne Skoll 2009-04-22 2017-05-25
canit_store 6568 tcp CanIt Storage Manager Dianne Skoll Dianne Skoll 2009-04-22 2017-05-25 This entry is an alias to "canit-store". This entry is now historic, not usable for use with many common service discovery mechanisms.
rp-reputation 6568 udp Roaring Penguin IP Address Reputation Collection Dianne Skoll Dianne Skoll 2010-02-05 2017-05-25
6569-6578 Unassigned
emgmsg 6656 tcp Emergency Message Control Service Gerry Gorman Gerry Gorman 2010-12-06
6656 udp Reserved
snip-slave 33656 tcp SNIP Slave Dr. Chris Tucker Dr. Chris Tucker 2005-08
snip-slave 33656 udp SNIP Slave Dr. Chris Tucker Dr. Chris Tucker 2005-08

Contact Information

Name Organization Contact URI Last Updated
Ben Rosenberg brosenberg&advsyscon.com 2003-01
Colin Goldstein Colin&kana.com
Dianne Skoll dfs&roaringpenguin.com 2017-05-25
Dr. Chris Tucker chris.tucker&ioltd.co.uk 2005-08
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Gerry Gorman gerry.gorman&emclock.com 2010-12-06
Henning Meier-Geinitz henning&meier-geinitz.de 2002-10
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jakob Kaivo jkaivo&nodomainname.net
Nick Shipman Nick.Shipman&mrmog.reo.dec.com