Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
vacdsm-sws 670 tcp VACDSM-SWS
vacdsm-sws 670 udp VACDSM-SWS
netview-aix-10 1670 tcp netview-aix-10
netview-aix-10 1670 udp netview-aix-10
tve-announce 2670 tcp TVE Announce Dean Blackketter Dean Blackketter
tve-announce 2670 udp TVE Announce Dean Blackketter Dean Blackketter
smile 3670 tcp SMILE TCP/UDP Interface Andre Petras Andre Petras 2003-01
smile 3670 udp SMILE TCP/UDP Interface Andre Petras Andre Petras 2003-01
light 4670 tcp Light packets transfer protocol Adam Golovenko Adam Golovenko 2006-10
light 4670 udp Light packets transfer protocol Adam Golovenko Adam Golovenko 2006-10
filemq 5670 tcp ZeroMQ file publish-subscribe protocol Pieter Hintjens Pieter Hintjens 2012-11-01 2013-02-25
zre-disc 5670 udp Local area discovery and messaging over ZeroMQ Pieter Hintjens Pieter Hintjens 2012-12-17
vocaltec-gold 6670 tcp Vocaltec Global Online Directory Scott Petrack Scott Petrack
vocaltec-gold 6670 udp Vocaltec Global Online Directory Scott Petrack Scott Petrack
6700 Unassigned 2010-01-26
kti-icad-srvr 6701 tcp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
kti-icad-srvr 6701 udp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
6701 sctp Unassigned 2010-01-26
e-design-net 6702 tcp e-Design network Janos Lerch Janos Lerch 2006-02
e-design-net 6702 udp e-Design network Janos Lerch Janos Lerch 2006-02
6702 sctp Unassigned 2010-01-26
e-design-web 6703 tcp e-Design web Janos Lerch Janos Lerch 2006-02
e-design-web 6703 udp e-Design web Janos Lerch Janos Lerch 2006-02
6704 udp Reserved
6704 tcp Reserved
frc-hp 6704 sctp ForCES HP (High Priority) channel RFC 5811
6705 udp Reserved
6705 tcp Reserved
frc-mp 6705 sctp ForCES MP (Medium Priority) channel RFC 5811
6706 udp Reserved
6706 tcp Reserved
frc-lp 6706 sctp ForCES LP (Low priority) channel RFC 5811
6707-6713 Unassigned
aero 8060 udp Asymmetric Extended Route Optimization (AERO) IESG IETF Chair RFC 6706
track 20670 tcp Track Michael Sweet Michael Sweet
track 20670 udp Track Michael Sweet Michael Sweet
mapx 36700 tcp MapX communication MicroTechniX Yarochkin Michail 2014-10-13
36700 udp Reserved
36701-36864 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Adam Golovenko golovenko&gmail.com 2006-10
Andre Petras a.petras&arcor.de 2003-01
Dean Blackketter dean&corp.webtv.net
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Janos Lerch lerch&softic.hu 2006-02
Michael Sweet msweet&ctr.nawcad.navy.mil
MicroTechniX Info&microtechnix.com 2014-10-13
Pieter Hintjens ph&imatix.com 2012-11-01
Pieter Hintjens ph&imatix.com 2012-12-17
Scott Petrack Scott_Petrack&vocaltec.com
Stanley Knutson Stanley.Knutson&ktiworld.com
Yarochkin Michail MicroTechniX Michail.Yarochkin&microtechnix.com 2014-10-13