Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| dctp | 675 | tcp | DCTP | Andre Kramer | Andre Kramer | ||||||
| dctp | 675 | udp | DCTP | Andre Kramer | Andre Kramer | ||||||
| 6a44 | 1027 | udp | IPv6 Behind NAT44 CPEs | IESG | IETF Chair | 2012-08-02 | RFC 6751 | ||||
| pdp | 1675 | tcp | Pacific Data Products | Gary Morton | Gary Morton | ||||||
| pdp | 1675 | udp | Pacific Data Products | Gary Morton | Gary Morton | ||||||
| ttc-etap | 2675 | tcp | TTC ETAP | Daniel Becker | Daniel Becker | ||||||
| ttc-etap | 2675 | udp | TTC ETAP | Daniel Becker | Daniel Becker | ||||||
| calltrax | 3675 | tcp | CallTrax Data Port | Oliver Bailey | Oliver Bailey | 2003-01 | |||||
| calltrax | 3675 | udp | CallTrax Data Port | Oliver Bailey | Oliver Bailey | 2003-01 | |||||
| dhct-status | 4675 | tcp | BIAP Device Status | ||||||||
| dhct-status | 4675 | udp | BIAP Device Status | ||||||||
| v5ua | 5675 | tcp | V5UA application port | RFC 3807 | |||||||
| v5ua | 5675 | udp | V5UA application port | RFC 3807 | |||||||
| v5ua | 5675 | sctp | V5UA application port | RFC 3807 | |||||||
| imqtunnel | 7675 | tcp | iMQ Tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| imqtunnel | 7675 | udp | iMQ Tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| msi-cps-rm | 8675 | tcp | Motorola Solutions Customer Programming Software for Radio Management | Motorola Solutions, Inc. | Jenish Amin | 2012-03-14 | |||||
| msi-cps-rm-disc | 8675 | udp | Motorola Solutions Customer Programming Software for Radio Management Discovery | Motorola Solutions, Inc. | Jenish Amin | 2012-03-14 | |||||
| 24667-24675 | Unassigned | ||||||||||
| jnx-kcsync | tcp | jollys keychain cloud sync protocol | Patrick Stein | Patrick Stein | 2011-10-24 | Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andre Kramer | Andre.Kramer&ansa.co.uk | ||
| Daniel Becker | becker2d&ttc.com | ||
| Gary Morton | mortong&pacdata.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jenish Amin | Motorola Solutions, Inc. | jenish&motorolasolutions.com | 2012-03-14 |
| Motorola Solutions, Inc. | jenish&motorolasolutions.com | 2012-03-14 | |
| Oliver Bailey | zzf66jjlm&time-lines.com | 2003-01 | |
| Patrick Stein | Patrick.Stein&jinx.eu | 2011-10-24 | |
| Shailesh S. Bavadekar | shailesh.bavadekar&sun.com | 2002-04 |