Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
mrm 679 tcp MRM Liming Wei Liming Wei
mrm 679 udp MRM Liming Wei Liming Wei
darcorp-lm 1679 tcp darcorp-lm DARcorp DARcorp
darcorp-lm 1679 udp darcorp-lm DARcorp DARcorp
syncserverssl 2679 tcp Sync Server SSL Shawn Casey Shawn Casey
syncserverssl 2679 udp Sync Server SSL Shawn Casey Shawn Casey
newton-dock 3679 tcp Newton Dock Paul Guyot Paul Guyot 2025-01-23
newton-dock 3679 udp Newton Dock Paul Guyot Paul Guyot 2025-01-23
mgesupervision 4679 tcp MGE UPS Supervision
mgesupervision 4679 udp MGE UPS Supervision
dccm 5679 tcp Direct Cable Connect Manager Mark Miller Mark Miller
dccm 5679 udp Direct Cable Connect Manager Mark Miller Mark Miller
osaut 6679 tcp Osorno Automation Peter Hombach Peter Hombach 2011-03-16
osaut 6679 udp Osorno Automation Peter Hombach Peter Hombach 2011-03-16
hnmp 6790 tcp HNMP Jude George Jude George
hnmp 6790 udp HNMP Jude George Jude George
hnm 6791 tcp Halcyon Network Manager Fortra Henriët Wilkinson 2005-05 2023-05-24
hnm 6791 udp Halcyon Network Manager Fortra Henriët Wilkinson 2005-05 2023-05-24
6792-6800 Unassigned
7678-7679 Unassigned
16790-16899 Unassigned
24679 Unassigned
45679-45823 Unassigned
mihcs MIH Command Services RFC 5679
mihes MIH Event Services RFC 5679
mihis MIH Information Services RFC 5679

Contact Information

Name Organization Contact URI Last Updated
DARcorp&aol.com
Fortra info&fortra.com 2023-05-24
Henriët Wilkinson henriet.wilkinson&fortra.com 2023-05-24
Jude George jude&nas.nasa.gov
Liming Wei lwei&cisco.com
Mark Miller mmiller&microsoft.com
Paul Guyot pguyot&kallisys.net 2003-01
Peter Hombach p.hombach&osorno.ca 2011-03-16
Shawn Casey Shawn.Casey&matrixone.com