Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ha-cluster 694 tcp ha-cluster Alan Robertson Alan Robertson
ha-cluster 694 udp ha-cluster Alan Robertson Alan Robertson
rrimwm 1694 tcp rrimwm
rrimwm 1694 udp rrimwm
pwrsevent 2694 tcp pwrsevent Yoshinobu Nakamura Yoshinobu Nakamura
pwrsevent 2694 udp pwrsevent Yoshinobu Nakamura Yoshinobu Nakamura
3694 Unassigned 2007-04-05
5694-5695 Unassigned
reload-config 6084 tcp Peer to Peer Infrastructure Configuration IESG IETF Chair 2009-01-29 2013-03-26 RFC 6940
6937-6945 Unassigned
bioserver 6946 tcp Biometrics Server ISHII AKIO ISHII AKIO 2006-01
bioserver 6946 udp Biometrics Server ISHII AKIO ISHII AKIO 2006-01
6947-6950 Unassigned
client-wakeup 9694 tcp T-Mobile Client Wakeup Message Michael Schönborn Michael Schönborn 2009-09-11
client-wakeup 9694 udp T-Mobile Client Wakeup Message Michael Schönborn Michael Schönborn 2009-09-11
16901-16949 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Alan Robertson alanr&unix.sh
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ISHII AKIO ishii.akio&jp.fujitsu.com 2006-01
Michael Schönborn T-Mobile International AG michael.schoenborn&t-mobile.net 2009-09-11
Yoshinobu Nakamura nakamura&np.lps.cs.fujitsu.co.jp