Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
uuidgen 697 tcp UUIDGEN James Falkner James Falkner
uuidgen 697 udp UUIDGEN James Falkner James Falkner
rrisat 1697 tcp rrisat Allen Briggs Allen Briggs
rrisat 1697 udp rrisat Allen Briggs Allen Briggs
oce-snmp-trap 2697 tcp Oce SNMP Trap Port Peter Teeuwen Peter Teeuwen
oce-snmp-trap 2697 udp Oce SNMP Trap Port Peter Teeuwen Peter Teeuwen
nw-license 3697 tcp NavisWorks License System Tim Wiegand Tim Wiegand 2003-02
nw-license 3697 udp NavisWorks License System Tim Wiegand Tim Wiegand 2003-02
5697-5699 Unassigned
ircs-u 6697 tcp Internet Relay Chat via TLS/SSL 2014-02-11 RFC 7194
6697 udp Reserved 2014-02-11
conductor 6970 tcp Conductor test coordination protocol George Neville-Neil George Neville-Neil 2014-09-18
6970 udp Reserved
conductor-mpx 6970 sctp conductor for multiplex George Neville-Neil George Neville-Neil 2014-07-29
6971-6979 Unassigned
klio 7697 tcp KLIO communications Helmut Giritzer Helmut Giritzer 2005-08
klio 7697 udp KLIO communications Helmut Giritzer Helmut Giritzer 2005-08

Contact Information

Name Contact URI Last Updated
Allen Briggs briggs&access.rrinc.com
George Neville-Neil gnn&neville-neil.com 2014-07-29
Helmut Giritzer helmut.giritzer&o.roteskreuz.at 2005-08
James Falkner james.falkner&sun.com
Peter Teeuwen ptee&oce.nl
Tim Wiegand tim.wiegand&navisworks.com 2003-02