Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
accessnetwork 699 tcp Access Network Yingchun Xu Yingchun Xu
accessnetwork 699 udp Access Network Yingchun Xu Yingchun Xu
rsvp-encap-2 1699 tcp RSVP-ENCAPSULATION-2 Bob Braden Bob Braden
rsvp-encap-2 1699 udp RSVP-ENCAPSULATION-2 Bob Braden Bob Braden
csoft-plusclnt 2699 tcp Csoft Plus Client Nedelcho Stanev Nedelcho Stanev
csoft-plusclnt 2699 udp Csoft Plus Client Nedelcho Stanev Nedelcho Stanev
kpn-icw 3699 tcp Internet Call Waiting B. J. Kortekaas B. J. Kortekaas 2003-02
kpn-icw 3699 udp Internet Call Waiting B. J. Kortekaas B. J. Kortekaas 2003-02
4693-4699 Unassigned
5697-5699 Unassigned
6699 tcp Reserved
babel-dtls 6699 udp Babel Routing Protocol over DTLS IESG IETF Chair 2020-09-04 RFC 8968
6981-6996 Unassigned
MobilitySrv 6997 tcp Mobility XE Protocol Joseph T Savarese Joseph T Savarese 2007-06
MobilitySrv 6997 udp Mobility XE Protocol Joseph T Savarese Joseph T Savarese 2007-06
iatp-highpri 6998 tcp IATP-highPri John Murphy John Murphy
iatp-highpri 6998 udp IATP-highPri John Murphy John Murphy
iatp-normalpri 6999 tcp IATP-normalPri John Murphy John Murphy
iatp-normalpri 6999 udp IATP-normalPri John Murphy John Murphy
7698-7699 Unassigned
vnyx 8699 tcp VNYX Primary Port Gregg Green Gregg Green 2004-11
8699 udp Reserved 2004-11 2013-05-24 This entry is being removed on 2013-05-24.
9696-9699 Unassigned
16951-16990 Unassigned
intel-rci-mp 16991 tcp INTEL-RCI-MP Jane Dashevsky Jane Dashevsky
intel-rci-mp 16991 udp INTEL-RCI-MP Jane Dashevsky Jane Dashevsky
amt-soap-http 16992 tcp Intel(R) AMT SOAP/HTTP David T. Hines David T. Hines 2005-02
amt-soap-http 16992 udp Intel(R) AMT SOAP/HTTP David T. Hines David T. Hines 2005-02
amt-soap-https 16993 tcp Intel(R) AMT SOAP/HTTPS David T. Hines David T. Hines 2005-02
amt-soap-https 16993 udp Intel(R) AMT SOAP/HTTPS David T. Hines David T. Hines 2005-02
amt-redir-tcp 16994 tcp Intel(R) AMT Redirection/TCP Nimrod Diamant Nimrod Diamant 2005-02
amt-redir-tcp 16994 udp Intel(R) AMT Redirection/TCP Nimrod Diamant Nimrod Diamant 2005-02
amt-redir-tls 16995 tcp Intel(R) AMT Redirection/TLS Nimrod Diamant Nimrod Diamant 2005-02
amt-redir-tls 16995 udp Intel(R) AMT Redirection/TLS Nimrod Diamant Nimrod Diamant 2005-02
16996-17006 Unassigned
26490-26999 Unassigned
36603-36699 Unassigned
46337-46997 Unassigned
spremotetablet 46998 tcp Connection between a desktop computer or server and a signature tablet to capture handwritten signatures SOFTPRO GmbH Christoph Hipp 2012-07-19 2013-08-02
46998 udp Reserved
mediabox 46999 tcp MediaBox Server Alexander Graef Alexander Graef 2004-11
mediabox 46999 udp MediaBox Server Alexander Graef Alexander Graef 2004-11

Contact Information

Name Organization Contact URI Last Updated
Alexander Graef alex&graef.cc 2004-11
B. J. Kortekaas b.j.kortekaas&kpn.com 2003-02
Bob Braden braden&isi.edu
Christoph Hipp SOFTPRO GmbH christoph.hipp&softpro.de 2013-08-02
David T. Hines david.hines&intel.com 2005-02
Gregg Green legal&vnyx.net 2004-11
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jane Dashevsky jane.dashevsky&intel.com
John Murphy john.m.murphy&mci.com
Joseph T Savarese joesa&nmwco.com 2007-06
Nedelcho Stanev nstanev&csoft.bg
Nimrod Diamant nimrod.diamant&intel.com 2005-02
SOFTPRO GmbH christoph.hipp&softpro.de 2013-08-02
Yingchun Xu Yingchun_Xu&3com.com