Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
gopher 70 tcp Gopher Mark McCahill Mark McCahill
gopher 70 udp Gopher Mark McCahill Mark McCahill
print-srv 170 tcp Network PostScript Brian Reid Brian Reid
print-srv 170 udp Network PostScript Brian Reid Brian Reid
dsp3270 246 tcp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
dsp3270 246 udp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
270 tcp Reserved
gist 270 udp Q-mode encapsulation for GIST messages RFC 5971
codaauth2 370 tcp codaauth2 Robert Watson Robert Watson
codaauth2 370 udp codaauth2 Robert Watson Robert Watson
scx-proxy 470 tcp scx-proxy Scott Narveson Scott Narveson
scx-proxy 470 udp scx-proxy Scott Narveson Scott Narveson
meter 570 tcp demon
meter 570 udp demon
vacdsm-sws 670 tcp VACDSM-SWS
vacdsm-sws 670 udp VACDSM-SWS
epp 700 tcp Extensible Provisioning Protocol RFC 5734
epp 700 udp EPP running over QUIC IESG IETF Chair 2026-07-23 RFC 5734; RFC-ietf-regext-epp-quic-12
lmp 701 tcp Link Management Protocol (LMP) RFC 4204
lmp 701 udp Link Management Protocol (LMP) RFC 4204
iris-beep 702 tcp IRIS over BEEP RFC 3983
iris-beep 702 udp IRIS over BEEP RFC 3983
703 Unassigned
elcsd 704 tcp errlog copy/server daemon
elcsd 704 udp errlog copy/server daemon
agentx 705 tcp AgentX Bob Natale Bob Natale
agentx 705 udp AgentX Bob Natale Bob Natale
silc 706 tcp SILC Pekka Riikonen Pekka Riikonen
silc 706 udp SILC Pekka Riikonen Pekka Riikonen
borland-dsj 707 tcp Borland DSJ Gerg Cole Gerg Cole
borland-dsj 707 udp Borland DSJ Gerg Cole Gerg Cole
708 Unassigned
entrust-kmsh 709 tcp Entrust Key Management Service Handler
entrust-kmsh 709 udp Entrust Key Management Service Handler
cadlock 770 tcp
cadlock 770 udp
nas 991 tcp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
nas 991 udp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
gmrupdateserv 1070 tcp GMRUpdateSERV Steve Kellogg Steve Kellogg
gmrupdateserv 1070 udp GMRUpdateSERV Steve Kellogg Steve Kellogg
atc-lm 1170 tcp AT+C License Manager Peter Schäfer Peter Schäfer 2004-02
atc-lm 1170 udp AT+C License Manager Peter Schäfer Peter Schäfer 2004-02
opsmgr 1270 tcp Microsoft Operations Manager Ashvin Sanghvi Ashvin Sanghvi
opsmgr 1270 udp Microsoft Operations Manager Ashvin Sanghvi Ashvin Sanghvi
us-gv 1370 tcp Unix Shell to GlobalView Makoto Mita Makoto Mita
us-gv 1370 udp Unix Shell to GlobalView Makoto Mita Makoto Mita
uaiact 1470 tcp Universal Analytics Mark R. Ludwig Mark R. Ludwig
uaiact 1470 udp Universal Analytics Mark R. Ludwig Mark R. Ludwig
orbixd 1570 tcp orbixd Bridget Walsh Bridget Walsh
orbixd 1570 udp orbixd Bridget Walsh Bridget Walsh
mil-2045-47001 1581 tcp MIL-2045-47001 Eric Whitehill Eric Whitehill
mil-2045-47001 1581 udp MIL-2045-47001 Eric Whitehill Eric Whitehill
netview-aix-10 1670 tcp netview-aix-10
netview-aix-10 1670 udp netview-aix-10
mps-raft 1700 tcp mps-raft Jason Leupen Jason Leupen
mps-raft 1700 udp mps-raft Jason Leupen Jason Leupen
l2f 1701 tcp l2f
l2f 1701 udp l2f
l2tp 1701 tcp l2tp Andy Valencia Andy Valencia
l2tp 1701 udp l2tp Andy Valencia Andy Valencia
deskshare 1702 tcp deskshare Sarah Thompson Sarah Thompson
deskshare 1702 udp deskshare Sarah Thompson Sarah Thompson
hb-engine 1703 tcp hb-engine Charles C.L. Chou Charles C.L. Chou
hb-engine 1703 udp hb-engine Charles C.L. Chou Charles C.L. Chou
bcs-broker 1704 tcp bcs-broker Andy Warner Andy Warner
bcs-broker 1704 udp bcs-broker Andy Warner Andy Warner
slingshot 1705 tcp slingshot Paul Groarke Paul Groarke
slingshot 1705 udp slingshot Paul Groarke Paul Groarke
jetform 1706 tcp jetform gdeinsta gdeinsta
jetform 1706 udp jetform gdeinsta gdeinsta
vdmplay 1707 tcp vdmplay David Thielen David Thielen
vdmplay 1707 udp vdmplay David Thielen David Thielen
gat-lmd 1708 tcp gat-lmd Igor Zaoutine Igor Zaoutine
gat-lmd 1708 udp gat-lmd Igor Zaoutine Igor Zaoutine
centra 1709 tcp centra Drew Wolff Drew Wolff
centra 1709 udp centra Drew Wolff Drew Wolff
bmc-net-svc 1770 tcp bmc-net-svc Portnoy Boxman Portnoy Boxman
bmc-net-svc 1770 udp bmc-net-svc Portnoy Boxman Portnoy Boxman
sunscalar-dns 1870 tcp SunSCALAR DNS Service Sanjay Radia Sanjay Radia
sunscalar-dns 1870 udp SunSCALAR DNS Service Sanjay Radia Sanjay Radia
netop-rc 1970 tcp NetOp Remote Control
netop-rc 1970 udp NetOp Remote Control
ah-esp-encap 2070 tcp AH and ESP Encapsulated in UDP packet Amy Weaver Amy Weaver
ah-esp-encap 2070 udp AH and ESP Encapsulated in UDP packet Amy Weaver Amy Weaver
eyetv 2170 tcp EyeTV Server Port Elgato Systems Elgato Systems 2004-11
eyetv 2170 udp EyeTV Server Port Elgato Systems Elgato Systems 2004-11
starschool 2270 tcp starSchool Adam Ernst Adam Ernst 2004-12
starschool 2270 udp starSchool Adam Ernst Adam Ernst 2004-12
l3-hbmon 2370 tcp L3-HBMon Dolores Scott Dolores Scott 2014-04-09
l3-hbmon 2370 udp L3-HBMon Dolores Scott Dolores Scott 2014-04-09
iec-104 2404 tcp IEC 60870-5-104 process control over IP Walter K. Eichelburg Walter K. Eichelburg
iec-104 2404 udp IEC 60870-5-104 process control over IP Walter K. Eichelburg Walter K. Eichelburg
taskman-port 2470 tcp taskman port Boris Panteleev Boris Panteleev
taskman-port 2470 udp taskman port Boris Panteleev Boris Panteleev
hs-port 2570 tcp HS Port Uri Doron Uri Doron
hs-port 2570 udp HS Port Uri Doron Uri Doron
tve-announce 2670 tcp TVE Announce Dean Blackketter Dean Blackketter
tve-announce 2670 udp TVE Announce Dean Blackketter Dean Blackketter
tqdata 2700 tcp tqdata Al Guetzlaff Al Guetzlaff
tqdata 2700 udp tqdata Al Guetzlaff Al Guetzlaff

Contact Information

Name Organization Contact URI Last Updated
Adam Ernst cosmicsoft&cosmicsoft.net 2004-12
Al Guetzlaff aeg&teamquest.com
Amy Weaver aweaver&vpnet.com
Andy Valencia vandys&vandys-lap.cisco.com
Andy Warner andyw&knoware.nl
Ashvin Sanghvi AshvinS&microsoft.com
Bob Natale bob.natale&appliedsnmp.com
Boris Panteleev bpanteleev&himel.com
Brian Reid reid&decwrl.dec.com
Bridget Walsh bwalsh&iona.ie
Charles C.L. Chou cchou&zoom.com
David Thielen support&windward.net
Dean Blackketter dean&corp.webtv.net
Dolores Scott Dolores.Scott&l-3security.com
Drew Wolff dwolff&centra.net
Elgato Systems portinfo&elgato.com 2004-11
Eric Whitehill Eric.Whitehill&itt.com
Gerg Cole gcole&corp.borland.com
Heiko Schlichting heiko.schlichting&fu-berlin.de 2022-06-07
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Igor Zaoutine igor&global-tech.com
Jason Leupen Jleupen&aol.com
Makoto Mita mita&ssdev.ksp.fujixerox.co.jp
Mark McCahill mpm&boombox.micro.umn.edu
Mark R. Ludwig Mark-Ludwig&uai.com
Paul Groarke paulg&quay.ie
Pekka Riikonen priikone&poseidon.pspt.fi
Peter Schäfer p.schaefer&nospam.atc-systeme.de 2004-02
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Robert Watson robert&cyrus.watson.org
Sanjay Radia srradia&kasumbi.eng.sun.com
Sarah Thompson sarah&telergy.com
Scott Narveson sjn&cray.com
Steve Kellogg stevekellogg&mezzogmr.com
Uri Doron uri&il.netect.com
Vera Heinau vera.heinau&fu-berlin.de 2022-06-07
Walter K. Eichelburg walter.eichelburg&sat-automation.com
Weldon J. Showalter Gamma&mintaka.dca.mil
gdeinsta gdeinsta&jetform.com