Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
lmp 701 tcp Link Management Protocol (LMP) RFC 4204
lmp 701 udp Link Management Protocol (LMP) RFC 4204
l2f 1701 tcp l2f
l2f 1701 udp l2f
l2tp 1701 tcp l2tp Andy Valencia Andy Valencia
l2tp 1701 udp l2tp Andy Valencia Andy Valencia
sms-rcinfo 2701 tcp SMS RCINFO
sms-rcinfo 2701 udp SMS RCINFO
netcelera 3701 tcp NetCelera Tarek Nabhan Tarek Nabhan 2003-02
netcelera 3701 udp NetCelera Tarek Nabhan Tarek Nabhan 2003-02
netxms-mgmt 4701 tcp NetXMS Management
netxms-mgmt 4701 udp NetXMS Management
5701-5704 Unassigned
ieee11073-20701 6464 tcp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
ieee11073-20701 6464 udp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
kti-icad-srvr 6701 tcp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
kti-icad-srvr 6701 udp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
6701 sctp Unassigned 2010-01-26
ups-onlinet 7010 tcp onlinet uninterruptable power supplies Jim Thompson Jim Thompson
ups-onlinet 7010 udp onlinet uninterruptable power supplies Jim Thompson Jim Thompson
talon-disc 7011 tcp Talon Discovery Port Jim Thompson Jim Thompson Known Unauthorized Use on 7011
talon-disc 7011 udp Talon Discovery Port Jim Thompson Jim Thompson Known Unauthorized Use on 7011
talon-engine 7012 tcp Talon Engine Jim Thompson Jim Thompson Known Unauthorized Use on 7011
talon-engine 7012 udp Talon Engine Jim Thompson Jim Thompson Known Unauthorized Use on 7011
microtalon-dis 7013 tcp Microtalon Discovery Jim Thompson Jim Thompson
microtalon-dis 7013 udp Microtalon Discovery Jim Thompson Jim Thompson
microtalon-com 7014 tcp Microtalon Communications Jim Thompson Jim Thompson
microtalon-com 7014 udp Microtalon Communications Jim Thompson Jim Thompson
talon-webserver 7015 tcp Talon Webserver Jim Thompson Jim Thompson
talon-webserver 7015 udp Talon Webserver Jim Thompson Jim Thompson
spg 7016 tcp SPG Controls Carrier SPG Controls Ltd Steve Barton 2017-03-27
spg 7016 udp SPG Controls Carrier SPG Controls Ltd Steve Barton 2017-03-27
grasp 7017 tcp GeneRic Autonomic Signaling Protocol IESG IETF Chair 2017-04-28 2017-07-20 RFC 8990
grasp 7017 udp GeneRic Autonomic Signaling Protocol IESG IETF Chair 2017-04-28 2017-07-20 RFC 8990
fisa-svc 7018 tcp FISA Service FAUCONNET Ingénierie SA FAUCONNET Ingénierie SA 2011-05-19
7018 udp Reserved
doceri-ctl 7019 tcp doceri drawing service control Paul Brown Paul Brown 2011-04-27
doceri-view 7019 udp doceri drawing service screen view Paul Brown Paul Brown 2011-04-27
7701 tcp Reserved
7701 udp Reserved
nfapi 7701 sctp SCF nFAPI defining MAC/PHY split Small Cell Forum Richard Kennedy 2017-01-24
9701-9746 Unassigned
ncpu 17010 tcp Plan 9 cpu port Ronald G. Minnich Ronald G. Minnich 2022-05-13 Defined TXT keys: u=username; k=keypattern; f=fstabFILE; n=namespace; h=hostkey; r=root
17010 udp Reserved
17011-17183 Unassigned
flex-lmadmin 27010 tcp A protocol for managing license services Flexera Paul Bland 2018-08-22
27010 udp Reserved
27011-27015 Unassigned
chlenix 27016 tcp Cloud hosting environment network Vlad Bondarenko Vlad Bondarenko 2024-09-23
27016 udp Reserved
mongodb 27017 tcp Mongo database system MongoDB, Inc. Akshay Kumar 2019-02-21
27017 udp Reserved
27018-27344 Unassigned Unauthorized Use Known on ports 27018 and 27019
36701-36864 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Akshay Kumar MongoDB, Inc. akshay&mongodb.com 2019-02-21
Andy Valencia vandys&vandys-lap.cisco.com
David Gregorczyk david.gregorczyk&draeger.com 2017-03-02
FAUCONNET Ingénierie SA dev&fisa.fr 2011-05-19
Flexera pbland&flexera.com 2018-08-22
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jim Thompson jim.thompson&powerware.com
MongoDB, Inc. akshay&mongodb.com 2019-02-21
Paul Bland pbland&flexera.com 2018-08-22
Paul Brown pbrown&spcontrols.com 2011-04-27
Richard Kennedy Richard&smallcellforum.org 2017-01-24
Ronald G. Minnich rminnich&gmail.com 2022-05-13
Small Cell Forum Richard&smallcellforum.org 2017-01-24
SPG Controls Ltd steveb&spgcontrols.com 2017-03-27
Stanley Knutson Stanley.Knutson&ktiworld.com
Steve Barton SPG Controls Ltd steveb&spgcontrols.com 2017-03-27
Tarek Nabhan standards&itworx.com 2003-02
Vlad Bondarenko bondarenko.vlad.univ&gmail.com 2024-09-23