Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
iris-beep 702 tcp IRIS over BEEP RFC 3983
iris-beep 702 udp IRIS over BEEP RFC 3983
deskshare 1702 tcp deskshare Sarah Thompson Sarah Thompson
deskshare 1702 udp deskshare Sarah Thompson Sarah Thompson
sms-xfer 2702 tcp SMS XFER
sms-xfer 2702 udp SMS XFER
ws-discovery 3702 tcp Web Service Discovery Christian Huitema Christian Huitema 2003-02
ws-discovery 3702 udp Web Service Discovery Christian Huitema Christian Huitema 2003-02
netxms-sync 4702 tcp NetXMS Server Synchronization Victor Kirhenshtein Victor Kirhenshtein 2006-07
netxms-sync 4702 udp NetXMS Server Synchronization Victor Kirhenshtein Victor Kirhenshtein 2006-07
e-design-net 6702 tcp e-Design network Janos Lerch Janos Lerch 2006-02
e-design-net 6702 udp e-Design network Janos Lerch Janos Lerch 2006-02
6702 sctp Unassigned 2010-01-26
dpserve 7020 tcp DP Serve Allan Stanley Allan Stanley
dpserve 7020 udp DP Serve Allan Stanley Allan Stanley
dpserveadmin 7021 tcp DP Serve Admin Allan Stanley Allan Stanley
dpserveadmin 7021 udp DP Serve Admin Allan Stanley Allan Stanley
ctdp 7022 tcp CT Discovery Protocol James Kirkwood James Kirkwood 2005-06
ctdp 7022 udp CT Discovery Protocol James Kirkwood James Kirkwood 2005-06
ct2nmcs 7023 tcp Comtech T2 NMCS Bryan Wilcutt Bryan Wilcutt 2005-06
ct2nmcs 7023 udp Comtech T2 NMCS Bryan Wilcutt Bryan Wilcutt 2005-06
vmsvc 7024 tcp Vormetric service Tom Boyle Tom Boyle 2005-06
vmsvc 7024 udp Vormetric service Tom Boyle Tom Boyle 2005-06
vmsvc-2 7025 tcp Vormetric Service II Tom Boyle Tom Boyle 2005-06
vmsvc-2 7025 udp Vormetric Service II Tom Boyle Tom Boyle 2005-06
loreji-panel 7026 tcp Loreji Webhosting Panel J.A. Smit DALTCORE 2018-02-21
7026 udp Reserved
7027-7029 Unassigned
7702-7706 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Allan Stanley allan&hummingbird.com
Bryan Wilcutt bwilcutt&comtechefdata.com 2005-06
Christian Huitema huitema&microsoft.com 2003-02
DALTCORE Info&daltcore.com 2018-02-21
J.A. Smit rsmit&daltcore.com 2018-02-21
James Kirkwood james.kirkwood&controltechniques.com 2005-06
Janos Lerch lerch&softic.hu 2006-02
Sarah Thompson sarah&telergy.com
Tom Boyle tboyle&vormetric.com 2005-06
Victor Kirhenshtein victor&opticom.lv 2006-07