Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
borland-dsj 707 tcp Borland DSJ Gerg Cole Gerg Cole
borland-dsj 707 udp Borland DSJ Gerg Cole Gerg Cole
nas 991 tcp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
nas 991 udp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
vdmplay 1707 tcp vdmplay David Thielen David Thielen
vdmplay 1707 udp vdmplay David Thielen David Thielen
emcsymapiport 2707 tcp EMCSYMAPIPORT Bruce Ferjulian Bruce Ferjulian
emcsymapiport 2707 udp EMCSYMAPIPORT Bruce Ferjulian Bruce Ferjulian
rt-event-s 3707 tcp Real-Time Event Secure Port Terry Gin Terry Gin 2003-02
rt-event-s 3707 udp Real-Time Event Secure Port Terry Gin Terry Gin 2003-02
6707-6713 Unassigned
arcp 7070 tcp ARCP Jude George Jude George
arcp 7070 udp ARCP Jude George Jude George
iwg1 7071 tcp IWGADTS Aircraft Housekeeping Message Don Sullivan Don Sullivan 2010-02-16
iwg1 7071 udp IWGADTS Aircraft Housekeeping Message Don Sullivan Don Sullivan 2010-02-16
iba-cfg 7072 tcp iba Device Configuration Protocol iba AG Alexander Melamed 2018-02-12
iba-cfg-disc 7072 udp iba Device Configuration Protocol iba AG Alexander Melamed 2018-02-12
martalk 7073 tcp MarTalk protocol Mahr GmbH Göttingen Kevin Bube 2013-09-02
7073 udp Reserved
7074-7079 Unassigned
sync-em7 7707 tcp EM7 Dynamic Updates Christopher Cordray Christopher Cordray 2004-11
sync-em7 7707 udp EM7 Dynamic Updates Christopher Cordray Christopher Cordray 2004-11

Contact Information

Name Organization Contact URI Last Updated
Alexander Melamed alexander.melamed&iba-ag.com 2018-02-12
Bruce Ferjulian ferjulian_bruce&emc.com
Christopher Cordray ccordray&sciencelogic.com 2008-06-05
David Thielen support&windward.net
Don Sullivan donald.v.sullivan&nasa.gov 2010-02-16
Gerg Cole gcole&corp.borland.com
Heiko Schlichting heiko.schlichting&fu-berlin.de 2022-06-07
iba AG info&iba-ag.com 2018-02-12
Jude George jude&nas.nasa.gov
Kevin Bube Mahr GmbH Göttingen kevin.bube&mahr.de 2013-09-02
Mahr GmbH Göttingen info&mahr.de 2013-09-02
Terry Gin terry_gin&inter-tel.com 2003-02
Vera Heinau vera.heinau&fu-berlin.de 2022-06-07