Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
netviewdm2 730 tcp IBM NetView DM/6000 send/tcp
netviewdm2 730 udp IBM NetView DM/6000 send/tcp
roketz 1730 tcp roketz [Ahti_Heinla] [Ahti_Heinla]
roketz 1730 udp roketz [Ahti_Heinla] [Ahti_Heinla]
nec-raidplus 2730 tcp NEC RaidPlus [Yusuke_Asai] [Yusuke_Asai]
nec-raidplus 2730 udp NEC RaidPlus [Yusuke_Asai] [Yusuke_Asai]
client-ctrl 3730 tcp Client Control [Lawrence_W_Dunn] [Lawrence_W_Dunn] 2003-04
client-ctrl 3730 udp Client Control [Lawrence_W_Dunn] [Lawrence_W_Dunn] 2003-04
gearman 4730 tcp Gearman Job Queue System [Eric_Day] [Eric_Day] 2009-01-16
gearman 4730 udp Gearman Job Queue System [Eric_Day] [Eric_Day] 2009-01-16
coaps 5684 tcp Constrained Application Protocol (CoAP) [IESG] [IETF_Chair] 2017-12-22 [RFC 7301][RFC 8323]
unieng 5730 tcp Steltor's calendar access [Bernard_Desruisseaux] [Bernard_Desruisseaux]
unieng 5730 udp Steltor's calendar access [Bernard_Desruisseaux] [Bernard_Desruisseaux]
swx 7300-7359 The Swiss Exchange [Edgar_Blum] [Edgar_Blum]
17730-17753 Unassigned

Contact Information

ID Name Organization Contact URI Last Updated
[Ahti_Heinla] Ahti Heinla mailto:ahti&ahti.bluemoon.ee 2002-06
[Bernard_Desruisseaux] Bernard Desruisseaux mailto:bernard&steltor.com
[Edgar_Blum] Edgar Blum mailto:edgar.blum&swx.ch
[Eric_Day] Eric Day mailto:eday&oddments.org 2009-01-16
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Lawrence_W_Dunn] Lawrence W. Dunn mailto:larrydunn&aptcomp.com 2003-04
[Yusuke_Asai] Yusuke Asai mailto:yasai&nw1.file.fc.nec.co.jp