Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-10-09
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| nlogin | 758 | tcp | |||||||||
| nlogin | 758 | udp | |||||||||
| tftp-mcast | 1758 | tcp | tftp-mcast | [Tom_Emberson] | [Tom_Emberson] | ||||||
| tftp-mcast | 1758 | udp | tftp-mcast | [Tom_Emberson] | [Tom_Emberson] | ||||||
| apollo-status | 2758 | tcp | APOLLO Status | ||||||||
| apollo-status | 2758 | udp | APOLLO Status | ||||||||
| apw-registry | 3758 | tcp | apw RMI registry | [Dan_Davis] | [Dan_Davis] | 2003-04 | |||||
| apw-registry | 3758 | udp | apw RMI registry | [Dan_Davis] | [Dan_Davis] | 2003-04 | |||||
| 5758-5765 | Unassigned | ||||||||||
| netconf-tls | 6513 | tcp | NETCONF over TLS | [IESG] | [IETF_Chair] | 2024-01-24 | [RFC 7589][RFC 9918] | ||||
| 7576-7587 | Unassigned | ||||||||||
| sun-lm | 7588 | tcp | Sun License Manager | [Sophie_Deng] | [Sophie_Deng] | ||||||
| sun-lm | 7588 | udp | Sun License Manager | [Sophie_Deng] | [Sophie_Deng] | ||||||
| 7589-7605 | Unassigned | ||||||||||
| jnx-kcsync | tcp | jollys keychain cloud sync protocol | [Patrick_Stein] | [Patrick_Stein] | 2011-10-24 | Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa | |||||
| radiusdtls | udp | Authentication, Accounting, and Dynamic Authorization via the RADIUS protocol. This service name is used to construct the SRV service label "_radiusdtls" for discovery of RADIUS/DTLS servers. | [IESG] | [IETF_Chair] | 2015-03-23 | 2015-10-06 | [RFC 7585] | Defined TXT keys: None | |||
| radiustls | tcp | Authentication, Accounting, and Dynamic Authorization via the RADIUS protocol. This service name is used to construct the SRV service label "_radiustls" for discovery of RADIUS/TLS servers. | [IESG] | [IETF_Chair] | 2015-03-23 | 2015-10-06 | [RFC 7585] | Defined TXT keys: None |
Contact Information
| ID | Name | Organization | Contact URI | Last Updated |
|---|---|---|---|---|
| [Dan_Davis] | Dan Davis | mailto:Dan.A.Davis&hp.com | 2003-04 | |
| [IESG] | IESG | mailto:iesg&ietf.org | ||
| [IETF_Chair] | IETF Chair | IETF | mailto:chair&ietf.org | |
| [Patrick_Stein] | Patrick Stein | mailto:Patrick.Stein&jinx.eu | 2011-10-24 | |
| [Sophie_Deng] | Sophie Deng | mailto:Sophie.Deng&eng.sun.com | ||
| [Tom_Emberson] | Tom Emberson | mailto:tom&lanworks.com |