Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
webster 765 tcp [Josyula_R_Rao] [Josyula_R_Rao]
webster 765 udp [Josyula_R_Rao] [Josyula_R_Rao]
cft-4 1765 tcp cft-4 [Martine_Marchand] [Martine_Marchand]
cft-4 1765 udp cft-4 [Martine_Marchand] [Martine_Marchand]
qip-audup 2765 tcp qip-audup [Mike_Morgan] [Mike_Morgan]
qip-audup 2765 udp qip-audup [Mike_Morgan] [Mike_Morgan]
rtraceroute 3765 tcp Remote Traceroute [A_Blake_Cooper] [A_Blake_Cooper] 2003-06
rtraceroute 3765 udp Remote Traceroute [A_Blake_Cooper] [A_Blake_Cooper] 2003-06
5758-5765 Unassigned
ultraseek-http 8765 tcp Ultraseek HTTP [Walter_Underwood] [Walter_Underwood]
ultraseek-http 8765 udp Ultraseek HTTP [Walter_Underwood] [Walter_Underwood]
gamesmith-port 31765 tcp GameSmith Port [Randy_Thompson] [Randy_Thompson] 2002-08
gamesmith-port 31765 udp GameSmith Port [Randy_Thompson] [Randy_Thompson] 2002-08
37602-37653 Unassigned
unisys-eportal 37654 tcp Unisys ClearPath ePortal [Sung_U_Ro] [Sung_U_Ro] 2006-01
unisys-eportal 37654 udp Unisys ClearPath ePortal [Sung_U_Ro] [Sung_U_Ro] 2006-01
37655-37999 Unassigned
dns-push-tls tcp DNS Push Notification Service Type [IESG] [IETF_Chair] 2019-11-25 [RFC8765, Section 6.1] Defined TXT Keys: None

Contact Information

ID Name Organization Contact URI Last Updated
[A_Blake_Cooper] A. Blake Cooper mailto:blake&cluebie.net 2003-06
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Josyula_R_Rao] Josyula R. Rao mailto:jrrao&watson.ibm.com
[Martine_Marchand] Martine Marchand tel:+16-1-46-59-24-84
[Mike_Morgan] Mike Morgan mailto:mmorgan&lucent.com
[Randy_Thompson] Randy Thompson mailto:thompr&earthlink.net 2002-08
[Sung_U_Ro] Sung U. Ro mailto:ePortalSupport&unisys.com 2006-01
[Walter_Underwood] Walter Underwood mailto:wunder&infoseek.com