Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
idxp 603 tcp IDXP [RFC 4767]
idxp 603 udp IDXP [RFC 4767]
phonebook 767 tcp phone [Josyula_R_Rao] [Josyula_R_Rao]
phonebook 767 udp phone [Josyula_R_Rao] [Josyula_R_Rao]
sacred 1118 tcp SACRED [RFC 3767]
sacred 1118 udp SACRED [RFC 3767]
cft-6 1767 tcp cft-6 [Martine_Marchand] [Martine_Marchand]
cft-6 1767 udp cft-6 [Martine_Marchand] [Martine_Marchand]
uadtc 2767 tcp UADTC
uadtc 2767 udp UADTC
listmgr-port 3767 tcp ListMGR Port [Takashi_Kubota] [Takashi_Kubota] 2003-06
listmgr-port 3767 udp ListMGR Port [Takashi_Kubota] [Takashi_Kubota] 2003-06
s-openmail 5767 tcp OpenMail Suer Agent Layer (Secure) [OpenMail_Encyclopedi][Don_Loughry] [OpenMail_Encyclopedi][Don_Loughry]
s-openmail 5767 udp OpenMail Suer Agent Layer (Secure) [OpenMail_Encyclopedi][Don_Loughry] [OpenMail_Encyclopedi][Don_Loughry]
bmc-perf-agent 6767 tcp BMC PERFORM AGENT [Portnoy_Boxman] [Portnoy_Boxman]
bmc-perf-agent 6767 udp BMC PERFORM AGENT [Portnoy_Boxman] [Portnoy_Boxman]
7669-7671 Unassigned
imqstomp 7672 tcp iMQ STOMP Server [Amy_Kang] [Amy_Kang] 2009-03-10
7672 udp Reserved
imqstomps 7673 tcp iMQ STOMP Server over SSL [Amy_Kang] [Amy_Kang] 2009-03-10
7673 udp Reserved
imqtunnels 7674 tcp iMQ SSL tunnel [Shailesh_S_Bavadeka] [Shailesh_S_Bavadeka] 2002-04
imqtunnels 7674 udp iMQ SSL tunnel [Shailesh_S_Bavadeka] [Shailesh_S_Bavadeka] 2002-04
imqtunnel 7675 tcp iMQ Tunnel [Shailesh_S_Bavadeka] [Shailesh_S_Bavadeka] 2002-04
imqtunnel 7675 udp iMQ Tunnel [Shailesh_S_Bavadeka] [Shailesh_S_Bavadeka] 2002-04
imqbrokerd 7676 tcp iMQ Broker Rendezvous [Joseph_Di_Pol] [Joseph_Di_Pol] 2002-04
imqbrokerd 7676 udp iMQ Broker Rendezvous [Joseph_Di_Pol] [Joseph_Di_Pol] 2002-04
sun-user-https 7677 tcp Sun App Server - HTTPS [Abhijit_Kumar] [Abhijit_Kumar] 2005-11
sun-user-https 7677 udp Sun App Server - HTTPS [Abhijit_Kumar] [Abhijit_Kumar] 2005-11
7678-7679 Unassigned
core-of-source 8767 tcp Online mobile multiplayer game [Alt_Solve_Sdn_Bhd] [Almaz_Hong] 2019-07-24
8767 udp Reserved
filenet-powsrm 32767 tcp FileNet BPM WS-ReliableMessaging Client [Chris_Adkins] [Chris_Adkins] 2006-08
filenet-powsrm 32767 udp FileNet BPM WS-ReliableMessaging Client [Chris_Adkins] [Chris_Adkins] 2006-08

Contact Information

ID Name Organization Contact URI Last Updated
[Abhijit_Kumar] Abhijit Kumar mailto:as-iana-ports&sun.com 2005-11
[Almaz_Hong] Almaz Hong mailto:almaz.hong&altsolve.com 2019-07-24
[Alt_Solve_Sdn_Bhd] Alt Solve Sdn Bhd mailto:support&altsolve.com 2019-07-24
[Amy_Kang] Amy Kang mailto:amy.kang&sun.com 2009-03-10
[Chris_Adkins] Chris Adkins mailto:cadkins&filenet.com 2006-10
[Don_Loughry] Don Loughry mailto:DON_LOUGHRY&hp-cupertino-om4.om.hp.com
[Joseph_Di_Pol] Joseph Di Pol mailto:joe.dipol&sun.com 2002-04
[Josyula_R_Rao] Josyula R. Rao mailto:jrrao&watson.ibm.com
[Martine_Marchand] Martine Marchand tel:+16-1-46-59-24-84
[OpenMail_Encyclopedi] OpenMail Encyclopedia mailto:opencyc&hpopd.pwd.hp.com
[Portnoy_Boxman] Portnoy Boxman mailto:portnoy_boxman&bmc.com 2005-01
[Shailesh_S_Bavadeka] Shailesh S. Bavadekar mailto:shailesh.bavadekar&sun.com 2002-04
[Takashi_Kubota] Takashi Kubota mailto:kubota.takashi&pfu.fugitsu.com 2003-06