Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
cadlock 770 tcp
cadlock 770 udp
bmc-net-svc 1770 tcp bmc-net-svc [Portnoy_Boxman] [Portnoy_Boxman]
bmc-net-svc 1770 udp bmc-net-svc [Portnoy_Boxman] [Portnoy_Boxman]
veronica 2770 tcp Veronica [Jonas_Oberg] [Jonas_Oberg]
veronica 2770 udp Veronica [Jonas_Oberg] [Jonas_Oberg]
cindycollab 3770 tcp Cinderella Collaboration [Ulrich_Kortenkamp] [Ulrich_Kortenkamp] 2003-06
cindycollab 3770 udp Cinderella Collaboration [Ulrich_Kortenkamp] [Ulrich_Kortenkamp] 2003-06
spramsd 5770 tcp x509solutions Secure Data [Brendan_Fay] [Brendan_Fay] 2006-02
spramsd 5770 udp x509solutions Secure Data [Brendan_Fay] [Brendan_Fay] 2006-02
plysrv-http 6770 tcp PolyServe http [Mike_Spitzer] [Mike_Spitzer] 2005-08
plysrv-http 6770 udp PolyServe http [Mike_Spitzer] [Mike_Spitzer] 2005-08
em7-secom 7700 tcp EM7 Secure Communications [Christopher_Cordray] [Christopher_Cordray] 2008-06-05
7700 udp Reserved
7701 tcp Reserved
7701 udp Reserved
nfapi 7701 sctp SCF nFAPI defining MAC/PHY split [Small_Cell_Forum] [Richard_Kennedy] 2017-01-24
7702-7706 Unassigned
sync-em7 7707 tcp EM7 Dynamic Updates [Christopher_Cordray] [Christopher_Cordray] 2004-11
sync-em7 7707 udp EM7 Dynamic Updates [Christopher_Cordray] [Christopher_Cordray] 2004-11
scinet 7708 tcp scientia.net [Christoph_Anton_Mitt] [Christoph_Anton_Mitt] 2006-01
scinet 7708 udp scientia.net [Christoph_Anton_Mitt] [Christoph_Anton_Mitt] 2006-01
7709-7719 Unassigned
dpap 8770 tcp Digital Photo Access Protocol (iPhoto) [Amandeep_Jawa_2] [Amandeep_Jawa_2] 2004-11 Defined TXT keys: txtvers, Version, iPSh Version, Machine ID, Machine Name, Password
dpap 8770 udp Digital Photo Access Protocol (iPhoto) [Amandeep_Jawa_2] [Amandeep_Jawa_2] 2004-11 Defined TXT keys: txtvers, Version, iPSh Version, Machine ID, Machine Name, Password
hip-nat-t 10500 udp HIP NAT-Traversal [IESG] [IETF_Chair] 2020-08-12 [RFC 5770][RFC 9028]
18770-18880 Unassigned
filenet-nch 32770 tcp Filenet NCH [Daniel_Whelan] [Daniel_Whelan]
filenet-nch 32770 udp Filenet NCH [Daniel_Whelan] [Daniel_Whelan]

Contact Information

ID Name Organization Contact URI Last Updated
[Amandeep_Jawa_2] Amandeep Jawa mailto:dpap&apple.com 2004-11
[Brendan_Fay] Brendan Fay mailto:brendan.fay&x509solutions.com 2006-02
[Christoph_Anton_Mitt] Christoph Anton Mitterer mailto:calestyo&scientia.net 2009-03-10
[Christopher_Cordray] Christopher Cordray mailto:ccordray&sciencelogic.com 2008-06-05
[Daniel_Whelan] Daniel Whelan mailto:dwhelan&filenet.com
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Jonas_Oberg] Jonas Oberg mailto:jonas&coyote.org
[Mike_Spitzer] Mike Spitzer mailto:mjs&polyserve.com 2005-08
[Portnoy_Boxman] Portnoy Boxman mailto:portnoy_boxman&bmc.com 2005-01
[Richard_Kennedy] Richard Kennedy mailto:Richard&smallcellforum.org 2017-01-24
[Small_Cell_Forum] Small Cell Forum mailto:Richard&smallcellforum.org 2017-01-24
[Ulrich_Kortenkamp] Ulrich Kortenkamp mailto:kortenkamp&cinderella.de 2003-06