Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| finger | 79 | tcp | Finger | David Zimmerman | David Zimmerman | Unauthorized use by some mail users (see [RFC4146] for details) | |||||
| finger | 79 | udp | Finger | David Zimmerman | David Zimmerman | Unauthorized use by some mail users (see [RFC4146] for details) | |||||
| bgp | 179 | tcp | Border Gateway Protocol | Kirk Lougheed | Kirk Lougheed | ||||||
| bgp | 179 | udp | Border Gateway Protocol | Kirk Lougheed | Kirk Lougheed | ||||||
| bgp | 179 | sctp | BGP | Randall Stewart | Randall Stewart | 2022-02-07 | RFC 9260 | ||||
| 272-279 | Unassigned | ||||||||||
| is99c | 379 | tcp | TIA/EIA/IS-99 modem client | ||||||||
| is99c | 379 | udp | TIA/EIA/IS-99 modem client | ||||||||
| iafserver | 479 | tcp | iafserver | ||||||||
| iafserver | 479 | udp | iafserver | ||||||||
| decbsrv | 579 | tcp | decbsrv | Rudi Martin | Rudi Martin | ||||||
| decbsrv | 579 | udp | decbsrv | Rudi Martin | Rudi Martin | ||||||
| mrm | 679 | tcp | MRM | Liming Wei | Liming Wei | ||||||
| mrm | 679 | udp | MRM | Liming Wei | Liming Wei | ||||||
| 778-779 | Unassigned | ||||||||||
| 788-799 | Unassigned | Unauthorized Use Known on port 796 | |||||||||
| asprovatalk | 1079 | tcp | ASPROVATalk | Chiew Farn Chung | Chiew Farn Chung | ||||||
| asprovatalk | 1079 | udp | ASPROVATalk | Chiew Farn Chung | Chiew Farn Chung | ||||||
| b2n | 1179 | tcp | Backup To Neighbor | Thomas Fok | Thomas Fok | 2004-11 | |||||
| b2n | 1179 | udp | Backup To Neighbor | Thomas Fok | Thomas Fok | 2004-11 | |||||
| dellwebadmin-2 | 1279 | tcp | Dell Web Admin 2 | Bridget Navoda | Bridget Navoda | ||||||
| dellwebadmin-2 | 1279 | udp | Dell Web Admin 2 | Bridget Navoda | Bridget Navoda | ||||||
| dbreporter | 1379 | tcp | Integrity Solutions | Tim Dawson | Tim Dawson | ||||||
| dbreporter | 1379 | udp | Integrity Solutions | Tim Dawson | Tim Dawson | ||||||
| dberegister | 1479 | tcp | dberegister | Brian Griswold | Brian Griswold | ||||||
| dberegister | 1479 | udp | dberegister | Brian Griswold | Brian Griswold | ||||||
| ioc-sea-lm | 1579 | tcp | ioc-sea-lm | Paul Nelson | Paul Nelson | ||||||
| ioc-sea-lm | 1579 | udp | ioc-sea-lm | Paul Nelson | Paul Nelson | ||||||
| darcorp-lm | 1679 | tcp | darcorp-lm | DARcorp | DARcorp | ||||||
| darcorp-lm | 1679 | udp | darcorp-lm | DARcorp | DARcorp | ||||||
| pharmasoft | 1779 | tcp | pharmasoft | Ola Strandberg | Ola Strandberg | ||||||
| pharmasoft | 1779 | udp | pharmasoft | Ola Strandberg | Ola Strandberg | ||||||
| nmsp | 1790 | tcp | Narrative Media Streaming Protocol | Paul Santinelli Jr. | Paul Santinelli Jr. | ||||||
| nmsp | 1790 | udp | Narrative Media Streaming Protocol | Paul Santinelli Jr. | Paul Santinelli Jr. | ||||||
| ea1 | 1791 | tcp | EA1 | Kirk MacLean | Kirk MacLean | ||||||
| ea1 | 1791 | udp | EA1 | Kirk MacLean | Kirk MacLean | ||||||
| ibm-dt-2 | 1792 | tcp | ibm-dt-2 | Sam Borman | Sam Borman | ||||||
| ibm-dt-2 | 1792 | udp | ibm-dt-2 | Sam Borman | Sam Borman | ||||||
| rsc-robot | 1793 | tcp | rsc-robot | Andrew Jay Schneider | Andrew Jay Schneider | ||||||
| rsc-robot | 1793 | udp | rsc-robot | Andrew Jay Schneider | Andrew Jay Schneider | ||||||
| cera-bcm | 1794 | tcp | cera-bcm | Leo Moesgaard | Leo Moesgaard | ||||||
| cera-bcm | 1794 | udp | cera-bcm | Leo Moesgaard | Leo Moesgaard | ||||||
| dpi-proxy | 1795 | tcp | dpi-proxy | Charles Gordon | Charles Gordon | ||||||
| dpi-proxy | 1795 | udp | dpi-proxy | Charles Gordon | Charles Gordon | ||||||
| vocaltec-admin | 1796 | tcp | Vocaltec Server Administration | Scott Petrack | Scott Petrack | ||||||
| vocaltec-admin | 1796 | udp | Vocaltec Server Administration | Scott Petrack | Scott Petrack | ||||||
| uma | 1797 | tcp | UMA | Martin Kirk | Martin Kirk | ||||||
| uma | 1797 | udp | UMA | Martin Kirk | Martin Kirk | ||||||
| etp | 1798 | tcp | Event Transfer Protocol | Mike Wray | Mike Wray | ||||||
| etp | 1798 | udp | Event Transfer Protocol | Mike Wray | Mike Wray | ||||||
| netrisk | 1799 | tcp | NETRISK | Kevin Green | Kevin Green | ||||||
| netrisk | 1799 | udp | NETRISK | Kevin Green | Kevin Green | ||||||
| nettgain-nms | 1879 | tcp | NettGain NMS | Dr. Yair Shapira | Dr. Yair Shapira | ||||||
| nettgain-nms | 1879 | udp | NettGain NMS | Dr. Yair Shapira | Dr. Yair Shapira | ||||||
| unisql-java | 1979 | tcp | UniSQL Java | Keith Yarbrough | Keith Yarbrough | ||||||
| unisql-java | 1979 | udp | UniSQL Java | Keith Yarbrough | Keith Yarbrough | ||||||
| idware-router | 2079 | tcp | IDWARE Router Port | Zdenek Kolba | Zdenek Kolba | ||||||
| idware-router | 2079 | udp | IDWARE Router Port | Zdenek Kolba | Zdenek Kolba | ||||||
| vmrdp | 2179 | tcp | Microsoft RDP for virtual machines | Brian Henry | Brian Henry | 2007-03 | |||||
| vmrdp | 2179 | udp | Microsoft RDP for virtual machines | Brian Henry | Brian Henry | 2007-03 | |||||
| xmquery | 2279 | tcp | xmquery | Niels Christiansen | Niels Christiansen | ||||||
| xmquery | 2279 | udp | xmquery | Niels Christiansen | Niels Christiansen | ||||||
| etcd-client | 2379 | tcp | etcd client communication | CoreOS | Brian Harrington | 2014-07-09 | |||||
| 2379 | udp | Reserved | |||||||||
| ssm-els | 2479 | tcp | SecurSight Event Logging Server (SSL) | John Linn | John Linn | ||||||
| ssm-els | 2479 | udp | SecurSight Event Logging Server (SSL) | John Linn | John Linn | ||||||
| mpfoncl | 2579 | tcp | mpfoncl | Itaru Kimura | Itaru Kimura | ||||||
| mpfoncl | 2579 | udp | mpfoncl | Itaru Kimura | Itaru Kimura | ||||||
| syncserverssl | 2679 | tcp | Sync Server SSL | Shawn Casey | Shawn Casey | ||||||
| syncserverssl | 2679 | udp | Sync Server SSL | Shawn Casey | Shawn Casey | ||||||
| lbc-sync | 2779 | tcp | LBC Sync | ||||||||
| lbc-sync | 2779 | udp | LBC Sync | ||||||||
| plgproxy | 2790 | tcp | PLG Proxy | Charlie Hava | Charlie Hava | ||||||
| plgproxy | 2790 | udp | PLG Proxy | Charlie Hava | Charlie Hava | ||||||
| mtport-regist | 2791 | tcp | MT Port Registrator | Maxim Tseitlin | Maxim Tseitlin | ||||||
| mtport-regist | 2791 | udp | MT Port Registrator | Maxim Tseitlin | Maxim Tseitlin | ||||||
| f5-globalsite | 2792 | tcp | f5-globalsite | Christian Saether | Christian Saether | ||||||
| f5-globalsite | 2792 | udp | f5-globalsite | Christian Saether | Christian Saether | ||||||
| initlsmsad | 2793 | tcp | initlsmsad | Kelly Green | Kelly Green | ||||||
| initlsmsad | 2793 | udp | initlsmsad | Kelly Green | Kelly Green | ||||||
| urp | 2794 | tcp | Uniform Resource Platform | Liu Hongyan | Han Yingying | 2024-11-26 | |||||
| urp | 2794 | udp | Uniform Resource Platform | Liu Hongyan | Han Yingying | 2024-11-26 | |||||
| livestats | 2795 | tcp | LiveStats | Chris Greene | Chris Greene | ||||||
| livestats | 2795 | udp | LiveStats | Chris Greene | Chris Greene | ||||||
| ac-tech | 2796 | tcp | ac-tech | Chiming Huang | Chiming Huang | ||||||
| ac-tech | 2796 | udp | ac-tech | Chiming Huang | Chiming Huang | ||||||
| esp-encap | 2797 | tcp | esp-encap | Jorn Sierwald | Jorn Sierwald | ||||||
| esp-encap | 2797 | udp | esp-encap | Jorn Sierwald | Jorn Sierwald | ||||||
| tmesis-upshot | 2798 | tcp | TMESIS-UPShot | Brian Schenkenberger | Brian Schenkenberger | ||||||
| tmesis-upshot | 2798 | udp | TMESIS-UPShot | Brian Schenkenberger | Brian Schenkenberger | ||||||
| icon-discover | 2799 | tcp | ICON Discover | Alexander Falk | Alexander Falk | ||||||
| icon-discover | 2799 | udp | ICON Discover | Alexander Falk | Alexander Falk | ||||||
| ucentric-ds | 2879 | tcp | ucentric-ds | Alex Vasilevsky | Alex Vasilevsky | ||||||
| ucentric-ds | 2879 | udp | ucentric-ds | Alex Vasilevsky | Alex Vasilevsky | ||||||
| h263-video | 2979 | tcp | H.263 Video Streaming | Jauvane C. de Oliveira | Jauvane C. de Oliveira | ||||||
| h263-video | 2979 | udp | H.263 Video Streaming | Jauvane C. de Oliveira | Jauvane C. de Oliveira | ||||||
| lv-frontpanel | 3079 | tcp | LV Front Panel | Darshan Shah | Darshan Shah | ||||||
| lv-frontpanel | 3079 | udp | LV Front Panel | Darshan Shah | Darshan Shah | ||||||
| h2gf-w-2m | 3179 | tcp | H2GF W.2m Handover prot. | Arne Norefors | Arne Norefors | ||||||
| h2gf-w-2m | 3179 | udp | H2GF W.2m Handover prot. | Arne Norefors | Arne Norefors |