Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ipp 631 tcp IPP (Internet Printing Protocol) [IESG] [IETF_Chair] 2018-07-06 [RFC 8011] Defined TXT keys: See BonjourPrinting.pdf.
ipp 631 udp IPP (Internet Printing Protocol) [IESG] [IETF_Chair] 2018-07-06 [RFC 8011] Defined TXT keys: See BonjourPrinting.pdf.
ipps 631 tcp Internet Printing Protocol over HTTPS [IESG] [IETF_Chair] 2018-07-06 [RFC 8011]
device 801 tcp
device 801 udp
msmq 1801 tcp Microsoft Message Que [Amnon_Horowitz] [Amnon_Horowitz]
msmq 1801 udp Microsoft Message Que [Amnon_Horowitz] [Amnon_Horowitz]
igcp 2801 tcp IGCP [David_Hampson] [David_Hampson]
igcp 2801 udp IGCP [David_Hampson] [David_Hampson]
ibm-mgr 3801 tcp ibm manager service [Tim_Hahn] [Tim_Hahn] 2006-03
ibm-mgr 3801 udp ibm manager service [Tim_Hahn] [Tim_Hahn] 2006-03
iwec 4801 tcp Icona Web Embedded Chat
iwec 4801 udp Icona Web Embedded Chat
acnet 6801 tcp ACNET Control System Protocol [Fermilab] [Rich_Neswold] 2007-02 2017-07-13
acnet 6801 udp ACNET Control System Protocol [Fermilab] [Rich_Neswold] 2007-02 2017-07-13
ssp-client 7801 tcp Secure Server Protocol - client [Rick_Macchio] [Rick_Macchio] 2006-11
ssp-client 7801 udp Secure Server Protocol - client [Rick_Macchio] [Rick_Macchio] 2006-11
8010 Reserved 2018-01-09 yes
8011-8014 Unassigned
cfg-cloud 8015 tcp Configuration Cloud Service [admin_at_cfg_cloud] [Goksel_Darcan] 2019-01-09
8015 udp Reserved
ads-s 8016 tcp Beckhoff Automation Device Specification [Beckhoff_Automation_GmbH_Co_KG] [Henning_Mersch] 2019-02-28
8016 udp Reserved
8017 tcp Reserved
cisco-cloudsec 8017 udp Cisco Cloudsec Dataplane Port Number [Cisco_Systems_Inc] [Govind_Sharma] 2021-03-18
8018 Unassigned
qbdb 8019 tcp QB DB Dynamic Port [Sridhar_Krishnamurth] [Sridhar_Krishnamurth] 2008-02-15
qbdb 8019 udp QB DB Dynamic Port [Sridhar_Krishnamurth] [Sridhar_Krishnamurth] 2008-02-15
8801-8803 Unassigned Known UNAUTHORIZED USE: Port 8801
sstp-2 9801 tcp Sakura Script Transfer Protocol-2 [Kouichi_Takeda_2] [Kouichi_Takeda_2]
sstp-2 9801 udp Sakura Script Transfer Protocol-2 [Kouichi_Takeda_2] [Kouichi_Takeda_2]
10801-10804 Unassigned
sal 21801 tcp Safe AutoLogon [WM_Software_Inc.] [WM_Software_Inc.] 2022-07-05 2022-07-06
22801-22950 Unassigned
gruber-cashreg 28010 tcp Gruber cash registry protocol [Gruber_Schanksysteme] [Clemens_Gruber] 2019-12-31
28010 udp Reserved
28011-28079 Unassigned Unauthorized Use Known on ports 28017, 28018 and 28019
mlsn 32801 tcp Multiple Listing Service Network [Corey_Leong] [Corey_Leong] 2010-10-11
mlsn 32801 udp Multiple Listing Service Network [Corey_Leong] [Corey_Leong] 2010-10-11
38801-38864 Unassigned

Contact Information

ID Name Organization Contact URI Last Updated
[admin_at_cfg_cloud] admin_at_cfg_cloud mailto:gdarcan&gmail.com 2019-01-09
[Amnon_Horowitz] Amnon Horowitz mailto:amnonh&microsoft.com
[Beckhoff_Automation_GmbH_Co_KG] Beckhoff Automation GmbH & Co. KG mailto:legal&beckhoff.com 2019-02-28
[Cisco_Systems_Inc] Cisco Systems, Inc. mailto:gosharma&cisco.com 2021-03-18
[Clemens_Gruber] Clemens Gruber mailto:iana&pqgruber.com 2019-12-31
[Corey_Leong] Corey Leong mailto:cleong&gr8c.org 2010-10-11
[David_Hampson] David Hampson mailto:davidha&codemasters.com
[Fermilab] Fermilab mailto:neswold&fnal.gov 2017-07-13
[Goksel_Darcan] Goksel Darcan mailto:gdarcan&gmail.com 2019-01-09
[Govind_Sharma] Govind Sharma Cisco Systems, Inc. mailto:gosharma&cisco.com 2021-03-18
[Gruber_Schanksysteme] Gruber Schanksysteme mailto:iana&pqgruber.com 2019-12-31
[Henning_Mersch] Henning Mersch mailto:support&beckhoff.com 2019-02-28
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Kouichi_Takeda_2] Kouichi Takeda mailto:KHB05271&nifty.com
[Rich_Neswold] Rich Neswold mailto:neswold&fnal.gov 2007-02
[Rick_Macchio] Rick Macchio mailto:rmacchio&juniper.net 2006-11
[Sridhar_Krishnamurth] Sridhar Krishnamurthy mailto:Sridhar_Krishnamurthy&intuit.com 2008-02-15
[Tim_Hahn] Tim Hahn mailto:hahnt&us.ibm.com 2006-03
[WM_Software_Inc.] WM Software Inc. mailto:support&wmsoftware.com 2022-07-18