Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| mbap-s | 802 | tcp | Modbus Application Protocol Secure | modbus.org | Dennis Dube | 2014-06-10 | |||||
| mbap-s | 802 | udp | Modbus Application Protocol Secure | modbus.org | Dennis Dube | 2014-06-10 | |||||
| concomp1 | 1802 | tcp | ConComp1 | Ed Vincent | Ed Vincent | ||||||
| concomp1 | 1802 | udp | ConComp1 | Ed Vincent | Ed Vincent | ||||||
| veritas-tcp1 | 2802 | tcp | Veritas TCP1 | ||||||||
| veritas-udp1 | 2802 | udp | Veritas UDP1 | Russ Thrasher | Russ Thrasher | ||||||
| lsp-ping | 3503 | tcp | MPLS LSP-echo Port | RFC 8029 | |||||||
| lsp-ping | 3503 | udp | MPLS LSP-echo Port | RFC 8029 | |||||||
| 802-11-iapp | 3517 | tcp | IEEE 802.11 WLANs WG IAPP | Stuart J. Kerry | Stuart J. Kerry | 2002-05 | |||||
| 802-11-iapp | 3517 | udp | IEEE 802.11 WLANs WG IAPP | Stuart J. Kerry | Stuart J. Kerry | 2002-05 | |||||
| vhd | 3802 | tcp | VHD | Chris Duncombe | Chris Duncombe | ||||||
| vhd | 3802 | udp | VHD | Chris Duncombe | Chris Duncombe | ||||||
| ilss | 4802 | tcp | Icona License System Server | Paul Stephen Borlie | Paul Stephen Borlie | ||||||
| ilss | 4802 | udp | Icona License System Server | Paul Stephen Borlie | Paul Stephen Borlie | ||||||
| 6802-6816 | Unassigned | ||||||||||
| vns-tp | 7802 | udp | Virtualized Network Services Tunnel Protocol | Juniper Networks | Bruno Rijsman | 2013-02-01 | |||||
| 7802 | tcp | Reserved | |||||||||
| intu-ec-svcdisc | 8020 | tcp | Intuit Entitlement Service and Discovery | Daniel C. McGloin | Daniel C. McGloin | 2005-05 | |||||
| intu-ec-svcdisc | 8020 | udp | Intuit Entitlement Service and Discovery | Daniel C. McGloin | Daniel C. McGloin | 2005-05 | |||||
| intu-ec-client | 8021 | tcp | Intuit Entitlement Client | Daniel C. McGloin | Daniel C. McGloin | 2005-05 | |||||
| intu-ec-client | 8021 | udp | Intuit Entitlement Client | Daniel C. McGloin | Daniel C. McGloin | 2005-05 | |||||
| oa-system | 8022 | tcp | oa-system | Marie-France Dubreuil | Marie-France Dubreuil | ||||||
| oa-system | 8022 | udp | oa-system | Marie-France Dubreuil | Marie-France Dubreuil | ||||||
| arca-api | 8023 | tcp | ARCATrust vault API | ARCATrust SA | Yacince Felk | 2018-07-05 | |||||
| arca-api | 8023 | udp | ARCATrust vault API | ARCATrust SA | Yacince Felk | 2018-07-05 | |||||
| 8024 | Unassigned | ||||||||||
| ca-audit-da | 8025 | tcp | CA Audit Distribution Agent | Henning Smith | Henning Smith | 2006-07 | |||||
| ca-audit-da | 8025 | udp | CA Audit Distribution Agent | Henning Smith | Henning Smith | 2006-07 | |||||
| ca-audit-ds | 8026 | tcp | CA Audit Distribution Server | Henning Smith | Henning Smith | 2006-07 | |||||
| ca-audit-ds | 8026 | udp | CA Audit Distribution Server | Henning Smith | Henning Smith | 2006-07 | |||||
| papachi-p2p-srv | 8027 | tcp | peer tracker and data relay service | Pavel Csefalvay | Pavel Csefalvay | 2020-09-18 | |||||
| papachi-p2p-srv | 8027 | udp | peer tracker and data relay service | Pavel Csefalvay | Pavel Csefalvay | 2020-09-18 | |||||
| 8028-8031 | Unassigned | ||||||||||
| davsrcs | 9802 | tcp | WebDAV Source TLS/SSL | Rob Isaac | Rob Isaac | 2003-07 | |||||
| davsrcs | 9802 | udp | WebDAV Source TLS/SSL | Rob Isaac | Rob Isaac | 2003-07 | |||||
| 21802-21844 | Unassigned | ||||||||||
| 32802-32810 | Unassigned | ||||||||||
| ip-ieee | Internet Protocol on IEEE 802 | ||||||||||
| ip-ipx | Transmission of 802.2 over IPX Networks |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| ARCATrust SA | info&arcatrust.io | 2018-07-05 | |
| Bruno Rijsman | Juniper Networks | brijsman&juniper.net | 2013-02-01 |
| Chris Duncombe | cduncombe&atpeng.com | 2022-03-25 | |
| Daniel C. McGloin | daniel_mcgloin&intuit.com | 2005-05 | |
| Dennis Dube | dennis.dube&schneider-electric.com | 2014-06-10 | |
| Ed Vincent | edv&concomp.com | ||
| Henning Smith | henning.smith&ca.com | 2006-07 | |
| Juniper Networks | brijsman&juniper.net | 2013-02-01 | |
| Marie-France Dubreuil | Marie-France.Dubreuil&evidian.com | 2002-11 | |
| modbus.org | rbelliardi&modbus.org | 2014-06-10 | |
| Paul Stephen Borlie | paul&icona.it | ||
| Pavel Csefalvay | csefalvay&gmail.com | 2020-09-18 | |
| Rob Isaac | rob&automagic.org | 2003-07 | |
| Russ Thrasher | Russell.Thrasher&veritas.com | ||
| Stuart J. Kerry | Chair IEEE 802.11 WG | stuart&ok-brit.com | 2002-05 |
| Yacince Felk | yacine&arcatrust.io | 2018-07-05 |