Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-04

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
81 Unassigned 2007-09-06
unify 181 tcp Unify Daegis, Inc. Chris Anderson 2012-07-31
unify 181 udp Unify Daegis, Inc. Chris Anderson 2012-07-31
personal-link 281 tcp Personal Link Dan Cummings Dan Cummings
personal-link 281 udp Personal Link Dan Cummings Dan Cummings
rpki-rtr 323 tcp Resource PKI to Router Protocol IESG IETF Chair RFC 6810
rpki-rtr-tls 324 tcp Resource PKI to Router Protocol over TLS IESG IETF Chair RFC 6810
hp-collector 381 tcp hp performance data collector
hp-collector 381 udp hp performance data collector
ph 481 tcp Ph service Roland Hedberg Roland Hedberg
ph 481 udp Ph service Roland Hedberg Roland Hedberg
bdp 581 tcp Bundle Discovery Protocol Gary Malkin Gary Malkin
bdp 581 udp Bundle Discovery Protocol Gary Malkin Gary Malkin
dhcp-failover 647 tcp DHCP Failover IESG IETF Chair 2018-05-21 RFC 8156
entrust-aams 681 tcp entrust-aams Adrian Mancini Adrian Mancini
entrust-aams 681 udp entrust-aams Adrian Mancini Adrian Mancini
781-785 Unassigned
fcp-udp 810 tcp FCP Paul Whittemore Paul Whittemore
fcp-udp 810 udp FCP Datagram Paul Whittemore Paul Whittemore
811-827 Unassigned
dlep 854 tcp Dynamic Link Exchange Protocol (DLEP) IESG IETF Chair 2017-04-03 RFC 8175
dlep 854 udp Dynamic Link Exchange Protocol (DLEP) IESG IETF Chair 2017-04-03 RFC 8175
pvuniwien 1081 tcp PVUNIWIEN Peter Lipp Peter Lipp
pvuniwien 1081 udp PVUNIWIEN Peter Lipp Peter Lipp
3comnetman 1181 tcp 3Com Net Management Peter White Peter White 2004-11
3comnetman 1181 udp 3Com Net Management Peter White Peter White 2004-11
healthd 1281 tcp healthd James E. Housley James E. Housley
healthd 1281 udp healthd James E. Housley James E. Housley
apple-licman 1381 tcp Apple Network License Manager Earl Wallace Earl Wallace
apple-licman 1381 udp Apple Network License Manager Earl Wallace Earl Wallace
airs 1481 tcp AIRS Bruce Wilson Bruce Wilson
airs 1481 udp AIRS Bruce Wilson Bruce Wilson
mil-2045-47001 1581 tcp MIL-2045-47001 Eric Whitehill Eric Whitehill
mil-2045-47001 1581 udp MIL-2045-47001 Eric Whitehill Eric Whitehill
sd-elmd 1681 tcp sd-elmd Bryan Otey Bryan Otey
sd-elmd 1681 udp sd-elmd Bryan Otey Bryan Otey
answersoft-lm 1781 tcp answersoft-lm James A. Brewster James A. Brewster
answersoft-lm 1781 udp answersoft-lm James A. Brewster James A. Brewster
jerand-lm 1810 tcp Jerand License Manager Robert Monat Robert Monat
jerand-lm 1810 udp Jerand License Manager Robert Monat Robert Monat
scientia-sdb 1811 tcp Scientia-SDB SYSTEMS MANAGER SYSTEMS MANAGER
scientia-sdb 1811 udp Scientia-SDB SYSTEMS MANAGER SYSTEMS MANAGER
radius 1812 tcp RADIUS RFC 2865
radius 1812 udp RADIUS RFC 2865
radius-acct 1813 tcp RADIUS Accounting RFC 2866
radius-acct 1813 udp RADIUS Accounting RFC 2866
tdp-suite 1814 tcp TDP Suite Rob Lockhart Rob Lockhart
tdp-suite 1814 udp TDP Suite Rob Lockhart Rob Lockhart
mmpft 1815 tcp Manufacturing messaging protocol for factory transmission Ralf Muckenhirn Ralf Muckenhirn 2024-06-12
mmpft 1815 udp Manufacturing messaging protocol for factory transmission Ralf Muckenhirn Ralf Muckenhirn 2024-06-12
harp 1816 tcp HARP Bjorn Chambless Bjorn Chambless
harp 1816 udp HARP Bjorn Chambless Bjorn Chambless
rkb-oscs 1817 tcp RKB-OSCS Robert Kevin Breton Robert Kevin Breton
rkb-oscs 1817 udp RKB-OSCS Robert Kevin Breton Robert Kevin Breton
etftp 1818 tcp Enhanced Trivial File Transfer Protocol William Polites William Polites
etftp 1818 udp Enhanced Trivial File Transfer Protocol William Polites William Polites
plato-lm 1819 tcp Plato License Manager Mark Morris Mark Morris
plato-lm 1819 udp Plato License Manager Mark Morris Mark Morris
ibm-mqseries2 1881 tcp IBM WebSphere MQ Everyplace Jane Porter Jane Porter
ibm-mqseries2 1881 udp IBM WebSphere MQ Everyplace Jane Porter Jane Porter
p2pq 1981 tcp p2pQ Warren Alexander Warren Alexander
p2pq 1981 udp p2pQ Warren Alexander Warren Alexander
hsrp 1985 tcp Hot Standby Router Protocol RFC 2281
hsrp 1985 udp Hot Standby Router Protocol RFC 2281
kme-trap-port 2081 tcp KME PRINTER TRAP PORT Masakatsu Matsuo Masakatsu Matsuo
kme-trap-port 2081 udp KME PRINTER TRAP PORT Masakatsu Matsuo Masakatsu Matsuo
eforward 2181 tcp eforward Greg Pringle Greg Pringle
eforward 2181 udp eforward Greg Pringle Greg Pringle
lnvconsole 2281 tcp LNVCONSOLE
lnvconsole 2281 udp LNVCONSOLE
compaq-https 2381 tcp Compaq HTTPS Scott Shaffer Scott Shaffer
compaq-https 2381 udp Compaq HTTPS Scott Shaffer Scott Shaffer
giop 2481 tcp Oracle GIOP
giop 2481 udp Oracle GIOP
argis-te 2581 tcp ARGIS TE
argis-te 2581 udp ARGIS TE
gbjd816 2626 tcp gbjd816 George Balesta George Balesta
gbjd816 2626 udp gbjd816 George Balesta George Balesta
mpnjsomb 2681 tcp mpnjsomb Takenori Miyahara Takenori Miyahara
mpnjsomb 2681 udp mpnjsomb Takenori Miyahara Takenori Miyahara
whosells 2781 tcp whosells William Randolph Royere III William Randolph Royere III
whosells 2781 udp whosells William Randolph Royere III William Randolph Royere III
netsteward 2810 tcp Active Net Steward Keith Morley Keith Morley
netsteward 2810 udp Active Net Steward Keith Morley Keith Morley
gsiftp 2811 tcp GSI FTP Von Welch Von Welch
gsiftp 2811 udp GSI FTP Von Welch Von Welch
atmtcp 2812 tcp atmtcp Werner Almesberger Werner Almesberger
atmtcp 2812 udp atmtcp Werner Almesberger Werner Almesberger
llm-pass 2813 tcp llm-pass Loftware Glen Sansoucie 2020-07-20
llm-pass 2813 udp llm-pass Loftware Glen Sansoucie 2020-07-20
llm-csv 2814 tcp llm-csv Loftware Glen Sansoucie 2020-07-20
llm-csv 2814 udp llm-csv Loftware Glen Sansoucie 2020-07-20
lbc-measure 2815 tcp LBC Measurement
lbc-measure 2815 udp LBC Measurement
lbc-watchdog 2816 tcp LBC Watchdog Akiyoshi Ochi Akiyoshi Ochi
lbc-watchdog 2816 udp LBC Watchdog Akiyoshi Ochi Akiyoshi Ochi
nmsigport 2817 tcp NMSig Port Peter Egli Peter Egli
nmsigport 2817 udp NMSig Port Peter Egli Peter Egli
rmlnk 2818 tcp rmlnk
rmlnk 2818 udp rmlnk

Contact Information

Name Organization Contact URI Last Updated
Adrian Mancini adrian.mancini&entrust.com
Akiyoshi Ochi akiyoshi&net.paso.fujitsu.co.jp
Bjorn Chambless bjorn&cs.pdx.edu
Bruce Wilson tel:+1-905-771-6161
Bryan Otey bwo&softdesk.com
Chris Anderson Daegis, Inc. ianaportmaster&daegis.com 2012-07-31
Daegis, Inc. ianaportmaster&daegis.com 2012-07-31
Dan Cummings doc&cnr.com
Earl Wallace earlw&apple.com
Eric Whitehill Eric.Whitehill&itt.com
Gary Malkin gmalkin&xylogics.com
George Balesta George.Baletsa&tfn.com
Glen Sansoucie Loftware gsansoucie&loftware.com 2020-07-20
Greg Pringle gpringle&corvedia.com 2019-01-25
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
James A. Brewster jimbrew&answersoft.com
James E. Housley jim&thehousleys.net
Jane Porter janeporter&uk.ibm.com
Keith Morley keith&ndl.co.uk
Loftware gsansoucie&loftware.com 2020-07-20
Mark Morris mim&ermuk.com
Masakatsu Matsuo masa&sdsft.kme.mei.co.jp
Paul Whittemore paul&softarc.com
Peter Egli peter.egli&mail.inalp.com
Peter Lipp Peter.Lipp&iaik.at
Peter White peter_white&3com.com 2004-11
Ralf Muckenhirn info&muckenhirn.net 2024-06-11
Rob Lockhart rob.lockhart&mot.com
Robert Kevin Breton BOBBRETON&hotmail.com
Robert Monat jerand&jerand.com
Roland Hedberg Roland.Hedberg&umdac.umu.se
SYSTEMS MANAGER systems-manager&scientia.com
Scott Shaffer scott.shaffer&hp.com
Takenori Miyahara miyahara&pfu.co.jp
Von Welch vwelch&ncsa.uiuc.edu
Warren Alexander warren&chameleon-creative.co.uk
Werner Almesberger Werner.Almesberger&epfl.ch
William Polites wpolites&mitre.org
William Randolph Royere III william&royere.net