Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dhcp-failover2 847 tcp dhcp-failover 2 Bernard Volz Bernard Volz
dhcp-failover2 847 udp dhcp-failover 2 Bernard Volz Bernard Volz
slp-notify 1847 tcp SLP Notification RFC 3082
slp-notify 1847 udp SLP Notification RFC 3082
aimpp-port-req 2847 tcp AIMPP Port Req Brian Martinicky Brian Martinicky
aimpp-port-req 2847 udp AIMPP Port Req Brian Martinicky Brian Martinicky
msfw-control 3847 tcp MS Firewall Control Oren Trutner Oren Trutner 2003-08
msfw-control 3847 udp MS Firewall Control Oren Trutner Oren Trutner 2003-08
wfc 4847 tcp Web Fresh Communication Jonathan Bastnagel Jonathan Bastnagel 2007-09-17
wfc 4847 udp Web Fresh Communication Jonathan Bastnagel Jonathan Bastnagel 2007-09-17
csoauth 7847 tcp A product key authentication protocol made by CSO Jeff Wamsley Jacob Kiesel 2013-09-04
7847 udp Reserved
cisco-avp 8470 tcp Cisco Address Validation Protocol Cullen Jennings Cullen Jennings 2009-02-13
8470 udp Reserved
pim-port 8471 tcp PIM over Reliable Transport IESG IETF Chair 2008-08-21 RFC 6559
pim-port 8471 sctp PIM over Reliable Transport IESG IETF Chair 2008-08-21 RFC 6559
8471 udp Reserved
otv 8472 tcp Overlay Transport Virtualization (OTV) Dino Farinacci Dino Farinacci 2008-01-07
otv 8472 udp Overlay Transport Virtualization (OTV) Dino Farinacci Dino Farinacci 2008-01-07
vp2p 8473 tcp Virtual Point to Point Jerome Grimbert Jerome Grimbert
vp2p 8473 udp Virtual Point to Point Jerome Grimbert Jerome Grimbert
noteshare 8474 tcp AquaMinds NoteShare Michael McNabb Michael McNabb 2005-10
noteshare 8474 udp AquaMinds NoteShare Michael McNabb Michael McNabb 2005-10
8475-8499 Unassigned
netspeak-cs 21847 tcp NetSpeak Corp. Connection Services Toby Hosterman Toby Hosterman
netspeak-cs 21847 udp NetSpeak Corp. Connection Services Toby Hosterman Toby Hosterman
38463-38471 Unassigned
38472 tcp Reserved
38472 udp Reserved
f1-control 38472 sctp F1 Control Plane (3GPP) Luis Lopes Luis Lopes 2017-06-23
38473-38637 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Bernard Volz bevolz&gmail.com 2022-08-03
Brian Martinicky Brian_Martinicky&automationintelligence.com
Cullen Jennings fluffy&cisco.com 2010-02-03
Dino Farinacci dino&cisco.com 2008-08-21
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jacob Kiesel gocso.net jake.k&gocso.net 2013-09-04
Jeff Wamsley gocso.net jeffw&gocso.net 2013-09-04
Jerome Grimbert jerome.grimbert&atosorigin.com
Jonathan Bastnagel jonthebagel&gmail.com 2007-09-17
Luis Lopes llopes&qti.qualcomm.com 2017-06-23
Michael McNabb michael&aquaminds.com 2005-10
Oren Trutner orentrut&microsoft.com 2003-08
Toby Hosterman root&netspeak.com