Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
gdoi 848 tcp GDOI RFC 3547
gdoi 848 udp GDOI RFC 3547
fjdocdist 1848 tcp fjdocdist Yuichi Ohiwa Yuichi Ohiwa
fjdocdist 1848 udp fjdocdist Yuichi Ohiwa Yuichi Ohiwa
amt-blc-port 2848 tcp AMT-BLC-PORT Sandra Frulloni Sandra Frulloni
amt-blc-port 2848 udp AMT-BLC-PORT Sandra Frulloni Sandra Frulloni
stun 3478 tcp Session Traversal Utilities for NAT (STUN) port IESG IETF Chair 2019-03-28 RFC 8489
stun 3478 udp Session Traversal Utilities for NAT (STUN) port IESG IETF Chair 2019-03-28 RFC 8489
item 3848 tcp IT Environmental Monitor Keith Wright Keith Wright 2003-08
item 3848 udp IT Environmental Monitor Keith Wright Keith Wright 2003-08
appserv-http 4848 tcp App Server - Admin HTTP
appserv-http 4848 udp App Server - Admin HTTP
stuns 5349 tcp Session Traversal Utilities for NAT (STUN) port IESG IETF Chair 2019-03-28 RFC 8489
7848-7868 Unassigned
netspeak-acd 21848 tcp NetSpeak Corp. Automatic Call Distribution Toby Hosterman Toby Hosterman
netspeak-acd 21848 udp NetSpeak Corp. Automatic Call Distribution Toby Hosterman Toby Hosterman
mtrace 33435 udp IP Multicast Traceroute IESG IETF Chair 2017-12-13 2019-08-09 RFC 8487 Known Unauthorized Use on port 33435

Contact Information

Name Organization Contact URI Last Updated
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Keith Wright kwright&sensatronics.com 2003-08
Sandra Frulloni frulloni.amtec&interbusiness.it
Toby Hosterman root&netspeak.com
Yuichi Ohiwa y-ohiwa&ael.fujitsu.co.jp