Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
discard 9 tcp Discard Jon Postel Jon Postel
discard 9 udp Discard Jon Postel Jon Postel
discard 9 sctp Discard Randall Stewart Randall Stewart 2022-02-07 RFC 9260
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
chargen 19 tcp Character Generator
chargen 19 udp Character Generator
ftp-data 20 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
ftp 21 tcp File Transfer Protocol [Control] Jon Postel Jon Postel RFC 959 Defined TXT keys: u=<username> p=<password> path=<path>
ftp 21 udp File Transfer Protocol [Control] Jon Postel Jon Postel RFC 959 Defined TXT keys: u=<username> p=<password> path=<path>
ftp 21 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path>
ssh 22 sctp SSH Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password>
msg-icp 29 tcp MSG ICP Robert Thomas Robert Thomas
msg-icp 29 udp MSG ICP Robert Thomas Robert Thomas
rlp 39 tcp Resource Location Protocol Mike Accetta Mike Accetta
rlp 39 udp Resource Location Protocol Mike Accetta Mike Accetta
tacacs 49 tcp Login Host Protocol (TACACS) Pieter Ditmars Pieter Ditmars
tacacs 49 udp Login Host Protocol (TACACS) Pieter Ditmars Pieter Ditmars
59 tcp any private file service Jon Postel Jon Postel
59 udp any private file service Jon Postel Jon Postel
bootps 67 tcp Bootstrap Protocol Server Bill Croft Bill Croft RFC 951 Defined TXT keys: None
tftp 69 tcp Trivial File Transfer David Clark David Clark
tftp 69 udp Trivial File Transfer David Clark David Clark
finger 79 tcp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
finger 79 udp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
http 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
http 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
www 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
http 80 sctp HTTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path to document>
su-mit-tg 89 tcp SU/MIT Telnet Gateway Mark Crispin Mark Crispin
su-mit-tg 89 udp SU/MIT Telnet Gateway Mark Crispin Mark Crispin
dnsix 90 tcp DNSIX Securit Attribute Token Map Charles Watt Charles Watt PORT 90 also being used unofficially by Pointcast
dnsix 90 udp DNSIX Securit Attribute Token Map Charles Watt Charles Watt PORT 90 also being used unofficially by Pointcast
mit-dov 91 tcp MIT Dover Spooler Eliot Moss Eliot Moss
mit-dov 91 udp MIT Dover Spooler Eliot Moss Eliot Moss
npp 92 tcp Network Printing Protocol Louis Mamakos Louis Mamakos
npp 92 udp Network Printing Protocol Louis Mamakos Louis Mamakos
dcp 93 tcp Device Control Protocol Daniel Tappan Daniel Tappan
dcp 93 udp Device Control Protocol Daniel Tappan Daniel Tappan
objcall 94 tcp Tivoli Object Dispatcher Tom Bereiter Tom Bereiter
objcall 94 udp Tivoli Object Dispatcher Tom Bereiter Tom Bereiter
supdup 95 tcp SUPDUP Mark Crispin Mark Crispin
supdup 95 udp SUPDUP Mark Crispin Mark Crispin
dixie 96 tcp DIXIE Protocol Specification Tim Howes Tim Howes
dixie 96 udp DIXIE Protocol Specification Tim Howes Tim Howes
swift-rvf 97 tcp Swift Remote Virtural File Protocol Maurice R. Turcotte Maurice R. Turcotte
swift-rvf 97 udp Swift Remote Virtural File Protocol Maurice R. Turcotte Maurice R. Turcotte
tacnews 98 tcp TAC News Jon Postel Jon Postel
tacnews 98 udp TAC News Jon Postel Jon Postel
metagram 99 tcp Metagram Relay Geoff Goodfellow Geoff Goodfellow
metagram 99 udp Metagram Relay Geoff Goodfellow Geoff Goodfellow
pop2 109 tcp Post Office Protocol - Version 2 Joyce K. Reynolds Joyce K. Reynolds
pop2 109 udp Post Office Protocol - Version 2 Joyce K. Reynolds Joyce K. Reynolds
nntp 119 tcp Network News Transfer Protocol IESG IETF Chair 2018-07-06 RFC 3977
nntp 119 udp Network News Transfer Protocol IESG IETF Chair 2018-07-06 RFC 3977
ntp 123 tcp Network Time Protocol Dave Mills Dave Mills RFC 5905
ntp 123 udp Network Time Protocol Dave Mills Dave Mills RFC 5905
pwdgen 129 tcp Password Generator Protocol Frank J. Wacho Frank J. Wacho
pwdgen 129 udp Password Generator Protocol Frank J. Wacho Frank J. Wacho
netbios-ssn 139 tcp NETBIOS Session Service Jon Postel Jon Postel
netbios-ssn 139 udp NETBIOS Session Service Jon Postel Jon Postel
imap 143 tcp Internet Message Access Protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 9051
143 udp Reserved 2021-02-22 RFC 9051
aed-512 149 tcp AED 512 Emulation Service Albert G. Broscius Albert G. Broscius
aed-512 149 udp AED 512 Emulation Service Albert G. Broscius Albert G. Broscius
nss-routing 159 tcp NSS-Routing Yakov Rekhter Yakov Rekhter
nss-routing 159 udp NSS-Routing Yakov Rekhter Yakov Rekhter
send 169 tcp SEND William Oldwin William Oldwin 2019-04-22
send 169 udp SEND William Oldwin William Oldwin 2019-04-22
bgp 179 tcp Border Gateway Protocol Kirk Lougheed Kirk Lougheed
bgp 179 udp Border Gateway Protocol Kirk Lougheed Kirk Lougheed
bgp 179 sctp BGP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
qft 189 tcp Queued File Transport Wayne Schroeder Wayne Schroeder
qft 189 udp Queued File Transport Wayne Schroeder Wayne Schroeder
gacp 190 tcp Gateway Access Control Protocol C. Philip Wood C. Philip Wood
gacp 190 udp Gateway Access Control Protocol C. Philip Wood C. Philip Wood
prospero 191 tcp Prospero Directory Service B. Clifford Neuman B. Clifford Neuman
prospero 191 udp Prospero Directory Service B. Clifford Neuman B. Clifford Neuman
osu-nms 192 tcp OSU Network Monitoring System Doug Karl Doug Karl
osu-nms 192 udp OSU Network Monitoring System Doug Karl Doug Karl
srmp 193 tcp Spider Remote Monitoring Protocol Ted J. Socolofsky Ted J. Socolofsky
srmp 193 udp Spider Remote Monitoring Protocol Ted J. Socolofsky Ted J. Socolofsky
irc 194 tcp Internet Relay Chat Protocol Jarkko Oikarinen Jarkko Oikarinen
irc 194 udp Internet Relay Chat Protocol Jarkko Oikarinen Jarkko Oikarinen
dn6-nlm-aud 195 tcp DNSIX Network Level Module Audit
dn6-nlm-aud 195 udp DNSIX Network Level Module Audit
dn6-smm-red 196 tcp DNSIX Session Mgt Module Audit Redir Lawrence Lebahn Lawrence Lebahn
dn6-smm-red 196 udp DNSIX Session Mgt Module Audit Redir Lawrence Lebahn Lawrence Lebahn
dls 197 tcp Directory Location Service
dls 197 udp Directory Location Service
dls-mon 198 tcp Directory Location Service Monitor Scott Bellew Scott Bellew
dls-mon 198 udp Directory Location Service Monitor Scott Bellew Scott Bellew
smux 199 tcp SMUX Marshall Rose Marshall Rose
smux 199 udp SMUX Marshall Rose Marshall Rose
qmtp 209 tcp The Quick Mail Transfer Protocol D. J. Bernstein D. J. Bernstein 2018-04-05
qmtp 209 udp The Quick Mail Transfer Protocol D. J. Bernstein D. J. Bernstein 2018-04-05
z39-50 210 tcp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 tcp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
z39-50 210 udp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 udp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.

Contact Information

Name Organization Contact URI Last Updated
Albert G. Broscius broscius&dsl.cis.upenn.edu
B. Clifford Neuman bcn&isi.edu 2022-02-18
Bill Croft Croft&sumex-aim.stanford.edu
C. Philip Wood cpw&lanl.gov
Charles Watt watt&sware.com
D. J. Bernstein ports&box.cr.yp.to 2018-04-05
Daniel Tappan Tappan&bbn.com
Dave Mills mills&udel.edu 2022-06-03
David Clark ddc&lcs.mit.edu
David Zimmerman dpz&rutgers.edu
Doug Karl KARL-D&osu-20.ircc.ohio-state.edu
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Eliot Moss EBM&xx.lcs.mit.edu
Frank J. Wacho WANCHO&wsmr-simtel20.army.mil
Geoff Goodfellow Geoff&fernwood.mpk.ca.us
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jarkko Oikarinen jto&tolsun.oulu.fi
Jon Postel postel&isi.edu
Joyce K. Reynolds jkrey&isi.edu
Kirk Lougheed LOUGHEED&mathom.cisco.com
Lawrence Lebahn DIA3&paxrv-nes.navy.mil
Louis Mamakos louie&sayshell.umd.edu
Mark Crispin MRC&panda.com
Mark H. Needleman markn&sirsi.com
Marshall Rose mrose17&gmail.com 2024-07-29
Maurice R. Turcotte mailrus!uflorida!rm1!dnmrt%25rmatl@uunet.uu.net
Mike Accetta MIKE.ACCETTA&cmu-cs-a.edu
Pieter Ditmars pditmars&bbn.com
Randall Stewart IETF TSVWG rrs&lakerest.net
Robert Thomas BThomas&f.bbn.com
Scott Bellew smb&cs.purdue.edu
Ted J. Socolofsky Teds&spider.co.uk
Tim Howes Tim.Howes&terminator.cc.umich.edu
Tom Bereiter
Wayne Schroeder schroeder&sds.sdsc.edu
William Oldwin william&bitsome.ie 2022-01-28
Yakov Rekhter Yakov&ibm.com