Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
smpnameres 901 tcp SMPNAMERES Leif Ekblad Leif Ekblad
smpnameres 901 udp SMPNAMERES Leif Ekblad Leif Ekblad
fjicl-tep-a 1901 tcp Fujitsu ICL Terminal Emulator Program A Bob Lyon Bob Lyon
fjicl-tep-a 1901 udp Fujitsu ICL Terminal Emulator Program A Bob Lyon Bob Lyon
allstorcns 2901 tcp ALLSTORCNS Steve Dobson Steve Dobson
allstorcns 2901 udp ALLSTORCNS Steve Dobson Steve Dobson
nimsh 3901 tcp NIM Service Handler Paul B. Finley Paul B. Finley 2003-10
nimsh 3901 udp NIM Service Handler Paul B. Finley Paul B. Finley 2003-10
flr-agent 4901 tcp FileLocator Remote Search Agent

IANA assigned this well-formed service name as a replacement for "flr_agent".
David Vest David Vest 2008-11-19
flr_agent 4901 tcp FileLocator Remote Search Agent David Vest David Vest 2008-11-19 This entry is an alias to "flr-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
4901 udp Reserved
5901-5902 Unassigned
jetstream 6901 tcp Novell Jetstream messaging protocol Anil Tyagi Anil Tyagi 2010-06-11
6901 udp Reserved
tnos-sp 7901 tcp TNOS Service Protocol Rene Kurt Rene Kurt 2005-08
tnos-sp 7901 udp TNOS Service Protocol Rene Kurt Rene Kurt 2005-08
jmb-cds2 8901 tcp JMB-CDS 2 Curtis Bray Curtis Bray
jmb-cds2 8901 udp JMB-CDS 2 Curtis Bray Curtis Bray
sdr 9010 tcp Secure Data Replicator Protocol Sufyan Almajali Sufyan Almajali 2008-06-27
9010 udp Reserved
9011 tcp Reserved
d-star 9011 udp D-Star Routing digital voice+data for amateur radio QuadNet2 USA IRC Network Thomas A Early 2018-03-16
9012-9019 Unassigned
enrp 9901 udp enrp server channel
enrp-sctp 9901 sctp enrp server channel RFC 5353
16901-16949 Unassigned
19008-19019 Unassigned
niobserver 25901 tcp NIObserver Roman Oliynyk Roman Oliynyk
niobserver 25901 udp NIObserver Roman Oliynyk Roman Oliynyk
44901-44999 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Anil Tyagi tanil&novell.com 2010-06-11
Bob Lyon bl&oasis.icl.co.uk
Curtis Bray CurtisB&creativedesign.com
David Vest dave&mythicsoft.com 2008-11-19
Leif Ekblad leif&rdos.net
Paul B. Finley pfinley&us.ibm.com 2003-10
QuadNet2 USA IRC Network admins&openquad.net 2018-03-16
Rene Kurt rene.kurt&adasoft.ch 2005-08
Roman Oliynyk romano&netinst.com
Steve Dobson sdobson&allstor.com
Sufyan Almajali sufyan.almajali&sdrlive.com 2008-06-27
Thomas A Early tom.n7tae&tearly.net 2018-03-16