Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ideafarm-door 902 tcp self documenting Telnet Door
ideafarm-door 902 udp self documenting Door: send 0x00 for info
fjicl-tep-b 1902 tcp Fujitsu ICL Terminal Emulator Program B Bob Lyon Bob Lyon
fjicl-tep-b 1902 udp Fujitsu ICL Terminal Emulator Program B Bob Lyon Bob Lyon
netaspi 2902 tcp NET ASPI Johnson Luo Johnson Luo
netaspi 2902 udp NET ASPI Johnson Luo Johnson Luo
itu-bicc-stc 3097 sctp ITU-T Q.1902.1/Q.2150.3 Greg Sidebottom Greg Sidebottom
nimaux 3902 tcp NIMsh Auxiliary Port Paul B. Finley Paul B. Finley 2003-10
nimaux 3902 udp NIMsh Auxiliary Port Paul B. Finley Paul B. Finley 2003-10
magiccontrol 4902 tcp magicCONROL RF and Data Interface Andreas Spalenski Andreas Spalenski 2008-11-24
4902 udp Reserved
5901-5902 Unassigned
6902-6923 Unassigned
tnos-dp 7902 tcp TNOS shell Protocol Rene Kurt Rene Kurt 2005-08
tnos-dp 7902 udp TNOS shell Protocol Rene Kurt Rene Kurt 2005-08
8902-8907 Unassigned
tambora 9020 tcp TAMBORA Jason van Zyl Jason van Zyl 2002-03
tambora 9020 udp TAMBORA Jason van Zyl Jason van Zyl 2002-03
panagolin-ident 9021 tcp Pangolin Identification William Benner William Benner 2002-03
panagolin-ident 9021 udp Pangolin Identification William Benner William Benner 2002-03
paragent 9022 tcp PrivateArk Remote Agent Gal Cucuy Gal Cucuy 2002-03
paragent 9022 udp PrivateArk Remote Agent Gal Cucuy Gal Cucuy 2002-03
swa-1 9023 tcp Secure Web Access - 1 Tim McGranaghan Tim McGranaghan
swa-1 9023 udp Secure Web Access - 1 Tim McGranaghan Tim McGranaghan
swa-2 9024 tcp Secure Web Access - 2 Tim McGranaghan Tim McGranaghan
swa-2 9024 udp Secure Web Access - 2 Tim McGranaghan Tim McGranaghan
swa-3 9025 tcp Secure Web Access - 3 Tim McGranaghan Tim McGranaghan
swa-3 9025 udp Secure Web Access - 3 Tim McGranaghan Tim McGranaghan
swa-4 9026 tcp Secure Web Access - 4 Tim McGranaghan Tim McGranaghan
swa-4 9026 udp Secure Web Access - 4 Tim McGranaghan Tim McGranaghan
9027-9049 Unassigned
enrp-sctp-tls 9902 sctp enrp/tls server channel RFC 5353
hip-nat-t 10500 udp HIP NAT-Traversal IESG IETF Chair 2020-08-12 RFC 5770; RFC 9028
j-link 19020 tcp J-Link TCP/IP Protocol SEGGER Microcontroller GmbH & Co. KG SEGGER Microcontroller GmbH & Co. KG
19020 udp Reserved
19021-19190 Unassigned
nilinkanalyst 25902 tcp NILinkAnalyst Roman Oliynyk Roman Oliynyk 2007-08-30
nilinkanalyst 25902 udp NILinkAnalyst Roman Oliynyk Roman Oliynyk 2007-08-30

Contact Information

Name Organization Contact URI Last Updated
Andreas Spalenski andreas.spalenski&trsystems.de 2008-11-24
Bob Lyon bl&oasis.icl.co.uk
Gal Cucuy galc&cyber-ark.com 2002-03
Greg Sidebottom gregside&home.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jason van Zyl jvanzyl&zenplex.com 2002-03
Johnson Luo johnson_luo&mail.sercomm.com.tw
Paul B. Finley pfinley&us.ibm.com 2003-10
Rene Kurt rene.kurt&adasoft.ch 2005-08
Roman Oliynyk roman&netinst.com 2007-08-30
SEGGER Microcontroller GmbH & Co. KG info&segger.com 2009-01-16
Tim McGranaghan tim_mcgranaghan&mech.disa.mil
William Benner wrb2&pangolin.com 2025-03-27