Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| kink | 910 | tcp | Kerberized Internet Negotiation of Keys (KINK) | RFC 4430 | |||||||
| kink | 910 | udp | Kerberized Internet Negotiation of Keys (KINK) | RFC 4430 | |||||||
| ultrabac | 1910 | tcp | UltraBac Software communications port | Paul Bunn | Paul Bunn | ||||||
| ultrabac | 1910 | udp | UltraBac Software communications port | Paul Bunn | Paul Bunn | ||||||
| tdaccess | 2910 | tcp | TDAccess | Tom Haapanen | Tom Haapanen | ||||||
| tdaccess | 2910 | udp | TDAccess | Tom Haapanen | Tom Haapanen | ||||||
| prnrequest | 3910 | tcp | Printer Request Port | Brett Green | Brett Green | 2003-11 | |||||
| prnrequest | 3910 | udp | Printer Request Port | Brett Green | Brett Green | 2003-11 | |||||
| ats-atn | 5910 | tcp | Air Traffic Services applications using ATN | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ats-atn | 5910 | udp | Air Traffic Services applications using ATN | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| cm | 5910 | sctp | Context Management | Justin Yu | Justin Yu | 2011-05-19 | |||||
| manyone-http | 8910 | tcp | manyone-http | Matt King | Matt King | 2002-04 | |||||
| manyone-http | 8910 | udp | manyone-http | Matt King | Matt King | 2002-04 | |||||
| hp-pdl-datastr | 9100 | tcp | PDL Data Streaming Port | Shivaun Albright | Shivaun Albright | 2002-04 | |||||
| hp-pdl-datastr | 9100 | udp | PDL Data Streaming Port | Shivaun Albright | Shivaun Albright | 2002-04 | |||||
| pdl-datastream | 9100 | tcp | Printer PDL Data Stream | Stuart Cheshire | Stuart Cheshire | 2002-09 | The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100. | ||||
| pdl-datastream | 9100 | udp | Printer PDL Data Stream | Stuart Cheshire | Stuart Cheshire | 2002-09 | The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100. | ||||
| bacula-dir | 9101 | tcp | Bacula Director | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-dir | 9101 | udp | Bacula Director | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-fd | 9102 | tcp | Bacula File Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-fd | 9102 | udp | Bacula File Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-sd | 9103 | tcp | Bacula Storage Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-sd | 9103 | udp | Bacula Storage Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| peerwire | 9104 | tcp | PeerWire | Steven Gerhardt | Steven Gerhardt | 2004-02 | |||||
| peerwire | 9104 | udp | PeerWire | Steven Gerhardt | Steven Gerhardt | 2004-02 | |||||
| xadmin | 9105 | tcp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| xadmin | 9105 | udp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| astergate | 9106 | tcp | Astergate Control Service | Ariën Huisken | Ariën Huisken | 2010-01-04 | |||||
| astergate-disc | 9106 | udp | Astergate Discovery Service | Ariën Huisken | Ariën Huisken | 2010-01-04 | |||||
| astergatefax | 9107 | tcp | AstergateFax Control Service | Gijs Middelkamp | Gijs Middelkamp | 2010-02-03 | |||||
| 9107 | udp | Reserved | |||||||||
| 9108-9110 | Unassigned | ||||||||||
| 9910 | Unassigned |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Ariën Huisken | astergate&huisken-systems.nl | 2010-01-04 |
| Brett Green | brett_green&hp.com | 2003-11 |
| Eivan Cerasi | eivan.cerasi&eurocontrol.int | 2022-08-08 |
| Gijs Middelkamp | astergate-fax&huisken-systems.nl | 2010-02-03 |
| Greg Saccone | gregory.t.saccone&boeing.com | 2022-08-08 |
| Justin Yu | yyu&mitre.org | 2011-05-25 |
| Kern Sibbald | kern&sibbald.com | 2002-01 |
| Matt King | m&manyone.net | 2002-04 |
| Paul Bunn | iana&ultrabac.com | |
| Shivaun Albright | shivaun_albright&hp.com | 2002-04 |
| Steven Gerhardt | sgerhardt&ixiononline.com | 2004-02 |
| Stuart Cheshire | pdl-datastream&apple.com | 2002-09 |
| Tom Haapanen | tomh&metrics.com |