Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
https 443 tcp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 udp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 sctp HTTPS Randall Stewart Randall Stewart 2022-02-07 RFC 9260
spss 5443 tcp Pearson HTTPS Pearson Pearson 2008-01-17
spss 5443 udp Pearson HTTPS Pearson Pearson 2008-01-17
sun-sr-https 6443 tcp Service Registry Default HTTPS Domain Paul Sterk Paul Sterk 2006-03
sun-sr-https 6443 udp Service Registry Default HTTPS Domain Paul Sterk Paul Sterk 2006-03
oracleas-https 7443 tcp Oracle Application Server HTTPS David McMarlin David McMarlin 2006-08
oracleas-https 7443 udp Oracle Application Server HTTPS David McMarlin David McMarlin 2006-08
pcsync-https 8443 tcp PCsync HTTPS
pcsync-https 8443 udp PCsync HTTPS
tungsten-https 9443 tcp WSO2 Tungsten HTTPS Afkham Azeez Afkham Azeez 2006-06
tungsten-https 9443 udp WSO2 Tungsten HTTPS Afkham Azeez Afkham Azeez 2006-06

Contact Information

Name Organization Contact URI Last Updated
Afkham Azeez azeez&wso2.com 2006-06
David McMarlin david.mcmarlin&oracle.com 2006-08
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Paul Sterk paul.sterk&sun.com 2006-03
Pearson chad.smith&pearson.com 2008-01-17
Randall Stewart IETF TSVWG rrs&lakerest.net