Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
tcpmux 1 tcp TCP Port Service Multiplexer Mark Lottor Mark Lottor
tcpmux 1 udp TCP Port Service Multiplexer Mark Lottor Mark Lottor
2 tcp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by Bernie Volz
2 udp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by Bernie Volz
3 tcp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by Bernie Volz
3 udp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by Bernie Volz
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
10 tcp Unassigned
10 udp Unassigned
systat 11 tcp Active Users Jon Postel Jon Postel
systat 11 udp Active Users Jon Postel Jon Postel
12 tcp Unassigned
12 udp Unassigned
daytime 13 tcp Daytime Jon Postel Jon Postel RFC 867
daytime 13 udp Daytime Jon Postel Jon Postel RFC 867
14 tcp Unassigned
14 udp Unassigned
15 tcp Unassigned [was netstat]
15 udp Unassigned
16 tcp Unassigned
16 udp Unassigned
qotd 17 tcp Quote of the Day Jon Postel Jon Postel
qotd 17 udp Quote of the Day Jon Postel Jon Postel
msp 18 tcp Message Send Protocol (historic) Rina Nethaniel Rina Nethaniel
msp 18 udp Message Send Protocol (historic) Rina Nethaniel Rina Nethaniel
chargen 19 tcp Character Generator
chargen 19 udp Character Generator
ftp 21 tcp File Transfer Protocol [Control] Jon Postel Jon Postel RFC 959 Defined TXT keys: u=<username> p=<password> path=<path>
ftp 21 udp File Transfer Protocol [Control] Jon Postel Jon Postel RFC 959 Defined TXT keys: u=<username> p=<password> path=<path>
ftp 21 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path>
ssh 22 tcp The Secure Shell (SSH) Protocol RFC 4251 Defined TXT keys: u=<username> p=<password>
ssh 22 udp The Secure Shell (SSH) Protocol RFC 4251 Defined TXT keys: u=<username> p=<password>
smtp 25 tcp Simple Mail Transfer IESG IETF Chair 2017-06-05 RFC-ietf-emailcore-rfc5321bis-43
smtp 25 udp Simple Mail Transfer IESG IETF Chair 2017-06-05 RFC-ietf-emailcore-rfc5321bis-43
msg-auth 31 tcp MSG Authentication Robert Thomas Robert Thomas
msg-auth 31 udp MSG Authentication Robert Thomas Robert Thomas
graphics 41 tcp Graphics
graphics 41 udp Graphics
47 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
47 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
51 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
61 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
61 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
bootps 67 tcp Bootstrap Protocol Server Bill Croft Bill Croft RFC 951 Defined TXT keys: None
netrjs-1 71 tcp Remote Job Service
netrjs-1 71 udp Remote Job Service
finger 79 tcp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
finger 79 udp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
http 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
http 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
www 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
81 Unassigned 2007-09-06
kerberos 88 tcp Kerberos B. Clifford Neuman B. Clifford Neuman 2022-02-18 RFC 4120
kerberos 88 udp Kerberos B. Clifford Neuman B. Clifford Neuman 2022-02-18 RFC 4120
mit-dov 91 tcp MIT Dover Spooler Eliot Moss Eliot Moss
mit-dov 91 udp MIT Dover Spooler Eliot Moss Eliot Moss
100 Unassigned 2012-03-21 Known Unauthorized Use on 100
hostname 101 tcp NIC Host Name Server Jon Postel Jon Postel
hostname 101 udp NIC Host Name Server Jon Postel Jon Postel
iso-tsap 102 tcp ISO-TSAP Class 0 Marshall Rose Marshall Rose
iso-tsap 102 udp ISO-TSAP Class 0 Marshall Rose Marshall Rose
gppitnp 103 tcp Genesis Point-to-Point Trans Net
gppitnp 103 udp Genesis Point-to-Point Trans Net
acr-nema 104 tcp ACR-NEMA Digital Imag. & Comm. 300 Patrick McNamee Patrick McNamee
acr-nema 104 udp ACR-NEMA Digital Imag. & Comm. 300 Patrick McNamee Patrick McNamee
cso 105 tcp CCSO name server protocol Martin Hamilton Martin Hamilton
cso 105 udp CCSO name server protocol Martin Hamilton Martin Hamilton
csnet-ns 105 tcp Mailbox Name Nameserver Marvin Solomon Marvin Solomon
csnet-ns 105 udp Mailbox Name Nameserver Marvin Solomon Marvin Solomon
3com-tsmux 106 tcp 3COM-TSMUX Jeremy Siegel Jeremy Siegel Known Unauthorized Use on 106
3com-tsmux 106 udp 3COM-TSMUX Jeremy Siegel Jeremy Siegel Known Unauthorized Use on 106
rtelnet 107 tcp Remote Telnet Service Jon Postel Jon Postel
rtelnet 107 udp Remote Telnet Service Jon Postel Jon Postel
snagas 108 tcp SNA Gateway Access Server Kevin Murphy Kevin Murphy
snagas 108 udp SNA Gateway Access Server Kevin Murphy Kevin Murphy
pop2 109 tcp Post Office Protocol - Version 2 Joyce K. Reynolds Joyce K. Reynolds
pop2 109 udp Post Office Protocol - Version 2 Joyce K. Reynolds Joyce K. Reynolds
pop3 110 tcp Post Office Protocol - Version 3 Marshall Rose Marshall Rose
pop3 110 udp Post Office Protocol - Version 3 Marshall Rose Marshall Rose
sunrpc 111 tcp SUN Remote Procedure Call Chuck McManis Chuck McManis
sunrpc 111 udp SUN Remote Procedure Call Chuck McManis Chuck McManis
mcidas 112 tcp McIDAS Data Transmission Protocol Glenn Davis Glenn Davis
mcidas 112 udp McIDAS Data Transmission Protocol Glenn Davis Glenn Davis
ident 113 tcp
auth 113 tcp Authentication Service Mike St. Johns Mike St. Johns
auth 113 udp Authentication Service Mike St. Johns Mike St. Johns
114 unassigned Deprecated June 2004
sftp 115 tcp Simple File Transfer Protocol Mark Lottor Mark Lottor
sftp 115 udp Simple File Transfer Protocol Mark Lottor Mark Lottor
ansanotify 116 tcp ANSA REX Notify Nicola J. Howarth Nicola J. Howarth
ansanotify 116 udp ANSA REX Notify Nicola J. Howarth Nicola J. Howarth
uucp-path 117 tcp UUCP Path Service
uucp-path 117 udp UUCP Path Service
sqlserv 118 tcp SQL Services Larry Barnes Larry Barnes
sqlserv 118 udp SQL Services Larry Barnes Larry Barnes
nntp 119 tcp Network News Transfer Protocol IESG IETF Chair 2018-07-06 RFC 3977
nntp 119 udp Network News Transfer Protocol IESG IETF Chair 2018-07-06 RFC 3977
cfdptkt 120 tcp CFDPTKT John Ioannidis John Ioannidis
cfdptkt 120 udp CFDPTKT John Ioannidis John Ioannidis

Contact Information

Name Organization Contact URI Last Updated
B. Clifford Neuman bcn&isi.edu 2022-02-18
Bernie Volz volz&cisco.com
Bill Croft Croft&sumex-aim.stanford.edu
Chuck McManis cmcmanis&freegate.net
David Zimmerman dpz&rutgers.edu
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Eliot Moss EBM&xx.lcs.mit.edu
Glenn Davis support&unidata.ucar.edu
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jeremy Siegel jzs&nsd.3com.com
John Ioannidis ji&close.cs.columbia.ed
Jon Postel postel&isi.edu
Joyce K. Reynolds jkrey&isi.edu
Kevin Murphy murphy&sevens.lkg.dec.com
Larry Barnes barnes&broke.enet.dec.com
Mark Lottor MKL&nisc.sri.com
Marshall Rose mrose17&gmail.com 2024-07-29
Martin Hamilton martin&mrrl.lut.as.uk
Marvin Solomon solomon&cs.wisc.edu
Mike St. Johns stjohns&arpa.mil
Nicola J. Howarth njh&ansa.co.uk
Patrick McNamee
Randall Stewart IETF TSVWG rrs&lakerest.net
Rina Nethaniel
Robert Thomas BThomas&f.bbn.com