Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
12 tcp Unassigned
12 udp Unassigned
kerberos 88 tcp Kerberos B. Clifford Neuman B. Clifford Neuman 2022-02-18 RFC 4120
kerberos 88 udp Kerberos B. Clifford Neuman B. Clifford Neuman 2022-02-18 RFC 4120
mcidas 112 tcp McIDAS Data Transmission Protocol Glenn Davis Glenn Davis
mcidas 112 udp McIDAS Data Transmission Protocol Glenn Davis Glenn Davis
cfdptkt 120 tcp CFDPTKT John Ioannidis John Ioannidis
cfdptkt 120 udp CFDPTKT John Ioannidis John Ioannidis
erpc 121 tcp Encore Expedited Remote Pro.Call Jack O'Neil Jack O'Neil
erpc 121 udp Encore Expedited Remote Pro.Call Jack O'Neil Jack O'Neil
smakynet 122 tcp SMAKYNET Pierre Arnaud Pierre Arnaud
smakynet 122 udp SMAKYNET Pierre Arnaud Pierre Arnaud
ntp 123 tcp Network Time Protocol Dave Mills Dave Mills RFC 5905
ntp 123 udp Network Time Protocol Dave Mills Dave Mills RFC 5905
ansatrader 124 tcp ANSA REX Trader Nicola J. Howarth Nicola J. Howarth
ansatrader 124 udp ANSA REX Trader Nicola J. Howarth Nicola J. Howarth
locus-map 125 tcp Locus PC-Interface Net Map Ser Eric Peterson Eric Peterson
locus-map 125 udp Locus PC-Interface Net Map Ser Eric Peterson Eric Peterson
nxedit 126 tcp NXEdit Don Payette Don Payette Port 126 Previously assigned to application below unitary 126/tcp Unisys Unitary Login unitary 126/udp Unisys Unitary Login <feil&kronos.nisd.cam.unisys.com> Port 126 Previously assigned to application above
nxedit 126 udp NXEdit Don Payette Don Payette Port 126 Previously assigned to application below unitary 126/tcp Unisys Unitary Login unitary 126/udp Unisys Unitary Login <feil&kronos.nisd.cam.unisys.com> Port 126 Previously assigned to application above
locus-con 127 tcp Locus PC-Interface Conn Server Eric Peterson Eric Peterson
locus-con 127 udp Locus PC-Interface Conn Server Eric Peterson Eric Peterson
gss-xlicen 128 tcp GSS X License Verification John Light John Light
gss-xlicen 128 udp GSS X License Verification John Light John Light
pwdgen 129 tcp Password Generator Protocol Frank J. Wacho Frank J. Wacho
pwdgen 129 udp Password Generator Protocol Frank J. Wacho Frank J. Wacho
aed-512 149 tcp AED 512 Emulation Service Albert G. Broscius Albert G. Broscius
aed-512 149 udp AED 512 Emulation Service Albert G. Broscius Albert G. Broscius
anet 212 tcp ATEXSSTR Jim Taylor Jim Taylor
anet 212 udp ATEXSSTR Jim Taylor Jim Taylor
vslmp 312 tcp VSLMP Gerben Wierda Gerben Wierda
vslmp 312 udp VSLMP Gerben Wierda Gerben Wierda
synoptics-trap 412 tcp Trap Convention Port Illan Raab Illan Raab
synoptics-trap 412 udp Trap Convention Port Illan Raab Illan Raab
exec 512 tcp remote process execution; authentication performed using passwords and UNIX login names
comsat 512 udp
biff 512 udp used by mail system to notify users of new mail received; currently receives messages only from processes on the same machine
hmmp-ind 612 tcp HMMP Indication
hmmp-ind 612 udp HMMP Indication
epp 700 udp EPP running over QUIC IESG IETF Chair 2026-07-23 RFC 5734; RFC-ietf-regext-epp-quic-12
tbrpf 712 tcp TBRPF RFC 3684
tbrpf 712 udp TBRPF RFC 3684
apex-mesh 912 tcp APEX relay-relay service
apex-mesh 912 udp APEX relay-relay service
icp 1112 tcp Intelligent Communication Protocol Mark H. David Mark H. David
icp 1112 udp Intelligent Communication Protocol Mark H. David Mark H. David
ltp-deepspace 1113 udp Licklider Transmission Protocol 2014-02-21 RFC 5326; RFC 7122
ltp-deepspace 1113 dccp Licklider Transmission Protocol 2013-11-12 2014-02-21 RFC 7122 7107696
bnetfile 1120 tcp Battle.net File Transfer Protocol Domain Tech Domain Tech 2005-04
bnetfile 1120 udp Battle.net File Transfer Protocol Domain Tech Domain Tech 2005-04
rmpp 1121 tcp Datalode RMPP Dave Ruedger Dave Ruedger 2003-11
rmpp 1121 udp Datalode RMPP Dave Ruedger Dave Ruedger 2003-11
availant-mgr 1122 tcp availant-mgr Steven Pelletier Steven Pelletier
availant-mgr 1122 udp availant-mgr Steven Pelletier Steven Pelletier
murray 1123 tcp Murray Stu Mark Stu Mark
murray 1123 udp Murray Stu Mark Stu Mark
hpvmmcontrol 1124 tcp HP VMM Control
hpvmmcontrol 1124 udp HP VMM Control
hpvmmagent 1125 tcp HP VMM Agent
hpvmmagent 1125 udp HP VMM Agent
hpvmmdata 1126 tcp HP VMM Agent John Morton John Morton 2004-11
hpvmmdata 1126 udp HP VMM Agent John Morton John Morton 2004-11
kwdb-commn 1127 tcp KWDB Remote Communication Lal Samuel Varghese Lal Samuel Varghese 2005-08
kwdb-commn 1127 udp KWDB Remote Communication Lal Samuel Varghese Lal Samuel Varghese 2005-08
saphostctrl 1128 tcp SAPHostControl over SOAP/HTTP
saphostctrl 1128 udp SAPHostControl over SOAP/HTTP
saphostctrls 1129 tcp SAPHostControl over SOAP/HTTPS Muscarella Fabrizio Muscarella Fabrizio 2006-04
saphostctrls 1129 udp SAPHostControl over SOAP/HTTPS Muscarella Fabrizio Muscarella Fabrizio 2006-04
c1222-acse 1153 tcp ANSI C12.22 Port RFC 6142
c1222-acse 1153 udp ANSI C12.22 Port RFC 6142
scol 1200 tcp SCOL Cryo-Networks Cryo-Networks
scol 1200 udp SCOL Cryo-Networks Cryo-Networks
nucleus-sand 1201 tcp Nucleus Sand Database Server James Marsh James Marsh
nucleus-sand 1201 udp Nucleus Sand Database Server James Marsh James Marsh
caiccipc 1202 tcp caiccipc Vince Re Vince Re
caiccipc 1202 udp caiccipc Vince Re Vince Re
ssslic-mgr 1203 tcp License Validation
ssslic-mgr 1203 udp License Validation
ssslog-mgr 1204 tcp Log Request Listener Eric Bruno Eric Bruno
ssslog-mgr 1204 udp Log Request Listener Eric Bruno Eric Bruno
accord-mgc 1205 tcp Accord-MGC Roni Even Roni Even
accord-mgc 1205 udp Accord-MGC Roni Even Roni Even
anthony-data 1206 tcp Anthony Data Paul Dollemore Paul Dollemore
anthony-data 1206 udp Anthony Data Paul Dollemore Paul Dollemore
metasage 1207 tcp MetaSage Peter Anvelt Peter Anvelt
metasage 1207 udp MetaSage Peter Anvelt Peter Anvelt
seagull-ais 1208 tcp SEAGULL AIS Lee Breisacher Lee Breisacher
seagull-ais 1208 udp SEAGULL AIS Lee Breisacher Lee Breisacher
ipcd3 1209 tcp IPCD3 Mark Ciskey Mark Ciskey
ipcd3 1209 udp IPCD3 Mark Ciskey Mark Ciskey
eoss 1210 tcp EOSS Robert Armes Robert Armes
eoss 1210 udp EOSS Robert Armes Robert Armes
groove-dpp 1211 tcp Groove DPP Ken Moore Ken Moore
groove-dpp 1211 udp Groove DPP Ken Moore Ken Moore
lupa 1212 tcp lupa Barney Wolff Barney Wolff
lupa 1212 udp lupa Barney Wolff Barney Wolff
mpc-lifenet 1213 tcp Medtronic/Physio-Control LIFENET Physio-Control, Inc. Kevin Drew 2014-02-14
mpc-lifenet 1213 udp Medtronic/Physio-Control LIFENET Physio-Control, Inc. Kevin Drew 2014-02-14
kazaa 1214 tcp KAZAA Ahti Heinla Ahti Heinla
kazaa 1214 udp KAZAA Ahti Heinla Ahti Heinla

Contact Information

Name Organization Contact URI Last Updated
Ahti Heinla ahti&ahti.bluemoon.ee 2002-06
Albert G. Broscius broscius&dsl.cis.upenn.edu
B. Clifford Neuman bcn&isi.edu 2022-02-18
Barney Wolff barney&databus.com
Cryo-Networks p.favre&cryo-networks.fr
Dave Mills mills&udel.edu 2022-06-03
Dave Ruedger daver&datalode.com 2003-11
Domain Tech Domainnametech&blizzard.com 2005-04
Don Payette Don.Payette&unisys.com
Eric Bruno ebruno&solution-soft.com
Eric Peterson lcc.eric&seas.ucla.edu
Frank J. Wacho WANCHO&wsmr-simtel20.army.mil
Gerben Wierda Gerben_Wierda&rna.nl
Glenn Davis support&unidata.ucar.edu
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Illan Raab iraab&synoptics.com
Jack O'Neil
James Marsh James_T_Marsh&hotmail.com
Jim Taylor taylor&heart.epps.kodak.com
John Ioannidis ji&close.cs.columbia.ed
John Light johnl&gssc.gss.com
John Morton j.morton&hp.com 2004-11
Ken Moore kmoore&groove.net
Kevin Drew Physio-Control, Inc. kevin.c.drew&physio-control.com 2014-02-14
Lal Samuel Varghese lalsam&hp.com 2005-08
Lee Breisacher lbreisacher&seagullsw.com
Mark Ciskey mlciskey&plato.com
Mark H. David mhd&gensym.com
Muscarella Fabrizio fabrizio.muscarella&sap.com 2006-04
Nicola J. Howarth njh&ansa.co.uk
Paul Dollemore pauld&anthonydata.com
Peter Anvelt panvelt&xnai.com
Physio-Control, Inc. kevin.c.drew&physio-control.com 2014-02-14
Pierre Arnaud pierre.arnaud&iname.com
Robert Armes rarmes&axarte.com
Roni Even roni_e&accord.co.il
Steven Pelletier stevep&availant.com
Stu Mark fordii&j51.com
Vince Re Vincent.Re&cai.com