Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 15 | tcp | Unassigned [was netstat] | |||||||||
| 15 | udp | Unassigned | |||||||||
| sftp | 115 | tcp | Simple File Transfer Protocol | Mark Lottor | Mark Lottor | ||||||
| sftp | 115 | udp | Simple File Transfer Protocol | Mark Lottor | Mark Lottor | ||||||
| sql-net | 150 | tcp | SQL-NET | Martin Picard | Martin Picard | ||||||
| sql-net | 150 | udp | SQL-NET | Martin Picard | Martin Picard | ||||||
| hems | 151 | tcp | HEMS | ||||||||
| hems | 151 | udp | HEMS | ||||||||
| bftp | 152 | tcp | Background File Transfer Program | Annette DeSchon | Annette DeSchon | ||||||
| bftp | 152 | udp | Background File Transfer Program | Annette DeSchon | Annette DeSchon | ||||||
| sgmp | 153 | tcp | SGMP | Marty Schoffstahl | Marty Schoffstahl | ||||||
| sgmp | 153 | udp | SGMP | Marty Schoffstahl | Marty Schoffstahl | ||||||
| netsc-prod | 154 | tcp | NETSC | ||||||||
| netsc-prod | 154 | udp | NETSC | ||||||||
| netsc-dev | 155 | tcp | NETSC | Sergio Heker | Sergio Heker | ||||||
| netsc-dev | 155 | udp | NETSC | Sergio Heker | Sergio Heker | ||||||
| sqlsrv | 156 | tcp | SQL Service | Craig Rogers | Craig Rogers | ||||||
| sqlsrv | 156 | udp | SQL Service | Craig Rogers | Craig Rogers | ||||||
| knet-cmp | 157 | tcp | KNET/VM Command/Message Protocol | Gary S. Malkin | Gary S. Malkin | ||||||
| knet-cmp | 157 | udp | KNET/VM Command/Message Protocol | Gary S. Malkin | Gary S. Malkin | ||||||
| pcmail-srv | 158 | tcp | PCMail Server | Mark L. Lambert | Mark L. Lambert | ||||||
| pcmail-srv | 158 | udp | PCMail Server | Mark L. Lambert | Mark L. Lambert | ||||||
| nss-routing | 159 | tcp | NSS-Routing | Yakov Rekhter | Yakov Rekhter | ||||||
| nss-routing | 159 | udp | NSS-Routing | Yakov Rekhter | Yakov Rekhter | ||||||
| softpc | 215 | tcp | Insignia Solutions | Martyn Thomas | Martyn Thomas | ||||||
| softpc | 215 | udp | Insignia Solutions | Martyn Thomas | Martyn Thomas | ||||||
| dpsi | 315 | tcp | DPSI | Tony Scamurra | Tony Scamurra | ||||||
| dpsi | 315 | udp | DPSI | Tony Scamurra | Tony Scamurra | ||||||
| bnet | 415 | tcp | BNet | Jim Mertz | Jim Mertz | ||||||
| bnet | 415 | udp | BNet | Jim Mertz | Jim Mertz | ||||||
| snpp | 444 | tcp | Simple Network Paging Protocol | RFC 1568 | |||||||
| snpp | 444 | udp | Simple Network Paging Protocol | RFC 1568 | |||||||
| printer | 515 | tcp | spooler | ||||||||
| printer | 515 | udp | spooler | ||||||||
| dhcpv6-client | 546 | udp | DHCPv6 Client | IESG | IETF Chair | 2018-05-21 | RFC 9915 | ||||
| dhcpv6-server | 547 | udp | DHCPv6 Server | IESG | IETF Chair | 2018-05-21 | RFC 9915 | ||||
| sco-inetmgr | 615 | tcp | Internet Configuration Manager | ||||||||
| sco-inetmgr | 615 | udp | Internet Configuration Manager | ||||||||
| dhcp-failover | 647 | tcp | DHCP Failover | IESG | IETF Chair | 2018-05-21 | RFC 8156 | ||||
| iris-lwz | 715 | tcp | IRIS-LWZ | RFC 4993 | |||||||
| iris-lwz | 715 | udp | IRIS-LWZ | RFC 4993 | |||||||
| 915 | tcp | Reserved | |||||||||
| rift-ties | 915 | udp | Routing in Fat Trees Topology Information Element | IESG | IETF Chair | 2023-02-17 | 2024-06-07 | RFC 9692 | |||
| ardus-trns | 1115 | tcp | ARDUS Transfer | ||||||||
| ardus-trns | 1115 | udp | ARDUS Transfer | ||||||||
| blaze | 1150 | tcp | Blaze File Server | Curt Schimmel | Curt Schimmel | 2005-11 | |||||
| blaze | 1150 | udp | Blaze File Server | Curt Schimmel | Curt Schimmel | 2005-11 | |||||
| unizensus | 1151 | tcp | Unizensus Login Server | Dirk Materlik | Dirk Materlik | 2005-11 | |||||
| unizensus | 1151 | udp | Unizensus Login Server | Dirk Materlik | Dirk Materlik | 2005-11 | |||||
| winpoplanmess | 1152 | tcp | Winpopup LAN Messenger | Vitali Fomine | Vitali Fomine | 2005-11 | |||||
| winpoplanmess | 1152 | udp | Winpopup LAN Messenger | Vitali Fomine | Vitali Fomine | 2005-11 | |||||
| c1222-acse | 1153 | tcp | ANSI C12.22 Port | RFC 6142 | |||||||
| c1222-acse | 1153 | udp | ANSI C12.22 Port | RFC 6142 | |||||||
| resacommunity | 1154 | tcp | Community Service | Stéphane MONS | Stéphane MONS | 2005-09 | |||||
| resacommunity | 1154 | udp | Community Service | Stéphane MONS | Stéphane MONS | 2005-09 | |||||
| nfa | 1155 | tcp | Network File Access | James Powell | James Powell | ||||||
| nfa | 1155 | udp | Network File Access | James Powell | James Powell | ||||||
| iascontrol-oms | 1156 | tcp | iasControl OMS | Todd Guay | Todd Guay | 2004-11 | |||||
| iascontrol-oms | 1156 | udp | iasControl OMS | Todd Guay | Todd Guay | 2004-11 | |||||
| iascontrol | 1157 | tcp | Oracle iASControl | Todd Guay | Todd Guay | 2004-11 | |||||
| iascontrol | 1157 | udp | Oracle iASControl | Todd Guay | Todd Guay | 2004-11 | |||||
| dbcontrol-oms | 1158 | tcp | dbControl OMS | Todd Guay | Todd Guay | 2004-11 | |||||
| dbcontrol-oms | 1158 | udp | dbControl OMS | Todd Guay | Todd Guay | 2004-11 | |||||
| oracle-oms | 1159 | tcp | Oracle OMS | Todd Guay | Todd Guay | 2004-11 | |||||
| oracle-oms | 1159 | udp | Oracle OMS | Todd Guay | Todd Guay | 2004-11 | |||||
| scanstat-1 | 1215 | tcp | scanSTAT 1.0 | William Scheding | William Scheding | ||||||
| scanstat-1 | 1215 | udp | scanSTAT 1.0 | William Scheding | William Scheding | ||||||
| els | 1315 | tcp | E.L.S., Event Listener Service | Jim Cleppe | Jim Cleppe | ||||||
| els | 1315 | udp | E.L.S., Event Listener Service | Jim Cleppe | Jim Cleppe | ||||||
| tibet-server | 1407 | tcp | TIBET Data Server | Technical Pursuit Inc. | Scott Shattuck | 2015-06-16 | This port has been retasked on 2015-06-16. | ||||
| 1407 | udp | Reserved | This port has been removed on 2015-06-16. | ||||||||
| dbstar | 1415 | tcp | DBStar | Jeffrey Millman | Jeffrey Millman | ||||||
| dbstar | 1415 | udp | DBStar | Jeffrey Millman | Jeffrey Millman | ||||||
| vlsi-lm | 1500 | tcp | VLSI License Manager | Shue-Lin Kuo | Shue-Lin Kuo | ||||||
| vlsi-lm | 1500 | udp | VLSI License Manager | Shue-Lin Kuo | Shue-Lin Kuo | ||||||
| saiscm | 1501 | tcp | Satellite-data Acquisition System 3 | Bill Taylor | Bill Taylor | ||||||
| saiscm | 1501 | udp | Satellite-data Acquisition System 3 | Bill Taylor | Bill Taylor | ||||||
| shivadiscovery | 1502 | tcp | Shiva | Jonathan Wenocur | Jonathan Wenocur | ||||||
| shivadiscovery | 1502 | udp | Shiva | Jonathan Wenocur | Jonathan Wenocur | ||||||
| imtc-mcs | 1503 | tcp | Databeam | Jim Johnston | Jim Johnston | ||||||
| imtc-mcs | 1503 | udp | Databeam | Jim Johnston | Jim Johnston | ||||||
| evb-elm | 1504 | tcp | EVB Software Engineering License Manager | B.G. Mahesh | B.G. Mahesh | ||||||
| evb-elm | 1504 | udp | EVB Software Engineering License Manager | B.G. Mahesh | B.G. Mahesh | ||||||
| funkproxy | 1505 | tcp | Funk Software, Inc. | Robert D. Vincent | Robert D. Vincent | ||||||
| funkproxy | 1505 | udp | Funk Software, Inc. | Robert D. Vincent | Robert D. Vincent | ||||||
| utcd | 1506 | tcp | Universal Time daemon (utcd) | Walter Poxon | Walter Poxon | ||||||
| utcd | 1506 | udp | Universal Time daemon (utcd) | Walter Poxon | Walter Poxon | ||||||
| symplex | 1507 | tcp | symplex | Mike Turley | Mike Turley | ||||||
| symplex | 1507 | udp | symplex | Mike Turley | Mike Turley | ||||||
| diagmond | 1508 | tcp | diagmond | Pete Moscatelli | Pete Moscatelli | ||||||
| diagmond | 1508 | udp | diagmond | Pete Moscatelli | Pete Moscatelli | ||||||
| robcad-lm | 1509 | tcp | Robcad, Ltd. License Manager | Hindin Joseph | Hindin Joseph | ||||||
| robcad-lm | 1509 | udp | Robcad, Ltd. License Manager | Hindin Joseph | Hindin Joseph | ||||||
| mvx-lm | 1510 | tcp | Midland Valley Exploration Ltd. Lic. Man. | Neil Salter | Neil Salter | ||||||
| mvx-lm | 1510 | udp | Midland Valley Exploration Ltd. Lic. Man. | Neil Salter | Neil Salter | ||||||
| 3l-l1 | 1511 | tcp | 3l-l1 | Ian A. Young | Ian A. Young | ||||||
| 3l-l1 | 1511 | udp | 3l-l1 | Ian A. Young | Ian A. Young | ||||||
| wins | 1512 | tcp | Microsoft's Windows Internet Name Service | Pradeep Bahl | Pradeep Bahl | ||||||
| wins | 1512 | udp | Microsoft's Windows Internet Name Service | Pradeep Bahl | Pradeep Bahl | ||||||
| fujitsu-dtc | 1513 | tcp | Fujitsu Systems Business of America, Inc |