Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| msp | 18 | tcp | Message Send Protocol (historic) | Rina Nethaniel | Rina Nethaniel | ||||||
| msp | 18 | udp | Message Send Protocol (historic) | Rina Nethaniel | Rina Nethaniel | ||||||
| 47 | tcp | Reserved | 2017-05-18 | This entry has been removed on 2017-05-18. | |||||||
| 47 | udp | Reserved | 2017-05-18 | This entry has been removed on 2017-05-18. | |||||||
| 61 | tcp | Reserved | 2017-05-18 | This entry has been removed on 2017-05-18. | |||||||
| 61 | udp | Reserved | 2017-05-18 | This entry has been removed on 2017-05-18. | |||||||
| sqlserv | 118 | tcp | SQL Services | Larry Barnes | Larry Barnes | ||||||
| sqlserv | 118 | udp | SQL Services | Larry Barnes | Larry Barnes | ||||||
| ris | 180 | tcp | Intergraph | Dave Buehmann | Dave Buehmann | ||||||
| ris | 180 | udp | Intergraph | Dave Buehmann | Dave Buehmann | ||||||
| unify | 181 | tcp | Unify | Daegis, Inc. | Chris Anderson | 2012-07-31 | |||||
| unify | 181 | udp | Unify | Daegis, Inc. | Chris Anderson | 2012-07-31 | |||||
| audit | 182 | tcp | Unisys Audit SITP | Gil Greenbaum | Gil Greenbaum | ||||||
| audit | 182 | udp | Unisys Audit SITP | Gil Greenbaum | Gil Greenbaum | ||||||
| ocbinder | 183 | tcp | OCBinder | ||||||||
| ocbinder | 183 | udp | OCBinder | ||||||||
| ocserver | 184 | tcp | OCServer | Jerrilynn Okamura | Jerrilynn Okamura | ||||||
| ocserver | 184 | udp | OCServer | Jerrilynn Okamura | Jerrilynn Okamura | ||||||
| remote-kis | 185 | tcp | Remote-KIS | ||||||||
| remote-kis | 185 | udp | Remote-KIS | ||||||||
| kis | 186 | tcp | KIS Protocol | Ralph Droms | Ralph Droms | ||||||
| kis | 186 | udp | KIS Protocol | Ralph Droms | Ralph Droms | ||||||
| aci | 187 | tcp | Application Communication Interface | Rick Carlos | Rick Carlos | ||||||
| aci | 187 | udp | Application Communication Interface | Rick Carlos | Rick Carlos | ||||||
| mumps | 188 | tcp | Plus Five's MUMPS | Hokey Stenn | Hokey Stenn | ||||||
| mumps | 188 | udp | Plus Five's MUMPS | Hokey Stenn | Hokey Stenn | ||||||
| qft | 189 | tcp | Queued File Transport | Wayne Schroeder | Wayne Schroeder | ||||||
| qft | 189 | udp | Queued File Transport | Wayne Schroeder | Wayne Schroeder | ||||||
| mpp | 218 | tcp | Netix Message Posting Protocol | Shannon Yeh | Shannon Yeh | ||||||
| mpp | 218 | udp | Netix Message Posting Protocol | Shannon Yeh | Shannon Yeh | ||||||
| pkix-timestamp | 318 | tcp | PKIX TimeStamp | Robert Zuccherato | Robert Zuccherato | ||||||
| pkix-timestamp | 318 | udp | PKIX TimeStamp | Robert Zuccherato | Robert Zuccherato | ||||||
| hyper-g | 418 | tcp | Hyper-G | Frank Kappe | Frank Kappe | ||||||
| hyper-g | 418 | udp | Hyper-G | Frank Kappe | Frank Kappe | ||||||
| ntalk | 518 | tcp | |||||||||
| ntalk | 518 | udp | |||||||||
| cybercash | 551 | tcp | cybercash | Donald E. Eastlake 3rd | Donald E. Eastlake 3rd | RFC 1898 | |||||
| cybercash | 551 | udp | cybercash | Donald E. Eastlake 3rd | Donald E. Eastlake 3rd | RFC 1898 | |||||
| dei-icda | 618 | tcp | DEI-ICDA | David Turner | David Turner | ||||||
| dei-icda | 618 | udp | DEI-ICDA | David Turner | David Turner | ||||||
| sacred | 1118 | tcp | SACRED | RFC 3767 | |||||||
| sacred | 1118 | udp | SACRED | RFC 3767 | |||||||
| mc-client | 1180 | tcp | Millicent Client Proxy | Steve Glassman | Steve Glassman | ||||||
| mc-client | 1180 | udp | Millicent Client Proxy | Steve Glassman | Steve Glassman | ||||||
| 3comnetman | 1181 | tcp | 3Com Net Management | Peter White | Peter White | 2004-11 | |||||
| 3comnetman | 1181 | udp | 3Com Net Management | Peter White | Peter White | 2004-11 | |||||
| accelenet | 1182 | tcp | AcceleNet Control | ||||||||
| accelenet-data | 1182 | udp | AcceleNet Data | Peter Lepeska | Peter Lepeska | 2010-09-10 | |||||
| llsurfup-http | 1183 | tcp | LL Surfup HTTP | ||||||||
| llsurfup-http | 1183 | udp | LL Surfup HTTP | ||||||||
| llsurfup-https | 1184 | tcp | LL Surfup HTTPS | Katy Lynn McCullough | Katy Lynn McCullough | ||||||
| llsurfup-https | 1184 | udp | LL Surfup HTTPS | Katy Lynn McCullough | Katy Lynn McCullough | ||||||
| catchpole | 1185 | tcp | Catchpole port | Christian Catchpole | Christian Catchpole | 2002-03 | |||||
| catchpole | 1185 | udp | Catchpole port | Christian Catchpole | Christian Catchpole | 2002-03 | |||||
| mysql-cluster | 1186 | tcp | MySQL Cluster Manager | Arjen Lentz | Arjen Lentz | 2004-11 | |||||
| mysql-cluster | 1186 | udp | MySQL Cluster Manager | Arjen Lentz | Arjen Lentz | 2004-11 | |||||
| alias | 1187 | tcp | Alias Service | Paul Tokarchuk | Paul Tokarchuk | 2004-11 | |||||
| alias | 1187 | udp | Alias Service | Paul Tokarchuk | Paul Tokarchuk | 2004-11 | |||||
| hp-webadmin | 1188 | tcp | HP Web Admin | Lance Kind | Lance Kind | ||||||
| hp-webadmin | 1188 | udp | HP Web Admin | Lance Kind | Lance Kind | ||||||
| unet | 1189 | tcp | Unet Connection | Anthony Stahler | Anthony Stahler | 2004-11 | |||||
| unet | 1189 | udp | Unet Connection | Anthony Stahler | Anthony Stahler | 2004-11 | |||||
| aeroflight-ads | 1218 | tcp | AeroFlight-ADs | ||||||||
| aeroflight-ads | 1218 | udp | AeroFlight-ADs | ||||||||
| krb5gatekeeper | 1318 | tcp | krb5gatekeeper | Patrick Moore | Patrick Moore | ||||||
| krb5gatekeeper | 1318 | udp | krb5gatekeeper | Patrick Moore | Patrick Moore | ||||||
| timbuktu-srv2 | 1418 | tcp | Timbuktu Service 2 Port | ||||||||
| timbuktu-srv2 | 1418 | udp | Timbuktu Service 2 Port | ||||||||
| vpvd | 1518 | tcp | Virtual Places Video data | ||||||||
| vpvd | 1518 | udp | Virtual Places Video data | ||||||||
| skytelnet | 1618 | tcp | skytelnet | Byron Jones | Byron Jones | ||||||
| skytelnet | 1618 | udp | skytelnet | Byron Jones | Byron Jones | ||||||
| h323gatedisc | 1718 | tcp | H.323 Multicast Gatekeeper Discover | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h323gatedisc | 1718 | udp | H.323 Multicast Gatekeeper Discover | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| ansys-lm | 1800 | tcp | ANSYS-License manager | Suzanne Lorrin | Suzanne Lorrin | ||||||
| ansys-lm | 1800 | udp | ANSYS-License manager | Suzanne Lorrin | Suzanne Lorrin | ||||||
| msmq | 1801 | tcp | Microsoft Message Que | Amnon Horowitz | Amnon Horowitz | ||||||
| msmq | 1801 | udp | Microsoft Message Que | Amnon Horowitz | Amnon Horowitz | ||||||
| concomp1 | 1802 | tcp | ConComp1 | Ed Vincent | Ed Vincent | ||||||
| concomp1 | 1802 | udp | ConComp1 | Ed Vincent | Ed Vincent | ||||||
| hp-hcip-gwy | 1803 | tcp | HP-HCIP-GWY | Allen Baker | Allen Baker | ||||||
| hp-hcip-gwy | 1803 | udp | HP-HCIP-GWY | Allen Baker | Allen Baker | ||||||
| enl | 1804 | tcp | ENL | Brian Olson | Brian Olson | ||||||
| enl | 1804 | udp | ENL | Brian Olson | Brian Olson | ||||||
| enl-name | 1805 | tcp | ENL-Name | Brian Olson | Brian Olson | ||||||
| enl-name | 1805 | udp | ENL-Name | Brian Olson | Brian Olson | ||||||
| musiconline | 1806 | tcp | Musiconline | Craig Weeks | Craig Weeks | ||||||
| musiconline | 1806 | udp | Musiconline | Craig Weeks | Craig Weeks | ||||||
| fhsp | 1807 | tcp | Fujitsu Hot Standby Protocol | Eiki Iwata | Eiki Iwata | ||||||
| fhsp | 1807 | udp | Fujitsu Hot Standby Protocol | Eiki Iwata | Eiki Iwata | ||||||
| oracle-vp2 | 1808 | tcp | Oracle-VP2 | Craig Fowler | Craig Fowler | ||||||
| oracle-vp2 | 1808 | udp | Oracle-VP2 | Craig Fowler | Craig Fowler | ||||||
| oracle-vp1 | 1809 | tcp | Oracle-VP1 | Craig Fowler | Craig Fowler | ||||||
| oracle-vp1 | 1809 | udp | Oracle-VP1 | Craig Fowler | Craig Fowler | ||||||
| jerand-lm | 1810 | tcp | Jerand License Manager | Robert Monat | Robert Monat | ||||||
| jerand-lm | 1810 | udp | Jerand License Manager | Robert Monat | Robert Monat | ||||||
| scientia-sdb | 1811 | tcp | Scientia-SDB | SYSTEMS MANAGER | SYSTEMS MANAGER | ||||||
| scientia-sdb | 1811 | udp | Scientia-SDB | SYSTEMS MANAGER | SYSTEMS MANAGER | ||||||
| radius | 1812 | tcp | RADIUS | RFC 2865 | |||||||
| radius | 1812 | udp | RADIUS | RFC 2865 |