Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 24 | tcp | any private mail system | Rick Adams | Rick Adams | |||||||
| 24 | udp | any private mail system | Rick Adams | Rick Adams | |||||||
| 51 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| ansatrader | 124 | tcp | ANSA REX Trader | Nicola J. Howarth | Nicola J. Howarth | ||||||
| ansatrader | 124 | udp | ANSA REX Trader | Nicola J. Howarth | Nicola J. Howarth | ||||||
| masqdialer | 224 | tcp | masqdialer | Charles Wright | Charles Wright | Possible Conflict of Port 222 with "Masqdialer" | |||||
| masqdialer | 224 | udp | masqdialer | Charles Wright | Charles Wright | Possible Conflict of Port 222 with "Masqdialer" | |||||
| 225-241 | Reserved | 2024-12-20 | RFC 1060 | ||||||||
| direct | 242 | tcp | Direct | Herb Sutter | Paul Horton | ||||||
| direct | 242 | udp | Direct | Herb Sutter | Paul Horton | ||||||
| sur-meas | 243 | tcp | Survey Measurement | Dave Clark | Dave Clark | ||||||
| sur-meas | 243 | udp | Survey Measurement | Dave Clark | Dave Clark | ||||||
| inbusiness | 244 | tcp | inbusiness | Derrick Hisatake | Derrick Hisatake | ||||||
| inbusiness | 244 | udp | inbusiness | Derrick Hisatake | Derrick Hisatake | ||||||
| link | 245 | tcp | LINK | ||||||||
| link | 245 | udp | LINK | ||||||||
| dsp3270 | 246 | tcp | Display Systems Protocol | Weldon J. Showalter | Weldon J. Showalter | ||||||
| dsp3270 | 246 | udp | Display Systems Protocol | Weldon J. Showalter | Weldon J. Showalter | ||||||
| subntbcst-tftp | 247 | tcp | SUBNTBCST_TFTP IANA assigned this well-formed service name as a replacement for "subntbcst_tftp". |
John Fake | John Fake | ||||||
| subntbcst_tftp | 247 | tcp | SUBNTBCST_TFTP | John Fake | John Fake | This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| subntbcst-tftp | 247 | udp | SUBNTBCST_TFTP IANA assigned this well-formed service name as a replacement for "subntbcst_tftp". |
John Fake | John Fake | ||||||
| subntbcst_tftp | 247 | udp | SUBNTBCST_TFTP | John Fake | John Fake | This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| bhfhs | 248 | tcp | bhfhs | John Kelly | John Kelly | ||||||
| bhfhs | 248 | udp | bhfhs | John Kelly | John Kelly | ||||||
| 249-255 | Reserved | 2024-12-20 | RFC 1060 | ||||||||
| rpki-rtr-tls | 324 | tcp | Resource PKI to Router Protocol over TLS | IESG | IETF Chair | RFC 6810 | |||||
| 324 | udp | Reserved | |||||||||
| opc-job-track | 424 | tcp | IBM Operations Planning and Control Track | Conny Larsson | Conny Larsson | ||||||
| opc-job-track | 424 | udp | IBM Operations Planning and Control Track | Conny Larsson | Conny Larsson | ||||||
| ncp | 524 | tcp | NCP | Don Provan | Don Provan | ||||||
| ncp | 524 | udp | NCP | Don Provan | Don Provan | ||||||
| cryptoadmin | 624 | tcp | Crypto Admin | Tony Walker | Tony Walker | ||||||
| cryptoadmin | 624 | udp | Crypto Admin | Tony Walker | Tony Walker | ||||||
| netconf-ssh | 830 | tcp | NETCONF over SSH | RFC 6242 | |||||||
| netconf-ssh | 830 | udp | NETCONF over SSH | RFC 6242 | |||||||
| 1024 | tcp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| 1024 | udp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| 1030 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| 1031 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| 1032 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| hpvmmcontrol | 1124 | tcp | HP VMM Control | ||||||||
| hpvmmcontrol | 1124 | udp | HP VMM Control | ||||||||
| vpnz | 1224 | tcp | VPNz | Tom Strack | Tom Strack | ||||||
| vpnz | 1224 | udp | VPNz | Tom Strack | Tom Strack | ||||||
| instantia | 1240 | tcp | Instantia | Ruth Slater | Ruth Slater | ||||||
| instantia | 1240 | udp | Instantia | Ruth Slater | Ruth Slater | ||||||
| nessus | 1241 | tcp | nessus | Jordan Hrycaj | Jordan Hrycaj | ||||||
| nessus | 1241 | udp | nessus | Jordan Hrycaj | Jordan Hrycaj | ||||||
| nmasoverip | 1242 | tcp | NMAS over IP | Hal Henderson | Hal Henderson | ||||||
| nmasoverip | 1242 | udp | NMAS over IP | Hal Henderson | Hal Henderson | ||||||
| serialgateway | 1243 | tcp | SerialGateway | Stephen LaValley | Stephen LaValley | ||||||
| serialgateway | 1243 | udp | SerialGateway | Stephen LaValley | Stephen LaValley | ||||||
| isbconference1 | 1244 | tcp | isbconference1 | ||||||||
| isbconference1 | 1244 | udp | isbconference1 | ||||||||
| isbconference2 | 1245 | tcp | isbconference2 | Arnold Dittmann | Arnold Dittmann | ||||||
| isbconference2 | 1245 | udp | isbconference2 | Arnold Dittmann | Arnold Dittmann | ||||||
| payrouter | 1246 | tcp | payrouter | David Wilson | David Wilson | ||||||
| payrouter | 1246 | udp | payrouter | David Wilson | David Wilson | ||||||
| visionpyramid | 1247 | tcp | VisionPyramid | Gavin Hutchinson | Gavin Hutchinson | ||||||
| visionpyramid | 1247 | udp | VisionPyramid | Gavin Hutchinson | Gavin Hutchinson | ||||||
| hermes | 1248 | tcp | hermes | ||||||||
| hermes | 1248 | udp | hermes | ||||||||
| mesavistaco | 1249 | tcp | Mesa Vista Co | Rick LaBanca | Rick LaBanca | ||||||
| mesavistaco | 1249 | udp | Mesa Vista Co | Rick LaBanca | Rick LaBanca | ||||||
| delta-mcp | 1324 | tcp | delta-mcp | Quinton Tormanen | Quinton Tormanen | ||||||
| delta-mcp | 1324 | udp | delta-mcp | Quinton Tormanen | Quinton Tormanen | ||||||
| hybrid | 1424 | tcp | Hybrid Encryption Protocol | Howard Hart | Howard Hart | ||||||
| hybrid | 1424 | udp | Hybrid Encryption Protocol | Howard Hart | Howard Hart | ||||||
| ingreslock | 1524 | tcp | ingres | ||||||||
| ingreslock | 1524 | udp | ingres | ||||||||
| udp-sr-port | 1624 | tcp | udp-sr-port | Herb Jensen | Herb Jensen | ||||||
| udp-sr-port | 1624 | udp | udp-sr-port | Herb Jensen | Herb Jensen | ||||||
| csbphonemaster | 1724 | tcp | csbphonemaster | Hans-Peter Heffels | Hans-Peter Heffels | ||||||
| csbphonemaster | 1724 | udp | csbphonemaster | Hans-Peter Heffels | Hans-Peter Heffels | ||||||
| metrics-pas | 1824 | tcp | metrics-pas | Tom Haapanen | Tom Haapanen | ||||||
| metrics-pas | 1824 | udp | metrics-pas | Tom Haapanen | Tom Haapanen | ||||||
| xiip | 1924 | tcp | XIIP | Alain Robert | Alain Robert | ||||||
| xiip | 1924 | udp | XIIP | Alain Robert | Alain Robert | ||||||
| xinuexpansion4 | 2024 | tcp | |||||||||
| xinuexpansion4 | 2024 | udp | |||||||||
| elatelink | 2124 | tcp | ELATELINK | Tim Lawrence | Tim Lawrence | ||||||
| elatelink | 2124 | udp | ELATELINK | Tim Lawrence | Tim Lawrence | ||||||
| efi-mg | 2224 | tcp | Easy Flexible Internet/Multiplayer Games | Thomas Efer | Thomas Efer | 2006-03 | |||||
| efi-mg | 2224 | udp | Easy Flexible Internet/Multiplayer Games | Thomas Efer | Thomas Efer | 2006-03 | |||||
| recipe | 2240 | tcp | RECIPe | Charlie Limoges | Charlie Limoges | 1997-12-16 | |||||
| recipe | 2240 | udp | RECIPe | Charlie Limoges | Charlie Limoges | 1997-12-16 | |||||
| ivsd | 2241 | tcp | IVS Daemon | Thierry Turletti | Thierry Turletti | ||||||
| ivsd | 2241 | udp | IVS Daemon | Thierry Turletti | Thierry Turletti | ||||||
| foliocorp | 2242 | tcp | Folio Remote Server | Pat Mcgowan | Pat Mcgowan | ||||||
| foliocorp | 2242 | udp | Folio Remote Server | Pat Mcgowan | Pat Mcgowan | ||||||
| magicom | 2243 | tcp | Magicom Protocol | Yossi Appleboum | Yossi Appleboum | ||||||
| magicom | 2243 | udp | Magicom Protocol | Yossi Appleboum | Yossi Appleboum | ||||||
| nmsserver | 2244 | tcp | NMS Server | Dmitry Krasnonosenkikh | Dmitry Krasnonosenkikh | ||||||
| nmsserver | 2244 | udp | NMS Server | Dmitry Krasnonosenkikh | Dmitry Krasnonosenkikh | ||||||
| hao | 2245 | tcp | HaO | Panic Ride | Panic Ride | ||||||
| hao | 2245 | udp | HaO | Panic Ride | Panic Ride | ||||||
| pc-mta-addrmap | 2246 | tcp | PacketCable MTA Addr Map | Dave Maxwell | Dave Maxwell | ||||||
| pc-mta-addrmap | 2246 | udp | PacketCable MTA Addr Map | Dave Maxwell | Dave Maxwell | ||||||
| antidotemgrsvr | 2247 | tcp | Antidote Deployment Manager Service | Rod Waltermann | Rod Waltermann | 2006-02 | |||||
| antidotemgrsvr | 2247 | udp | Antidote Deployment Manager Service | Rod Waltermann | Rod Waltermann | 2006-02 |