Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 2 | tcp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 2 | udp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 3 | tcp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 3 | udp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| ssh | 22 | tcp | The Secure Shell (SSH) Protocol | RFC 4251 | Defined TXT keys: u=<username> p=<password> | ||||||
| ssh | 22 | udp | The Secure Shell (SSH) Protocol | RFC 4251 | Defined TXT keys: u=<username> p=<password> | ||||||
| smtp | 25 | tcp | Simple Mail Transfer | IESG | IETF Chair | 2017-06-05 | RFC-ietf-emailcore-rfc5321bis-43 | ||||
| smtp | 25 | udp | Simple Mail Transfer | IESG | IETF Chair | 2017-06-05 | RFC-ietf-emailcore-rfc5321bis-43 | ||||
| locus-map | 125 | tcp | Locus PC-Interface Net Map Ser | Eric Peterson | Eric Peterson | ||||||
| locus-map | 125 | udp | Locus PC-Interface Net Map Ser | Eric Peterson | Eric Peterson | ||||||
| 225-241 | Reserved | 2024-12-20 | RFC 1060 | ||||||||
| 249-255 | Reserved | 2024-12-20 | RFC 1060 | ||||||||
| rap | 256 | tcp | RAP | J. S. Greenfield | J. S. Greenfield | ||||||
| rap | 256 | udp | RAP | J. S. Greenfield | J. S. Greenfield | ||||||
| set | 257 | tcp | Secure Electronic Transaction | Donald Eastlake | Donald Eastlake | ||||||
| set | 257 | udp | Secure Electronic Transaction | Donald Eastlake | Donald Eastlake | ||||||
| 258 | Unassigned | 2006-09-13 | |||||||||
| esro-gen | 259 | tcp | Efficient Short Remote Operations | Mohsen Banan | Mohsen Banan | ||||||
| esro-gen | 259 | udp | Efficient Short Remote Operations | Mohsen Banan | Mohsen Banan | ||||||
| 325-332 | Unassigned | ||||||||||
| icad-el | 425 | tcp | ICAD | Larry Stone | Larry Stone | ||||||
| icad-el | 425 | udp | ICAD | Larry Stone | Larry Stone | ||||||
| timed | 525 | tcp | timeserver | ||||||||
| timed | 525 | udp | timeserver | ||||||||
| dec-dlm | 625 | tcp | DEC DLM IANA assigned this well-formed service name as a replacement for "dec_dlm". |
Rudi Martin | Rudi Martin | ||||||
| dec_dlm | 625 | tcp | DEC DLM | Rudi Martin | Rudi Martin | This entry is an alias to "dec-dlm". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| dec-dlm | 625 | udp | DEC DLM IANA assigned this well-formed service name as a replacement for "dec_dlm". |
Rudi Martin | Rudi Martin | ||||||
| dec_dlm | 625 | udp | DEC DLM | Rudi Martin | Rudi Martin | This entry is an alias to "dec-dlm". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| domain-s | 853 | udp | DNS query-response protocol run over DTLS or QUIC | IESG | IETF Chair | 2015-10-08 | 2022-04-01 | RFC 7858; RFC 8094; RFC 9250 | |||
| blackjack | 1025 | tcp | network blackjack | ||||||||
| blackjack | 1025 | udp | network blackjack | ||||||||
| hpvmmagent | 1125 | tcp | HP VMM Agent | ||||||||
| hpvmmagent | 1125 | udp | HP VMM Agent | ||||||||
| slinkysearch | 1225 | tcp | SLINKYSEARCH | Desmond Chan | Desmond Chan | ||||||
| slinkysearch | 1225 | udp | SLINKYSEARCH | Desmond Chan | Desmond Chan | ||||||
| swldy-sias | 1250 | tcp | swldy-sias | Peter E Williams | Peter E Williams | ||||||
| swldy-sias | 1250 | udp | swldy-sias | Peter E Williams | Peter E Williams | ||||||
| servergraph | 1251 | tcp | servergraph | Lindsay Morris | Lindsay Morris | ||||||
| servergraph | 1251 | udp | servergraph | Lindsay Morris | Lindsay Morris | ||||||
| bspne-pcc | 1252 | tcp | bspne-pcc | ||||||||
| bspne-pcc | 1252 | udp | bspne-pcc | ||||||||
| q55-pcc | 1253 | tcp | q55-pcc | Prem Tirilok | Prem Tirilok | ||||||
| q55-pcc | 1253 | udp | q55-pcc | Prem Tirilok | Prem Tirilok | ||||||
| de-noc | 1254 | tcp | de-noc | ||||||||
| de-noc | 1254 | udp | de-noc | ||||||||
| de-cache-query | 1255 | tcp | de-cache-query | ||||||||
| de-cache-query | 1255 | udp | de-cache-query | ||||||||
| de-server | 1256 | tcp | de-server | Jeff Burdette | Jeff Burdette | ||||||
| de-server | 1256 | udp | de-server | Jeff Burdette | Jeff Burdette | ||||||
| shockwave2 | 1257 | tcp | Shockwave 2 | Dave Simmons | Dave Simmons | ||||||
| shockwave2 | 1257 | udp | Shockwave 2 | Dave Simmons | Dave Simmons | ||||||
| opennl | 1258 | tcp | Open Network Library | Phil Frisbie | Phil Frisbie | ||||||
| opennl | 1258 | udp | Open Network Library | Phil Frisbie | Phil Frisbie | ||||||
| opennl-voice | 1259 | tcp | Open Network Library Voice | Phil Frisbie | Phil Frisbie | ||||||
| opennl-voice | 1259 | udp | Open Network Library Voice | Phil Frisbie | Phil Frisbie | ||||||
| dx-instrument | 1325 | tcp | Thermo Fisher Scientific Instrumentation (Formally Dionex) | Thermo Fisher Scientific | Simon Cubbon | 2025-09-22 | |||||
| dx-instrument | 1325 | udp | Thermo Fisher Scientific Instrumentation (Formally Dionex) | Thermo Fisher Scientific | Simon Cubbon | 2025-09-22 | |||||
| zion-lm | 1425 | tcp | Zion Software License Manager | David Ferrero | David Ferrero | ||||||
| zion-lm | 1425 | udp | Zion Software License Manager | David Ferrero | David Ferrero | ||||||
| eicon-x25 | 1439 | tcp | Eicon X25/SNA Gateway | ||||||||
| eicon-x25 | 1439 | udp | Eicon X25/SNA Gateway | ||||||||
| orasrv | 1525 | tcp | oracle | ||||||||
| orasrv | 1525 | udp | oracle | ||||||||
| prospero-np | 1525 | tcp | Prospero Directory Service non-priv | ||||||||
| prospero-np | 1525 | udp | Prospero Directory Service non-priv | ||||||||
| svs-omagent | 1625 | tcp | svs-omagent | Alberto Berlen | Alberto Berlen | ||||||
| svs-omagent | 1625 | udp | svs-omagent | Alberto Berlen | Alberto Berlen | ||||||
| iden-ralp | 1725 | tcp | iden-ralp | Chris Stanaway | Chris Stanaway | ||||||
| iden-ralp | 1725 | udp | iden-ralp | Chris Stanaway | Chris Stanaway | ||||||
| direcpc-video | 1825 | tcp | DirecPC Video | Chris Kerrigan | Chris Kerrigan | ||||||
| direcpc-video | 1825 | udp | DirecPC Video | Chris Kerrigan | Chris Kerrigan | ||||||
| discovery-port | 1925 | tcp | Surrogate Discovery Port | Keith Thompson | Keith Thompson | ||||||
| discovery-port | 1925 | udp | Surrogate Discovery Port | Keith Thompson | Keith Thompson | ||||||
| x25-svc-port | 1998 | tcp | cisco X.25 service (XOT) | ||||||||
| x25-svc-port | 1998 | udp | cisco X.25 service (XOT) | ||||||||
| ellpack | 2025 | tcp | |||||||||
| xribs | 2025 | udp | |||||||||
| h2250-annex-g | 2099 | tcp | H.225.0 Annex G Signalling | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h2250-annex-g | 2099 | udp | H.225.0 Annex G Signalling | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| lockstep | 2125 | tcp | LOCKSTEP | Karl Forster | Karl Forster | ||||||
| lockstep | 2125 | udp | LOCKSTEP | Karl Forster | Karl Forster | ||||||
| rcip-itu | 2225 | tcp | Resource Connection Initiation Protocol | ITU TSB, Place des Nations, CH-1211 Geneva 20 | ITU TSB, Place des Nations, CH-1211 Geneva 20 | ||||||
| 2225 | udp | Reserved | |||||||||
| rcip-itu | 2225 | sctp | Resource Connection Initiation Protocol | ITU TSB, Place des Nations, CH-1211 Geneva 20 | ITU TSB, Place des Nations, CH-1211 Geneva 20 | ||||||
| remote-collab | 2250 | tcp | remote-collab | Richard Walters | Richard Walters | ||||||
| remote-collab | 2250 | udp | remote-collab | Richard Walters | Richard Walters | ||||||
| dif-port | 2251 | tcp | Distributed Framework Port | Sebastien Lambla | Sebastien Lambla | ||||||
| dif-port | 2251 | udp | Distributed Framework Port | Sebastien Lambla | Sebastien Lambla | ||||||
| njenet-ssl | 2252 | tcp | NJENET using SSL | Hans U Schmidt | Hans U Schmidt | ||||||
| njenet-ssl | 2252 | udp | NJENET using SSL | Hans U Schmidt | Hans U Schmidt | ||||||
| dtv-chan-req | 2253 | tcp | DTV Channel Request | Richard Hodges | Richard Hodges | ||||||
| dtv-chan-req | 2253 | udp | DTV Channel Request | Richard Hodges | Richard Hodges | ||||||
| seispoc | 2254 | tcp | Seismic P.O.C. Port | Robert Reimiller | Robert Reimiller | ||||||
| seispoc | 2254 | udp | Seismic P.O.C. Port | Robert Reimiller | Robert Reimiller | ||||||
| vrtp | 2255 | tcp | VRTP - ViRtue Transfer Protocol | Max Fudim | Max Fudim | ||||||
| vrtp | 2255 | udp | VRTP - ViRtue Transfer Protocol | Max Fudim | Max Fudim | ||||||
| pcc-mfp | 2256 | tcp | PCC MFP | Kunihiko Morota | Kunihiko Morota | 2005-08 | |||||
| pcc-mfp | 2256 | udp | PCC MFP | Kunihiko Morota | Kunihiko Morota | 2005-08 | |||||
| simple-tx-rx | 2257 | tcp | simple text/file transfer | Daniel Kilsdonk | Daniel Kilsdonk | 2006-08 | |||||
| simple-tx-rx | 2257 | udp | simple text/file transfer | Daniel Kilsdonk | Daniel Kilsdonk | 2006-08 |