Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
0 tcp Reserved 2024-12-20 RFC 6335
0 udp Reserved 2024-12-20 RFC 6335
35 tcp any private printer server Jon Postel Jon Postel
35 udp any private printer server Jon Postel Jon Postel
epmap 135 tcp DCE endpoint resolution Joe Pato Joe Pato
epmap 135 udp DCE endpoint resolution Joe Pato Joe Pato
imap 143 tcp Internet Message Access Protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 9051
matip-type-a 350 tcp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-a 350 udp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-b 351 tcp MATIP Type B Alain Robert Alain Robert RFC 2351
matip-type-b 351 udp MATIP Type B Alain Robert Alain Robert RFC 2351
bhoetty 351 tcp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoetty 351 udp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
dtag-ste-sb 352 tcp DTAG Ruediger Wald Ruediger Wald (assigned long ago)
dtag-ste-sb 352 udp DTAG Ruediger Wald Ruediger Wald (assigned long ago)
bhoedap4 352 tcp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 udp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
ndsauth 353 tcp NDSAUTH Jayakumar Ramalingam Jayakumar Ramalingam
ndsauth 353 udp NDSAUTH Jayakumar Ramalingam Jayakumar Ramalingam
bh611 354 tcp bh611 John Kelly John Kelly
bh611 354 udp bh611 John Kelly John Kelly
datex-asn 355 tcp DATEX-ASN Kenneth Vaughn Kenneth Vaughn
datex-asn 355 udp DATEX-ASN Kenneth Vaughn Kenneth Vaughn
cloanto-net-1 356 tcp Cloanto Net 1 Michael Battilana Michael Battilana 2010-04-30
cloanto-net-1 356 udp Cloanto Net 1 Michael Battilana Michael Battilana 2010-04-30
bhevent 357 tcp bhevent John Kelly John Kelly
bhevent 357 udp bhevent John Kelly John Kelly
shrinkwrap 358 tcp Shrinkwrap Bill Simpson Bill Simpson
shrinkwrap 358 udp Shrinkwrap Bill Simpson Bill Simpson
359 tcp Reserved 2023-11-16 De-Assigned on 2023-11-16.
359 udp Reserved 2023-11-16 De-Assigned on 2023-11-16.
mobilip-mn 435 tcp MobilIP-MN Kannan Alagappan Kannan Alagappan
mobilip-mn 435 udp MobilIP-MN Kannan Alagappan Kannan Alagappan
iiop 535 tcp iiop Jeff M.Michaud Jeff M.Michaud
iiop 535 udp iiop Jeff M.Michaud Jeff M.Michaud
xmlrpc-beep 602 tcp XML-RPC over BEEP RFC 3529
xmlrpc-beep 602 udp XML-RPC over BEEP RFC 3529
rlzdbase 635 tcp RLZ DBase Michael Ginn Michael Ginn
rlzdbase 635 udp RLZ DBase Michael Ginn Michael Ginn
gdoi 848 tcp GDOI RFC 3547
gdoi 848 udp GDOI RFC 3547
twamp-control 862 tcp TWAMP-Control IESG IETF Chair RFC 5357
imaps 993 tcp IMAP over TLS protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 8314; RFC 9051
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 tcp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 udp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 sctp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 dccp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
1023 tcp Reserved 2024-12-20 RFC 6335
1023 udp Reserved 2024-12-20 RFC 6335
1024 tcp Reserved 2024-12-20 RFC 6335
1024 udp Reserved 2024-12-20 RFC 6335
mxxrlogin 1035 tcp MX-XR RPC Valassis John Eckert 2003-04 2015-05-05
mxxrlogin 1035 udp MX-XR RPC Valassis John Eckert 2003-04 2015-05-05
omnivision 1135 tcp OmniVision Communication Service Serge Vacquier Serge Vacquier 2006-02
omnivision 1135 udp OmniVision Communication Service Serge Vacquier Serge Vacquier 2006-02
mosaicsyssvc1 1235 tcp mosaicsyssvc1 Brian Matthews Brian Matthews
mosaicsyssvc1 1235 udp mosaicsyssvc1 Brian Matthews Brian Matthews
digital-notary 1335 tcp Digital Notary Protocol Wes Doonan Wes Doonan
digital-notary 1335 udp Digital Notary Protocol Wes Doonan Wes Doonan
editbench 1350 tcp Registration Network Protocol Simson L. Garfinkel Simson L. Garfinkel
editbench 1350 udp Registration Network Protocol Simson L. Garfinkel Simson L. Garfinkel
equationbuilder 1351 tcp Digital Tool Works (MIT) Terrence J. Talbot Terrence J. Talbot
equationbuilder 1351 udp Digital Tool Works (MIT) Terrence J. Talbot Terrence J. Talbot
lotusnote 1352 tcp Lotus Note Greg Pflaum Greg Pflaum 1992-07
lotusnote 1352 udp Lotus Note Greg Pflaum Greg Pflaum 1992-07
relief 1353 tcp Relief Consulting John Feiler John Feiler
relief 1353 udp Relief Consulting John Feiler John Feiler
XSIP-network 1354 tcp Five Across XSIP Network Glenn Reid Glenn Reid
XSIP-network 1354 udp Five Across XSIP Network Glenn Reid Glenn Reid
intuitive-edge 1355 tcp Intuitive Edge Montgomery Zukowski Montgomery Zukowski
intuitive-edge 1355 udp Intuitive Edge Montgomery Zukowski Montgomery Zukowski
cuillamartin 1356 tcp CuillaMartin Company
cuillamartin 1356 udp CuillaMartin Company
pegboard 1357 tcp Electronic PegBoard Chris Cuilla Chris Cuilla
pegboard 1357 udp Electronic PegBoard Chris Cuilla Chris Cuilla
connlcli 1358 tcp CONNLCLI
connlcli 1358 udp CONNLCLI
ftsrv 1359 tcp FTSRV Ines Homem de Melo Ines Homem de Melo
ftsrv 1359 udp FTSRV Ines Homem de Melo Ines Homem de Melo
ibm-cics 1435 tcp IBM CICS Geoff Meacock Geoff Meacock
ibm-cics 1435 udp IBM CICS Geoff Meacock Geoff Meacock
ampr-info 1535 tcp ampr-info
ampr-info 1535 udp ampr-info
edb-server1 1635 tcp EDB Server 1 Carlos Portela Carlos Portela
edb-server1 1635 udp EDB Server 1 Carlos Portela Carlos Portela
privatechat 1735 tcp PrivateChat Louis E. Simard Louis E. Simard
privatechat 1735 udp PrivateChat Louis E. Simard Louis E. Simard
ardusmul 1835 tcp ARDUS Multicast Toshikatsu Ito Toshikatsu Ito
ardusmul 1835 udp ARDUS Multicast Toshikatsu Ito Toshikatsu Ito
macromedia-fcs 1935 tcp Macromedia Flash Communications Server MX Pritham Shetty Pritham Shetty
macromedia-fcs 1935 udp Macromedia Flash Communications server MX Pritham Shetty Pritham Shetty
imsldoc 2035 tcp
imsldoc 2035 udp
gris 2135 tcp Grid Resource Information Server Steve Tuecke Steve Tuecke
gris 2135 udp Grid Resource Information Server Steve Tuecke Steve Tuecke
sercomm-wlink 2235 tcp Sercomm-WLink Melinda Tsao Melinda Tsao

Contact Information

Name Organization Contact URI Last Updated
Alain Robert arobert&par.sita.int
Bill Simpson wsimpson&greendragon.com
Brian Matthews bmatthews&mosaicsystems.com
Carlos Portela cportela&simple-sw.com 2003-02
Chris Cuilla balr!vpnet!cuilla!chris&clout.chi.il.us
Geoff Meacock gbibmswl&ibmmail.com
Glenn Reid port-reg&fiveacross.com 2004-11
Greg Pflaum iris.com!Greg_Pflaum&uunet.uu.net 1992-07
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ines Homem de Melo sidinf&brfapesp.bitnet
Jayakumar Ramalingam jayakumar&novell.com
Jeff M.Michaud michaud&zk3.dec.com
Joe Pato pato&apollo.hp.com
John Eckert Valassis eckertj&valassis.com 2015-05-05
John Feiler relief!jjfeiler&uu2.psi.com
John Kelly johnk&bellhow.com
Jon Postel postel&isi.edu
Kannan Alagappan kannan&sejour.lkg.dec.com
Kenneth Vaughn kvaughn&mail.viggen.com
Louis E. Simard 76400.3371&compuserve.com
Melinda Tsao melinda&tpe1.sercomm.com.tw
Michael Battilana mcb-iana&cloanto.net 2010-04-30
Michael Ginn ginn&tyxar.com
Montgomery Zukowski monty&nextnorth.acs.ohio-state.edu
Pritham Shetty pritham&macromedia.com
Ruediger Wald wald&ez-darmstadt.telekom.de
Serge Vacquier svacquier&axway.com 2019-03-29
Simson L. Garfinkel simsong&next.cambridge.ma.us
Steve Tuecke tuecke&mcs.anl.gov
Terrence J. Talbot lexcube!tjt&bu.edu
Toshikatsu Ito ito-t&pfu.co.jp
Valassis eckertj&valassis.com 2015-05-05
Wes Doonan