Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
telnet 23 tcp Telnet [Jon_Postel] [Jon_Postel] [RFC 854] Defined TXT keys: u=<username> p=<password>
telnet 23 udp Telnet [Jon_Postel] [Jon_Postel] [RFC 854] Defined TXT keys: u=<username> p=<password>
xns-ch 54 tcp XNS Clearinghouse [Susie_Armstrong] [Susie_Armstrong]
xns-ch 54 udp XNS Clearinghouse [Susie_Armstrong] [Susie_Armstrong]
netsc-prod 154 tcp NETSC
netsc-prod 154 udp NETSC
manet 269 tcp MANET Protocols [RFC 5498]
manet 269 udp MANET Protocols [RFC 5498]
bh611 354 tcp bh611 [John_Kelly] [John_Kelly]
bh611 354 udp bh611 [John_Kelly] [John_Kelly]
contentserver 454 tcp ContentServer
contentserver 454 udp ContentServer
syslog 514 udp 2020-06-01 [RFC 5426]
uucp 540 tcp uucpd
uucp 540 udp uucpd
uucp-rlogin 541 tcp uucp-rlogin [Stuart_Lynne] [Stuart_Lynne]
uucp-rlogin 541 udp uucp-rlogin [Stuart_Lynne] [Stuart_Lynne]
commerce 542 tcp commerce [Randy_Epstein] [Randy_Epstein]
commerce 542 udp commerce [Randy_Epstein] [Randy_Epstein]
klogin 543 tcp
klogin 543 udp
kshell 544 tcp krcmd
kshell 544 udp krcmd
appleqtcsrvr 545 tcp appleqtcsrvr [Murali_Ranganathan] [Murali_Ranganathan]
appleqtcsrvr 545 udp appleqtcsrvr [Murali_Ranganathan] [Murali_Ranganathan]
dhcpv6-client 546 tcp DHCPv6 Client
dhcpv6-client 546 udp DHCPv6 Client [IESG] [IETF_Chair] 2018-05-21 [RFC 9915]
dhcpv6-server 547 tcp DHCPv6 Server [IESG] [IETF_Chair] 2018-05-21 [RFC 5460]
dhcpv6-server 547 udp DHCPv6 Server [IESG] [IETF_Chair] 2018-05-21 [RFC 9915]
afpovertcp 548 tcp AFP over TCP [Leland_Wallace] [Leland_Wallace] Defined TXT keys: u=<username> p=<password> path=<path>
afpovertcp 548 udp AFP over TCP [Leland_Wallace] [Leland_Wallace] Defined TXT keys: u=<username> p=<password> path=<path>
idfp 549 tcp IDFP [Ramana_Kovi] [Ramana_Kovi]
idfp 549 udp IDFP [Ramana_Kovi] [Ramana_Kovi]
rtsp 554 tcp Real Time Streaming Protocol (RTSP) [Rob_Lanphier] [Rob_Lanphier]
rtsp 554 udp Real Time Streaming Protocol (RTSP) [Rob_Lanphier] [Rob_Lanphier]
aodv 654 tcp AODV [Charles_Perkins] [Charles_Perkins]
aodv 654 udp AODV [Charles_Perkins] [Charles_Perkins]
tell 754 tcp send [Josyula_R_Rao] [Josyula_R_Rao]
tell 754 udp send [Josyula_R_Rao] [Josyula_R_Rao]
gdoi 848 tcp GDOI [RFC 3547]
gdoi 848 udp GDOI [RFC 3547]
dlep 854 tcp Dynamic Link Exchange Protocol (DLEP) [IESG] [IETF_Chair] 2017-04-03 [RFC 8175]
dlep 854 udp Dynamic Link Exchange Protocol (DLEP) [IESG] [IETF_Chair] 2017-04-03 [RFC 8175]
owamp-test 861 udp OWAMP-Test [IESG] [IETF_Chair] 2018-12-21 [RFC 8545]
twamp-test 862 udp TWAMP-Test Receiver Port [IESG] [IETF_Chair] 2018-12-21 [RFC 8545]
954-988 Unassigned
brvread 1054 tcp BRVREAD [A_Boninn] [A_Boninn]
brvread 1054 udp BRVREAD [A_Boninn] [A_Boninn]
resacommunity 1154 tcp Community Service [Stephane_MONS] [Stephane_MONS] 2005-09
resacommunity 1154 udp Community Service [Stephane_MONS] [Stephane_MONS] 2005-09
de-noc 1254 tcp de-noc
de-noc 1254 udp de-noc
XSIP-network 1354 tcp Five Across XSIP Network [Glenn_Reid] [Glenn_Reid]
XSIP-network 1354 udp Five Across XSIP Network [Glenn_Reid] [Glenn_Reid]
interhdl-elmd 1454 tcp interHDL License Manager

IANA assigned this well-formed service name as a replacement for "interhdl_elmd".
[Eli_Sternheim] [Eli_Sternheim]
interhdl_elmd 1454 tcp interHDL License Manager [Eli_Sternheim] [Eli_Sternheim] This entry is an alias to "interhdl-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
interhdl-elmd 1454 udp interHDL License Manager

IANA assigned this well-formed service name as a replacement for "interhdl_elmd".
[Eli_Sternheim] [Eli_Sternheim]
interhdl_elmd 1454 udp interHDL License Manager [Eli_Sternheim] [Eli_Sternheim] This entry is an alias to "interhdl-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
rds 1540 tcp rds
rds 1540 udp rds
rds2 1541 tcp rds2 [Sudhakar_Rajamannar] [Sudhakar_Rajamannar]
rds2 1541 udp rds2 [Sudhakar_Rajamannar] [Sudhakar_Rajamannar]
gridgen-elmd 1542 tcp gridgen-elmd [John_R_Chawner] [John_R_Chawner]
gridgen-elmd 1542 udp gridgen-elmd [John_R_Chawner] [John_R_Chawner]
simba-cs 1543 tcp simba-cs [Betsy_Alexander] [Betsy_Alexander]
simba-cs 1543 udp simba-cs [Betsy_Alexander] [Betsy_Alexander]
aspeclmd 1544 tcp aspeclmd [V_Balaji] [V_Balaji]
aspeclmd 1544 udp aspeclmd [V_Balaji] [V_Balaji]
vistium-share 1545 tcp vistium-share [Allison_Carleton] [Allison_Carleton]
vistium-share 1545 udp vistium-share [Allison_Carleton] [Allison_Carleton]
abbaccuray 1546 tcp abbaccuray [John_Wendt] [John_Wendt]
abbaccuray 1546 udp abbaccuray [John_Wendt] [John_Wendt]
laplink 1547 tcp laplink [Michael_Crawford] [Michael_Crawford]
laplink 1547 udp laplink [Michael_Crawford] [Michael_Crawford]
axon-lm 1548 tcp Axon License Manager [Mark_Pearce] [Mark_Pearce]
axon-lm 1548 udp Axon License Manager [Mark_Pearce] [Mark_Pearce]
shivahose 1549 tcp Shiva Hose
shivasound 1549 udp Shiva Sound [Kin_Chan] [Kin_Chan]
caci-lm 1554 tcp CACI Products Company License Manager [Erik_Blume] [Erik_Blume]
caci-lm 1554 udp CACI Products Company License Manager [Erik_Blume] [Erik_Blume]
stargatealerts 1654 tcp stargatealerts [Tim_Coppernoll] [Tim_Coppernoll]
stargatealerts 1654 udp stargatealerts [Tim_Coppernoll] [Tim_Coppernoll]
oracle-em2 1754 tcp oracle-em2 [Bob_Purvy] [Bob_Purvy]
oracle-em2 1754 udp oracle-em2 [Bob_Purvy] [Bob_Purvy]
buddy-draw 1854 tcp Buddy Draw [Marvin_Shin] [Marvin_Shin]
buddy-draw 1854 udp Buddy Draw [Marvin_Shin] [Marvin_Shin]
abr-api 1954 tcp ABR-API (diskbridge)
abr-api 1954 udp ABR-API (diskbridge)
weblogin 2054 tcp Weblogin Port [Diego_Saravia] [Diego_Saravia]
weblogin 2054 udp Weblogin Port [Diego_Saravia] [Diego_Saravia]
stdptc 2154 tcp Standard Protocol
stdptc 2154 udp Standard Protocol
seispoc 2254 tcp Seismic P.O.C. Port [Robert_Reimiller] [Robert_Reimiller]
seispoc 2254 udp Seismic P.O.C. Port [Robert_Reimiller] [Robert_Reimiller]
psprserver 2354 tcp psprserver
psprserver 2354 udp psprserver
indx-dds 2454 tcp IndX-DDS [Paul_Carmichael] [Paul_Carmichael]
indx-dds 2454 udp IndX-DDS [Paul_Carmichael] [Paul_Carmichael]
lonworks 2540 tcp LonWorks
lonworks 2540 udp LonWorks

Contact Information

ID Name Organization Contact URI Last Updated
[A_Boninn] A. Boninn mailto:aboninn&hotmail.com
[Allison_Carleton] Allison Carleton mailto:acarleto&naper1.napervilleil.ncr.com
[Betsy_Alexander] Betsy Alexander tel:+1-604-681-4549
[Bob_Purvy] Bob Purvy mailto:bpurvy&us.oracle.com
[Charles_Perkins] Charles Perkins mailto:cperkins&eng.sun.com
[Diego_Saravia] Diego Saravia mailto:dsa&unsa.edu.ar
[Eli_Sternheim] Eli Sternheim mailto:eli&interhdl.com
[Erik_Blume] Erik Blume mailto:erikb&caciasl.com
[Glenn_Reid] Glenn Reid mailto:port-reg&fiveacross.com 2004-11
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[John_Kelly] John Kelly mailto:johnk&bellhow.com
[John_R_Chawner] John R. Chawner tel:+1-817-354-1004
[John_Wendt] John Wendt tel:+1-614-261-2000
[Jon_Postel] Jon Postel mailto:postel&isi.edu
[Josyula_R_Rao] Josyula R. Rao mailto:jrrao&watson.ibm.com
[Kin_Chan] Kin Chan mailto:kchan&shiva.com
[Leland_Wallace] Leland Wallace mailto:randall&apple.com
[Mark_Pearce] Mark Pearce mailto:Mark_A.._Pearce/AXON_Networks_Inc..@notes.axon.com
[Marvin_Shin] Marvin Shin mailto:president&medialingo.com
[Michael_Crawford] Michael Crawford mailto:MichaelC&dev.travsoft.com
[Murali_Ranganathan] Murali Ranganathan mailto:murali_ranganathan&quickmail.apple.com
[Paul_Carmichael] Paul Carmichael mailto:paulcarmichael&indx.net
[Ramana_Kovi] Ramana Kovi mailto:ramana&kovi.com
[Randy_Epstein] Randy Epstein mailto:randy&epstein.com 2023-10-18
[Rob_Lanphier] Rob Lanphier mailto:robla&prognet.com
[Robert_Reimiller] Robert Reimiller mailto:bob&certsoft.com
[Stephane_MONS] Stéphane MONS mailto:stephane.mons&free.fr 2005-09
[Stuart_Lynne] Stuart Lynne mailto:sl&wimsey.com
[Sudhakar_Rajamannar] Sudhakar Rajamannar mailto:mobius1&cerfnet.com
[Susie_Armstrong] Susie Armstrong mailto:Armstrong.wbst128@xerox
[Tim_Coppernoll] Tim Coppernoll mailto:Tim_Coppernoll&ccm.jf.intel.com
[V_Balaji] V. Balaji mailto:balaji&aspec.com