Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
acas 62 tcp ACA Services E. Wald E. Wald
acas 62 udp ACA Services E. Wald E. Wald
snmptrap 162 tcp SNMPTRAP Marshall Rose Marshall Rose
snmptrap 162 udp SNMPTRAP Marshall Rose Marshall Rose
arcisdms 262 tcp Arcisdms Russell Crook Russell Crook
arcisdms 262 udp Arcisdms Russell Crook Russell Crook
srssend 362 tcp SRS Send Curt Mayer Curt Mayer
srssend 362 udp SRS Send Curt Mayer Curt Mayer
datasurfsrvsec 462 tcp DataRampSrvSec Diane Downie Diane Downie
datasurfsrvsec 462 udp DataRampSrvSec Diane Downie Diane Downie
chshell 562 tcp chcmd
chshell 562 udp chcmd
tunnel 604 tcp TUNNEL RFC 3620
tunnel 604 udp TUNNEL RFC 3620
sco-websrvrmgr 620 tcp SCO WebServer Manager Christopher Durham Christopher Durham
sco-websrvrmgr 620 udp SCO WebServer Manager Christopher Durham Christopher Durham
escp-ip 621 tcp ESCP Lai Zit Seng Lai Zit Seng
escp-ip 621 udp ESCP Lai Zit Seng Lai Zit Seng
collaborator 622 tcp Collaborator Johnson Davis Johnson Davis
collaborator 622 udp Collaborator Johnson Davis Johnson Davis
oob-ws-http 623 tcp DMTF out-of-band web services management protocol Jim Davis Jim Davis 2007-06
asf-rmcp 623 udp ASF Remote Management and Control Protocol Carl First Carl First
cryptoadmin 624 tcp Crypto Admin Tony Walker Tony Walker
cryptoadmin 624 udp Crypto Admin Tony Walker Tony Walker
dec-dlm 625 tcp DEC DLM

IANA assigned this well-formed service name as a replacement for "dec_dlm".
Rudi Martin Rudi Martin
dec_dlm 625 tcp DEC DLM Rudi Martin Rudi Martin This entry is an alias to "dec-dlm". This entry is now historic, not usable for use with many common service discovery mechanisms.
dec-dlm 625 udp DEC DLM

IANA assigned this well-formed service name as a replacement for "dec_dlm".
Rudi Martin Rudi Martin
dec_dlm 625 udp DEC DLM Rudi Martin Rudi Martin This entry is an alias to "dec-dlm". This entry is now historic, not usable for use with many common service discovery mechanisms.
asia 626 tcp ASIA Michael Dasenbrock Michael Dasenbrock
asia 626 udp ASIA Michael Dasenbrock Michael Dasenbrock
passgo-tivoli 627 tcp PassGo Tivoli John Rainford John Rainford
passgo-tivoli 627 udp PassGo Tivoli John Rainford John Rainford
qmqp 628 tcp QMQP D. J. Bernstein D. J. Bernstein 2018-04-05
qmqp 628 udp QMQP D. J. Bernstein D. J. Bernstein 2018-04-05
3com-amp3 629 tcp 3Com AMP3 Prakash Banthia Prakash Banthia
3com-amp3 629 udp 3Com AMP3 Prakash Banthia Prakash Banthia
pftp 662 tcp PFTP Ben Schluricke Ben Schluricke
pftp 662 udp PFTP Ben Schluricke Ben Schluricke
quotad 762 tcp
quotad 762 udp
netconf-ssh 830 tcp NETCONF over SSH RFC 6242
netconf-ssh 830 udp NETCONF over SSH RFC 6242
twamp-control 862 tcp TWAMP-Control IESG IETF Chair RFC 5357
twamp-test 862 udp TWAMP-Test Receiver Port IESG IETF Chair 2018-12-21 RFC 8545
veracity 1062 tcp Veracity Ross Williams Ross Williams
veracity 1062 udp Veracity Ross Williams Ross Williams
health-trap 1162 tcp Health Trap
health-trap 1162 udp Health Trap
qnts-orb 1262 tcp QNTS-ORB Raghurama Bhat Raghurama Bhat
qnts-orb 1262 udp QNTS-ORB Raghurama Bhat Raghurama Bhat
timeflies 1362 tcp TimeFlies Doug Kent Doug Kent
timeflies 1362 udp TimeFlies Doug Kent Doug Kent
world-lm 1462 tcp World License Manager Michael S Amirault Michael S Amirault
world-lm 1462 udp World License Manager Michael S Amirault Michael S Amirault
pconnectmgr 1562 tcp pconnectmgr Bob Kaiser Bob Kaiser
pconnectmgr 1562 udp pconnectmgr Bob Kaiser Bob Kaiser
faxportwinport 1620 tcp faxportwinport Chris Wells Chris Wells
faxportwinport 1620 udp faxportwinport Chris Wells Chris Wells
softdataphone 1621 tcp softdataphone Dror Gill Dror Gill
softdataphone 1621 udp softdataphone Dror Gill Dror Gill
ontime 1622 tcp ontime Keith Rhodes Keith Rhodes
ontime 1622 udp ontime Keith Rhodes Keith Rhodes
jaleosnd 1623 tcp jaleosnd Christian Schormann Christian Schormann
jaleosnd 1623 udp jaleosnd Christian Schormann Christian Schormann
udp-sr-port 1624 tcp udp-sr-port Herb Jensen Herb Jensen
udp-sr-port 1624 udp udp-sr-port Herb Jensen Herb Jensen
svs-omagent 1625 tcp svs-omagent Alberto Berlen Alberto Berlen
svs-omagent 1625 udp svs-omagent Alberto Berlen Alberto Berlen
shockwave 1626 tcp Shockwave Sarah Allen Sarah Allen
shockwave 1626 udp Shockwave Sarah Allen Sarah Allen
t128-gateway 1627 tcp T.128 Gateway Phil May Phil May
t128-gateway 1627 udp T.128 Gateway Phil May Phil May
lontalk-norm 1628 tcp LonTalk normal
lontalk-norm 1628 udp LonTalk normal
lontalk-urgnt 1629 tcp LonTalk urgent Bob Dolin Bob Dolin 2008-04-10
lontalk-urgnt 1629 udp LonTalk urgent Bob Dolin Bob Dolin 2008-04-10
netview-aix-2 1662 tcp netview-aix-2
netview-aix-2 1662 udp netview-aix-2
cft-1 1762 tcp cft-1 Martine Marchand Martine Marchand
cft-1 1762 udp cft-1 Martine Marchand Martine Marchand
mysql-cm-agent 1862 tcp MySQL Cluster Manager Agent Andrew Morgan Andrew Morgan 2009-12-08
mysql-cm-agent 1862 udp MySQL Cluster Manager Agent Andrew Morgan Andrew Morgan 2009-12-08
biap-mp 1962 tcp BIAP-MP Louis Slothouber Louis Slothouber
biap-mp 1962 udp BIAP-MP Louis Slothouber Louis Slothouber
icg-swp 2062 tcp ICG SWP Port
icg-swp 2062 udp ICG SWP Port
navisphere 2162 tcp Navisphere
navisphere 2162 udp Navisphere
comotionback 2262 tcp CoMotion Backup Server Friedman Wagner-Dobler Friedman Wagner-Dobler 2005-09
comotionback 2262 udp CoMotion Backup Server Friedman Wagner-Dobler Friedman Wagner-Dobler 2005-09
digiman 2362 tcp digiman Aaron S. Kurland Aaron S. Kurland
digiman 2362 udp digiman Aaron S. Kurland Aaron S. Kurland
qadmifevent 2462 tcp qadmifevent Pekka Takaranta Pekka Takaranta
qadmifevent 2462 udp qadmifevent Pekka Takaranta Pekka Takaranta
delibo 2562 tcp Delibo NovaWiz LTD NovaWiz LTD
delibo 2562 udp Delibo NovaWiz LTD NovaWiz LTD
lpsrecommender 2620 tcp LPSRecommender Pritham Shetty Pritham Shetty
lpsrecommender 2620 udp LPSRecommender Pritham Shetty Pritham Shetty
miles-apart 2621 tcp Miles Apart Jukebox Server Michael Rathmann Michael Rathmann
miles-apart 2621 udp Miles Apart Jukebox Server Michael Rathmann Michael Rathmann

Contact Information

Name Organization Contact URI Last Updated
Aaron S. Kurland akurland&netsilicon.com
Alberto Berlen aberlen&vnet.ibm.com
Andrew Morgan andrew.morgan&sun.com 2009-12-08
Ben Schluricke support&pftp.de
Bob Dolin bdolin&echelon.com 2008-04-10
Bob Kaiser BKaiser&palindrome.com
Carl First Carl.L.First&intel.com
Chris Wells chris_wells&lansource.com
Christian Schormann 100410.3063&compuserve.com
Christopher Durham chrisdu&sco.com
Curt Mayer curt&emergent.com
D. J. Bernstein ports&box.cr.yp.to 2018-04-05
Diane Downie downie&jibe.mv.com
Doug Kent mouthers@slugg&nwnexus.wa.com
Dror Gill drorgi&vnet.ibm.com
E. Wald ewald&via.enet.dec.com
Friedman Wagner-Dobler Friedman.Wagner-Dobler&gdc4s.com 2005-09
Herb Jensen HWJensen&nfsrv.avionics.itt.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jim Davis jim.davis&wbemsolutions.com 2007-06
John Rainford john.rainford&passgo.com
Johnson Davis johnsond&opteamasoft.com
Keith Rhodes tel:+1-810-559-5955
Lai Zit Seng lzs&pobox.com
Louis Slothouber lpslot&biap.com 2005-08
Marshall Rose mrose17&gmail.com 2024-07-29
Martine Marchand tel:+16-1-46-59-24-84
Michael Dasenbrock dasenbro&apple.com
Michael Rathmann rathmann_ia&milesinfo.com
Michael S Amirault ambi&world.std.com
NovaWiz LTD Moshe&novawiz.com
Pekka Takaranta pekka.takaranta&tellabs.fi
Phil May pm&datcon.co.uk
Prakash Banthia prakash_banthia&3com.com
Pritham Shetty pritham&andromedia.com
Raghurama Bhat raghu&quintus.com
Ross Williams ross&rocksoft.com
Rudi Martin Rudi.Martin&edo.mts.dec.com
Russell Crook rmc&sni.ca
Sarah Allen sallen&macromedia.com
Tony Walker tony&cryptocard.com