Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
sql-net 66 tcp Oracle SQL*NET

IANA assigned this well-formed service name as a replacement for "sql*net".
Jack Haverty Jack Haverty
sql*net 66 tcp Oracle SQL*NET Jack Haverty Jack Haverty This entry is an alias to "sql-net". This entry is now historic, not usable for use with many common service discovery mechanisms.
sql-net 66 udp Oracle SQL*NET

IANA assigned this well-formed service name as a replacement for "sql*net".
Jack Haverty Jack Haverty
sql*net 66 udp Oracle SQL*NET Jack Haverty Jack Haverty This entry is an alias to "sql-net". This entry is now historic, not usable for use with many common service discovery mechanisms.
s-net 166 tcp Sirius Systems Brian Lloyd Brian Lloyd
s-net 166 udp Sirius Systems Brian Lloyd Brian Lloyd
sst 266 tcp SCSI on ST Donald D. Woelz Donald D. Woelz
sst 266 udp SCSI on ST Donald D. Woelz Donald D. Woelz
odmr 366 tcp ODMR Randall Gellens Randall Gellens
odmr 366 udp ODMR Randall Gellens Randall Gellens
digital-vrc 466 tcp digital-vrc Peter Higginson Peter Higginson
digital-vrc 466 udp digital-vrc Peter Higginson Peter Higginson
streettalk 566 tcp streettalk
streettalk 566 udp streettalk
mac-srvr-admin 660 tcp MacOS Server Admin Forest Hill Forest Hill
mac-srvr-admin 660 udp MacOS Server Admin Forest Hill Forest Hill
hap 661 tcp HAP Igor Plotnikov Igor Plotnikov
hap 661 udp HAP Igor Plotnikov Igor Plotnikov
pftp 662 tcp PFTP Ben Schluricke Ben Schluricke
pftp 662 udp PFTP Ben Schluricke Ben Schluricke
purenoise 663 tcp PureNoise Sam Osa Sam Osa
purenoise 663 udp PureNoise Sam Osa Sam Osa
oob-ws-https 664 tcp DMTF out-of-band secure web services management protocol Jim Davis Jim Davis 2007-06
asf-secure-rmcp 664 udp ASF Secure Remote Management and Control Protocol Carl First Carl First
sun-dr 665 tcp Sun DR Harinder Bhasin Harinder Bhasin
sun-dr 665 udp Sun DR Harinder Bhasin Harinder Bhasin
mdqs 666 tcp
mdqs 666 udp
doom 666 tcp doom Id Software ddt ddt
doom 666 udp doom Id Software ddt ddt
disclose 667 tcp campaign contribution disclosures - SDR Technologies Jim Dixon Jim Dixon
disclose 667 udp campaign contribution disclosures - SDR Technologies Jim Dixon Jim Dixon
mecomm 668 tcp MeComm
mecomm 668 udp MeComm
meregister 669 tcp MeRegister Armin Sawusch Armin Sawusch
meregister 669 udp MeRegister Armin Sawusch Armin Sawusch
766 Unassigned
fpo-fns 1066 tcp FPO-FNS Jens Klose Jens Klose
fpo-fns 1066 udp FPO-FNS Jens Klose Jens Klose
qsm-remote 1166 tcp QSM RemoteExec Norm Lunde Norm Lunde 2004-11
qsm-remote 1166 udp QSM RemoteExec Norm Lunde Norm Lunde 2004-11
dellpwrappks 1266 tcp DELLPWRAPPKS David Troeger David Troeger
dellpwrappks 1266 udp DELLPWRAPPKS David Troeger David Troeger
netware-csp 1366 tcp Novell NetWare Comm Service Platform Laurie Lindsey Laurie Lindsey
netware-csp 1366 udp Novell NetWare Comm Service Platform Laurie Lindsey Laurie Lindsey
oceansoft-lm 1466 tcp Ocean Software License Manager Randy Leonard Randy Leonard
oceansoft-lm 1466 udp Ocean Software License Manager Randy Leonard Randy Leonard
corelvideo 1566 tcp CORELVIDEO Ming Poon Ming Poon
corelvideo 1566 udp CORELVIDEO Ming Poon Ming Poon
skip-mc-gikreq 1660 tcp skip-mc-gikreq Tom Markson Tom Markson
skip-mc-gikreq 1660 udp skip-mc-gikreq Tom Markson Tom Markson
netview-aix-1 1661 tcp netview-aix-1
netview-aix-1 1661 udp netview-aix-1
netview-aix-2 1662 tcp netview-aix-2
netview-aix-2 1662 udp netview-aix-2
netview-aix-3 1663 tcp netview-aix-3
netview-aix-3 1663 udp netview-aix-3
netview-aix-4 1664 tcp netview-aix-4
netview-aix-4 1664 udp netview-aix-4
netview-aix-5 1665 tcp netview-aix-5
netview-aix-5 1665 udp netview-aix-5
netview-aix-6 1666 tcp netview-aix-6
netview-aix-6 1666 udp netview-aix-6
netview-aix-7 1667 tcp netview-aix-7
netview-aix-7 1667 udp netview-aix-7
netview-aix-8 1668 tcp netview-aix-8
netview-aix-8 1668 udp netview-aix-8
netview-aix-9 1669 tcp netview-aix-9
netview-aix-9 1669 udp netview-aix-9
cft-5 1766 tcp cft-5 Martine Marchand Martine Marchand
cft-5 1766 udp cft-5 Martine Marchand Martine Marchand
radius-acct 1813 tcp RADIUS Accounting RFC 2866
radius-acct 1813 udp RADIUS Accounting RFC 2866
swrmi 1866 tcp swrmi Jun Yoshii Jun Yoshii
swrmi 1866 udp swrmi Jun Yoshii Jun Yoshii
slush 1966 tcp Slush Damien Miller Damien Miller
slush 1966 udp Slush Damien Miller Damien Miller
nfs 2049 sctp Network File System RFC 5665 Defined TXT keys: path=<path to mount point>
aura 2066 tcp AVM USB Remote Architecture Diego Friedel Diego Friedel 2006-03
aura 2066 udp AVM USB Remote Architecture Diego Friedel Diego Friedel 2006-03
radsec 2083 tcp Secure Radius Service IESG IETF Chair 2005-05 RFC 6614 The TCP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC. This early implementation can be configured to be compatible to RADIUS/TLS as specified by the IETF. See RFC 6614, Appendix A for details.
iwserver 2166 tcp iwserver Fred Surr Fred Surr
iwserver 2166 udp iwserver Fred Surr Fred Surr
mfserver 2266 tcp M-Files Server Samppa Lahtinen Samppa Lahtinen 2004-06
mfserver 2266 udp M-files Server Samppa Lahtinen Samppa Lahtinen 2004-06
qip-login 2366 tcp qip-login Mike Morgan Mike Morgan
qip-login 2366 udp qip-login Mike Morgan Mike Morgan
lbf 2466 tcp Load Balance Forwarding Kazuhiro Koide Kazuhiro Koide
lbf 2466 udp Load Balance Forwarding Kazuhiro Koide Kazuhiro Koide
pcs-pcw 2566 tcp pcs-pcw W. Jordan Fitzhugh W. Jordan Fitzhugh
pcs-pcw 2566 udp pcs-pcw W. Jordan Fitzhugh W. Jordan Fitzhugh
gcmonitor 2660 tcp GC Monitor Gustavo Rodriguez-Rivera Gustavo Rodriguez-Rivera
gcmonitor 2660 udp GC Monitor Gustavo Rodriguez-Rivera Gustavo Rodriguez-Rivera
olhost 2661 tcp OLHOST Robert Ripberger Robert Ripberger
olhost 2661 udp OLHOST Robert Ripberger Robert Ripberger
bintec-capi 2662 tcp BinTec-CAPI Unauthorized Use Known on port 2662
bintec-capi 2662 udp BinTec-CAPI Unauthorized Use Known on port 2662
bintec-tapi 2663 tcp BinTec-TAPI
bintec-tapi 2663 udp BinTec-TAPI
patrol-mq-gm 2664 tcp Patrol for MQ GM

Contact Information

Name Organization Contact URI Last Updated
Armin Sawusch armin&esd1.esd.de
Ben Schluricke support&pftp.de
Brian Lloyd brian&lloyd.com
Carl First Carl.L.First&intel.com
Damien Miller damien&ibs.com.au
David Troeger David_Troeger&dell.com
Diego Friedel d.friedel&avm.de 2006-03
Donald D. Woelz don&genroco.com
Forest Hill forest&apple.com
Fred Surr quest_iana&oz.quest.com
Gustavo Rodriguez-Rivera grr&geodesic.com
Harinder Bhasin Harinder.Bhasin&sun.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Igor Plotnikov igor&uroam.com
Jack Haverty jhaverty&oracle.com
Jens Klose jklose&intercope.com
Jim Davis jim.davis&wbemsolutions.com 2007-06
Jim Dixon jim&lambda.com
Jun Yoshii yoshii&ael.fujitsu.co.jp
Kazuhiro Koide kaz&pfu.co.jp
Laurie Lindsey llindsey&novell.com
Martine Marchand tel:+16-1-46-59-24-84
Mike Morgan mmorgan&lucent.com
Ming Poon mingp&corel.ca
Norm Lunde norm&commvault.com 2004-11
Peter Higginson higginson&mail.dec.com
Randall Gellens rg+ietf&coretechnologyconsulting.com 2024-07-29
Randy Leonard randy&oceansoft.com
Robert Ripberger rip&lan-aces.com 2017-02-08
Sam Osa pristine&mailcity.com
Samppa Lahtinen samppa.lahtinen&motivesys.com 2004-06
Tom Markson markson&osmosys.incog.com
W. Jordan Fitzhugh jfitz&pcare.com
ddt&idcube.idsoftware.com