Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
echo 7 tcp Echo Jon Postel Jon Postel
echo 7 udp Echo Jon Postel Jon Postel
daytime 13 tcp Daytime Jon Postel Jon Postel RFC 867
daytime 13 udp Daytime Jon Postel Jon Postel RFC 867
qotd 17 tcp Quote of the Day Jon Postel Jon Postel
qotd 17 udp Quote of the Day Jon Postel Jon Postel
nsw-fe 27 tcp NSW User System FE Robert Thomas Robert Thomas
nsw-fe 27 udp NSW User System FE Robert Thomas Robert Thomas
time 37 tcp Time Jon Postel Jon Postel
time 37 udp Time Jon Postel Jon Postel
47 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
47 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
57 tcp any private terminal access Jon Postel Jon Postel
57 udp any private terminal access Jon Postel Jon Postel
61 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
61 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
bootps 67 tcp Bootstrap Protocol Server Bill Croft Bill Croft RFC 951 Defined TXT keys: None
bootps 67 udp Bootstrap Protocol Server
gopher 70 tcp Gopher Mark McCahill Mark McCahill
gopher 70 udp Gopher Mark McCahill Mark McCahill
netrjs-1 71 tcp Remote Job Service
netrjs-1 71 udp Remote Job Service
netrjs-2 72 tcp Remote Job Service
netrjs-2 72 udp Remote Job Service
netrjs-3 73 tcp Remote Job Service
netrjs-3 73 udp Remote Job Service
netrjs-4 74 tcp Remote Job Service Bob Braden Bob Braden
netrjs-4 74 udp Remote Job Service Bob Braden Bob Braden
75 tcp any private dial out service Jon Postel Jon Postel
75 udp any private dial out service Jon Postel Jon Postel
deos 76 tcp Distributed External Object Store Robert Ullmann Robert Ullmann
deos 76 udp Distributed External Object Store Robert Ullmann Robert Ullmann
77 tcp any private RJE service Jon Postel Jon Postel
77 udp any private RJE service Jon Postel Jon Postel
vettcp 78 tcp vettcp Christopher Leong Christopher Leong
vettcp 78 udp vettcp Christopher Leong Christopher Leong
finger 79 tcp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
finger 79 udp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
87 tcp any private terminal link Jon Postel Jon Postel
87 udp any private terminal link Jon Postel Jon Postel
swift-rvf 97 tcp Swift Remote Virtural File Protocol Maurice R. Turcotte Maurice R. Turcotte
swift-rvf 97 udp Swift Remote Virtural File Protocol Maurice R. Turcotte Maurice R. Turcotte
rtelnet 107 tcp Remote Telnet Service Jon Postel Jon Postel
rtelnet 107 udp Remote Telnet Service Jon Postel Jon Postel
uucp-path 117 tcp UUCP Path Service
uucp-path 117 udp UUCP Path Service
nntp 119 tcp Network News Transfer Protocol IESG IETF Chair 2018-07-06 RFC 3977
nntp 119 udp Network News Transfer Protocol IESG IETF Chair 2018-07-06 RFC 3977
locus-con 127 tcp Locus PC-Interface Conn Server Eric Peterson Eric Peterson
locus-con 127 udp Locus PC-Interface Conn Server Eric Peterson Eric Peterson
netbios-ns 137 tcp NETBIOS Name Service
netbios-ns 137 udp NETBIOS Name Service
iso-ip 147 tcp ISO-IP Marshall Rose Marshall Rose
iso-ip 147 udp ISO-IP Marshall Rose Marshall Rose
knet-cmp 157 tcp KNET/VM Command/Message Protocol Gary S. Malkin Gary S. Malkin
knet-cmp 157 udp KNET/VM Command/Message Protocol Gary S. Malkin Gary S. Malkin
namp 167 tcp NAMP Marty Schoffstahl Marty Schoffstahl
namp 167 udp NAMP Marty Schoffstahl Marty Schoffstahl
print-srv 170 tcp Network PostScript Brian Reid Brian Reid
print-srv 170 udp Network PostScript Brian Reid Brian Reid
multiplex 171 tcp Network Innovations Multiplex
multiplex 171 udp Network Innovations Multiplex
cl-1 172 tcp Network Innovations CL/1

IANA assigned this well-formed service name as a replacement for "cl/1".
Kevin DeVault Kevin DeVault
cl/1 172 tcp Network Innovations CL/1 Kevin DeVault Kevin DeVault This entry is an alias to "cl-1". This entry is now historic, not usable for use with many common service discovery mechanisms.
cl-1 172 udp Network Innovations CL/1

IANA assigned this well-formed service name as a replacement for "cl/1".
Kevin DeVault Kevin DeVault
cl/1 172 udp Network Innovations CL/1 Kevin DeVault Kevin DeVault This entry is an alias to "cl-1". This entry is now historic, not usable for use with many common service discovery mechanisms.
xyplex-mux 173 tcp Xyplex Bob Stewart Bob Stewart
xyplex-mux 173 udp Xyplex Bob Stewart Bob Stewart
mailq 174 tcp MAILQ Rayan Zachariassen Rayan Zachariassen
mailq 174 udp MAILQ Rayan Zachariassen Rayan Zachariassen
vmnet 175 tcp VMNET Christopher Tengi Christopher Tengi
vmnet 175 udp VMNET Christopher Tengi Christopher Tengi
genrad-mux 176 tcp GENRAD-MUX Ron Thornton Ron Thornton
genrad-mux 176 udp GENRAD-MUX Ron Thornton Ron Thornton
xdmcp 177 tcp X Display Manager Control Protocol Robert W. Scheifler Robert W. Scheifler
xdmcp 177 udp X Display Manager Control Protocol Robert W. Scheifler Robert W. Scheifler
nextstep 178 tcp NextStep Window Server Leo Hourvitz Leo Hourvitz
nextstep 178 udp NextStep Window Server Leo Hourvitz Leo Hourvitz
bgp 179 tcp Border Gateway Protocol Kirk Lougheed Kirk Lougheed
bgp 179 udp Border Gateway Protocol Kirk Lougheed Kirk Lougheed
bgp 179 sctp BGP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
aci 187 tcp Application Communication Interface Rick Carlos Rick Carlos
aci 187 udp Application Communication Interface Rick Carlos Rick Carlos
dls 197 tcp Directory Location Service
dls 197 udp Directory Location Service
at-7 207 tcp AppleTalk Unused
at-7 207 udp AppleTalk Unused
dbase 217 tcp dBASE Unix Don Gibson Don Gibson
dbase 217 udp dBASE Unix Don Gibson Don Gibson
dsp3270 246 tcp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
dsp3270 246 udp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
subntbcst-tftp 247 tcp SUBNTBCST_TFTP

IANA assigned this well-formed service name as a replacement for "subntbcst_tftp".
John Fake John Fake
subntbcst_tftp 247 tcp SUBNTBCST_TFTP John Fake John Fake This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms.
subntbcst-tftp 247 udp SUBNTBCST_TFTP

IANA assigned this well-formed service name as a replacement for "subntbcst_tftp".
John Fake John Fake
subntbcst_tftp 247 udp SUBNTBCST_TFTP John Fake John Fake This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms.
set 257 tcp Secure Electronic Transaction Donald Eastlake Donald Eastlake
set 257 udp Secure Electronic Transaction Donald Eastlake Donald Eastlake
td-service 267 tcp Tobit David Service Layer
td-service 267 udp Tobit David Service Layer
270 tcp Reserved

Contact Information

Name Organization Contact URI Last Updated
Bill Croft Croft&sumex-aim.stanford.edu
Bob Braden Braden&isi.edu
Bob Stewart STEWART&xyplex.com
Brian Reid reid&decwrl.dec.com
Christopher Leong leong&kolmod.mlo.dec.com
Christopher Tengi tengi&princeton.edu
David Zimmerman dpz&rutgers.edu
Don Gibson sequent!aero!twinsun!ashtate.A-T.COM!dong&uunet.UU.NET
Donald Eastlake d3e3e3&gmail.com
Eric Peterson lcc.eric&seas.ucla.edu
Gary S. Malkin GMALKIN&xylogics.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
John Fake fake&us.ibm.com
Jon Postel postel&isi.edu
Kevin DeVault
Kirk Lougheed LOUGHEED&mathom.cisco.com
Leo Hourvitz leo&next.com
Mark McCahill mpm&boombox.micro.umn.edu
Marshall Rose mrose17&gmail.com 2024-07-29
Marty Schoffstahl schoff&nisc.nyser.net
Maurice R. Turcotte mailrus!uflorida!rm1!dnmrt%25rmatl@uunet.uu.net
Randall Stewart IETF TSVWG rrs&lakerest.net
Rayan Zachariassen rayan&ai.toronto.edu
Rick Carlos rick&ticipa.csc.ti.com
Robert Thomas BThomas&f.bbn.com
Robert Ullmann ariel&world.std.com
Robert W. Scheifler RWS&xx.lcs.mit.edu
Ron Thornton thornton&aerostation.org 2020-09-01
Weldon J. Showalter Gamma&mintaka.dca.mil