Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ftp 21 tcp File Transfer Protocol [Control] Jon Postel Jon Postel RFC 959 Defined TXT keys: u=<username> p=<password> path=<path>
ftp 21 udp File Transfer Protocol [Control] Jon Postel Jon Postel RFC 959 Defined TXT keys: u=<username> p=<password> path=<path>
bootps 67 tcp Bootstrap Protocol Server Bill Croft Bill Croft RFC 951 Defined TXT keys: None
supdup 95 tcp SUPDUP Mark Crispin Mark Crispin
supdup 95 udp SUPDUP Mark Crispin Mark Crispin
dn6-nlm-aud 195 tcp DNSIX Network Level Module Audit
dn6-nlm-aud 195 udp DNSIX Network Level Module Audit
netcp 395 tcp NetScout Control Protocol Ashwani Singhal Ashwani Singhal 2010-04-07
netcp 395 udp NetScout Control Protocol Ashwani Singhal Ashwani Singhal 2010-04-07
intecourier 495 tcp intecourier Steve Favor Steve Favor
intecourier 495 udp intecourier Steve Favor Steve Favor
cab-protocol 595 tcp CAB Protocol Winston Hetherington Winston Hetherington
cab-protocol 595 udp CAB Protocol Winston Hetherington Winston Hetherington
syslog-conn 601 tcp Reliable Syslog Service RFC 3195
syslog-conn 601 udp Reliable Syslog Service RFC 3195
ieee-mms-ssl 695 tcp IEEE-MMS-SSL Curtis Anderson Curtis Anderson
ieee-mms-ssl 695 udp IEEE-MMS-SSL Curtis Anderson Curtis Anderson
916-952 Unassigned
rndc 953 tcp BIND9 remote name daemon controller Internet Systems Consortium, Inc. Ray Bellis 2017-06-08
953 udp Reserved
954-988 Unassigned
pop3s 995 tcp POP3 over TLS protocol IESG IETF Chair 2017-12-12 RFC 8314
pop3s 995 udp pop3 protocol over TLS/SSL (was spop3) Gordon Mangione Gordon Mangione
nicelink 1095 tcp NICELink Jordi Lisbona Jordi Lisbona
nicelink 1095 udp NICELink Jordi Lisbona Jordi Lisbona
rsf-1 1195 tcp RSF-1 clustering Dave Hines Dave Hines 2004-11
rsf-1 1195 udp RSF-1 clustering Dave Hines Dave Hines 2004-11
ehtp 1295 tcp End-by-Hop Transmission Protocol Alexander Bogdanov Alexander Bogdanov
ehtp 1295 udp End-by-Hop Transmission Protocol Alexander Bogdanov Alexander Bogdanov
iclpv-wsm 1395 tcp PC Workstation Manager software A.P. Hobson A.P. Hobson
iclpv-wsm 1395 udp PC Workstation Manager software A.P. Hobson A.P. Hobson
cvc 1495 tcp cvc Bill Davidson Bill Davidson
cvc 1495 udp cvc Bill Davidson Bill Davidson
radio 1595 tcp radio
radio 1595 udp radio
rrilwm 1695 tcp rrilwm
rrilwm 1695 udp rrilwm
dpi-proxy 1795 tcp dpi-proxy Charles Gordon Charles Gordon
dpi-proxy 1795 udp dpi-proxy Charles Gordon Charles Gordon
1895 tcp unassigned Microsoft (unoffically) using 1895
1895 udp unassigned Microsoft (unoffically) using 1895
ismaeasdaqtest 1950 tcp ISMA Easdaq Test Stephen Dunne Stephen Dunne
ismaeasdaqtest 1950 udp ISMA Easdaq Test Stephen Dunne Stephen Dunne
bcs-lmserver 1951 tcp bcs-lmserver Andy Warner Andy Warner
bcs-lmserver 1951 udp bcs-lmserver Andy Warner Andy Warner
mpnjsc 1952 tcp mpnjsc Takenori Miyahara Takenori Miyahara
mpnjsc 1952 udp mpnjsc Takenori Miyahara Takenori Miyahara
rapidbase 1953 tcp Rapid Base Antoni Wolski Antoni Wolski
rapidbase 1953 udp Rapid Base Antoni Wolski Antoni Wolski
abr-api 1954 tcp ABR-API (diskbridge)
abr-api 1954 udp ABR-API (diskbridge)
abr-secure 1955 tcp ABR-Secure Data (diskbridge) Graham Wooden Graham Wooden
abr-secure 1955 udp ABR-Secure Data (diskbridge) Graham Wooden Graham Wooden
vrtl-vmf-ds 1956 tcp Vertel VMF DS Alan Akahoshi Alan Akahoshi
vrtl-vmf-ds 1956 udp Vertel VMF DS Alan Akahoshi Alan Akahoshi
unix-status 1957 tcp unix-status Thomas Erskine Thomas Erskine
unix-status 1957 udp unix-status Thomas Erskine Thomas Erskine
dxadmind 1958 tcp CA Administration Daemon John Birrell John Birrell
dxadmind 1958 udp CA Administration Daemon John Birrell John Birrell
simp-all 1959 tcp SIMP Channel Tim Hunnewell Tim Hunnewell
simp-all 1959 udp SIMP Channel Tim Hunnewell Tim Hunnewell
perf-port 1995 tcp cisco perf port
perf-port 1995 udp cisco perf port
nbx-ser 2095 tcp NBX SER
nbx-ser 2095 udp NBX SER
advant-lm 2295 tcp Advant License Manager Lars-Goran Magnusson Lars-Goran Magnusson
advant-lm 2295 udp Advant License Manager Lars-Goran Magnusson Lars-Goran Magnusson
lan900-remote 2395 tcp LAN900 Remote

IANA assigned this well-formed service name as a replacement for "lan900_remote".
Tom Quinlan Tom Quinlan
lan900_remote 2395 tcp LAN900 Remote Tom Quinlan Tom Quinlan This entry is an alias to "lan900-remote". This entry is now historic, not usable for use with many common service discovery mechanisms.
lan900-remote 2395 udp LAN900 Remote

IANA assigned this well-formed service name as a replacement for "lan900_remote".
Tom Quinlan Tom Quinlan
lan900_remote 2395 udp LAN900 Remote Tom Quinlan Tom Quinlan This entry is an alias to "lan900-remote". This entry is now historic, not usable for use with many common service discovery mechanisms.
fast-rem-serv 2495 tcp Fast Remote Services Scott St. Clair Scott St. Clair
fast-rem-serv 2495 udp Fast Remote Services Scott St. Clair Scott St. Clair
worldfusion1 2595 tcp World Fusion 1
worldfusion1 2595 udp World Fusion 1
vspread 2695 tcp VSPREAD Sumitake kobayashi Sumitake kobayashi
vspread 2695 udp VSPREAD Sumitake kobayashi Sumitake kobayashi
livestats 2795 tcp LiveStats Chris Greene Chris Greene
livestats 2795 udp LiveStats Chris Greene Chris Greene
natuslink 2895 tcp NATUS LINK Jonathan Mergy Jonathan Mergy
natuslink 2895 udp NATUS LINK Jonathan Mergy Jonathan Mergy
esip 2950 tcp ESIP David Stephenson David Stephenson
esip 2950 udp ESIP David Stephenson David Stephenson
ottp 2951 tcp OTTP Brent Foster Brent Foster
ottp 2951 udp OTTP Brent Foster Brent Foster
mpfwsas 2952 tcp MPFWSAS Toru Murai Toru Murai
mpfwsas 2952 udp MPFWSAS Toru Murai Toru Murai
ovalarmsrv 2953 tcp OVALARMSRV
ovalarmsrv 2953 udp OVALARMSRV
ovalarmsrv-cmd 2954 tcp OVALARMSRV-CMD Eric Pulsipher Eric Pulsipher
ovalarmsrv-cmd 2954 udp OVALARMSRV-CMD Eric Pulsipher Eric Pulsipher
csnotify 2955 tcp CSNOTIFY Israel Beniaminy Israel Beniaminy
csnotify 2955 udp CSNOTIFY Israel Beniaminy Israel Beniaminy
ovrimosdbman 2956 tcp OVRIMOSDBMAN Dimitrios Souflis Dimitrios Souflis
ovrimosdbman 2956 udp OVRIMOSDBMAN Dimitrios Souflis Dimitrios Souflis
jmact5 2957 tcp JAMCT5
jmact5 2957 udp JAMCT5
jmact6 2958 tcp JAMCT6
jmact6 2958 udp JAMCT6
rmopagt 2959 tcp RMOPAGT Shuji Okubo Shuji Okubo

Contact Information

Name Organization Contact URI Last Updated
A.P. Hobson A.P.Hobson&bra0112.wins.icl.co.uk
Alan Akahoshi alan-akahoshi&vertel.com
Alexander Bogdanov alexandr_bgd&softhome.net
Andy Warner andyw&knoware.nl
Antoni Wolski antoni.wolski&vtt.fi
Ashwani Singhal Ashwani.Singhal&netscout.com 2010-04-07
Bill Croft Croft&sumex-aim.stanford.edu
Bill Davidson billd&equalizer.cray.com
Brent Foster brent.foster&onstreamsystems.com 2006-04
Charles Gordon cgordon&digprod.com
Chris Greene cgreeneOA&avidsports.com
Curtis Anderson ecanderson&turbolinux.com
Dave Hines d.hines&high-availability.com 2004-11
David Stephenson david_stephenson&hp.com
Dimitrios Souflis dsouflis&altera.gr
Eric Pulsipher eric_pulsipher&hp.com
Gordon Mangione gordm&microsoft.com
Graham Wooden graham&g-rock.net
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Internet Systems Consortium, Inc. info&isc.org 2017-06-08
Israel Beniaminy israel.beniaminy&clickservice.com
John Birrell birjo99&cai.com
Jon Postel postel&isi.edu
Jonathan Mergy mergy&natus.com
Jordi Lisbona jlisbona&tango04.net
Lars-Goran Magnusson lars-goran.magnusson&seisy.mail.abb.com
Mark Crispin MRC&panda.com
Ray Bellis ray&isc.org 2017-06-08
Scott St. Clair stclair&ntc.adaptec.com
Shuji Okubo okubo&yk.fujitsu.co.jp
Stephen Dunne sdun&isma.co.uk
Steve Favor sfavor&tigger.intecom.com
Sumitake kobayashi kobayashi&np.lps.cs.fujitsu.co.jp
Takenori Miyahara miyahara&pfu.co.jp
Thomas Erskine erskine&sourceworks.com
Tim Hunnewell thunnewell&pinna.com
Tom Quinlan tquinlan&digitechinc.com
Toru Murai murai&saint.nm.fujitsu.co.jp
Winston Hetherington