Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
swift-rvf 97 tcp Swift Remote Virtural File Protocol Maurice R. Turcotte Maurice R. Turcotte
swift-rvf 97 udp Swift Remote Virtural File Protocol Maurice R. Turcotte Maurice R. Turcotte
nntp 119 tcp Network News Transfer Protocol IESG IETF Chair 2018-07-06 RFC 3977
nntp 119 udp Network News Transfer Protocol IESG IETF Chair 2018-07-06 RFC 3977
dls 197 tcp Directory Location Service
dls 197 udp Directory Location Service
gist 270 udp Q-mode encapsulation for GIST messages RFC 5971
bhoetty 351 tcp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoetty 351 udp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 tcp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 udp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
mptn 397 tcp Multi Protocol Trans. Net. Soumitra Sarkar Soumitra Sarkar
mptn 397 udp Multi Protocol Trans. Net. Soumitra Sarkar Soumitra Sarkar
nnsp 433 tcp NNTP for transit servers (NNSP) IESG IETF Chair 2018-07-06 RFC 3977
nnsp 433 udp NNTP for transit servers (NNSP) IESG IETF Chair 2018-07-06 RFC 3977
retrospect 497 tcp Retrospect backup and restore service Retrospect, Inc. JG Heithcock 2012-02-02
retrospect 497 udp Retrospect backup and restore service Retrospect, Inc. JG Heithcock 2012-02-02
ptcnameservice 597 tcp PTC Name Service Yuri Machkasov Yuri Machkasov
ptcnameservice 597 udp PTC Name Service Yuri Machkasov Yuri Machkasov
uuidgen 697 tcp UUIDGEN James Falkner James Falkner
uuidgen 697 udp UUIDGEN James Falkner James Falkner
maitrd 997 tcp
maitrd 997 udp
sunclustermgr 1097 tcp Sun Cluster Manager Ashit Patel Ashit Patel
sunclustermgr 1097 udp Sun Cluster Manager Ashit Patel Ashit Patel
carrius-rshell 1197 tcp Carrius Remote Access Gerry Dubois Gerry Dubois 2005-08
carrius-rshell 1197 udp Carrius Remote Access Gerry Dubois Gerry Dubois 2005-08
sdproxy 1297 tcp sdproxy Raimond Diederik Raimond Diederik
sdproxy 1297 udp sdproxy Raimond Diederik Raimond Diederik
audio-activmail 1397 tcp Audio Active Mail
audio-activmail 1397 udp Audio Active Mail
rfx-lm 1497 tcp rfx-lm Bill Bishop Bill Bishop
rfx-lm 1497 udp rfx-lm Bill Bishop Bill Bishop
orbplus-iiop 1597 tcp orbplus-iiop Robert A. Kukura Robert A. Kukura
orbplus-iiop 1597 udp orbplus-iiop Robert A. Kukura Robert A. Kukura
rrisat 1697 tcp rrisat Allen Briggs Allen Briggs
rrisat 1697 udp rrisat Allen Briggs Allen Briggs
uma 1797 tcp UMA Martin Kirk Martin Kirk
uma 1797 udp UMA Martin Kirk Martin Kirk
metaagent 1897 tcp MetaAgent Marie-France Dubreuil Marie-France Dubreuil
metaagent 1897 udp MetaAgent Marie-France Dubreuil Marie-France Dubreuil
netop-rc 1970 tcp NetOp Remote Control
netop-rc 1970 udp NetOp Remote Control
netop-school 1971 tcp NetOp School NetOp Technical Support NetOp Technical Support
netop-school 1971 udp NetOp School NetOp Technical Support NetOp Technical Support
intersys-cache 1972 tcp Cache Mark Hanson Mark Hanson
intersys-cache 1972 udp Cache Mark Hanson Mark Hanson
dlsrap 1973 tcp Data Link Switching Remote Access Protocol Steve T. Chiang Steve T. Chiang
dlsrap 1973 udp Data Link Switching Remote Access Protocol Steve T. Chiang Steve T. Chiang
drp 1974 tcp DRP Richard Alan Johnson Richard Alan Johnson
drp 1974 udp DRP Richard Alan Johnson Richard Alan Johnson
tcoflashagent 1975 tcp TCO Flash Agent
tcoflashagent 1975 udp TCO Flash Agent
tcoregagent 1976 tcp TCO Reg Agent
tcoregagent 1976 udp TCO Reg Agent
tcoaddressbook 1977 tcp TCO Address Book Allan Panitch Allan Panitch
tcoaddressbook 1977 udp TCO Address Book Allan Panitch Allan Panitch
unisql 1978 tcp UniSQL
unisql 1978 udp UniSQL
unisql-java 1979 tcp UniSQL Java Keith Yarbrough Keith Yarbrough
unisql-java 1979 udp UniSQL Java Keith Yarbrough Keith Yarbrough
gdp-port 1997 tcp cisco Gateway Discovery Protocol
gdp-port 1997 udp cisco Gateway Discovery Protocol
jetformpreview 2097 tcp Jet Form Preview Zygmunt Wiercioch Zygmunt Wiercioch
jetformpreview 2097 udp Jet Form Preview Zygmunt Wiercioch Zygmunt Wiercioch
mnp-exchange 2197 tcp MNP data exchange Peter Pramberger Peter Pramberger 2004-11
mnp-exchange 2197 udp MNP data exchange Peter Pramberger Peter Pramberger 2004-11
d2k-datamover1 2297 tcp D2K DataMover 1
d2k-datamover1 2297 udp D2K DataMover 1
ncl 2397 tcp NCL Robert Wiebe Robert Wiebe
ncl 2397 udp NCL Robert Wiebe Robert Wiebe
quaddb 2497 tcp Quad DB Jeff Rosenthal Jeff Rosenthal
quaddb 2497 udp Quad DB Jeff Rosenthal Jeff Rosenthal
homesteadglory 2597 tcp Homestead Glory John Tokash John Tokash
homesteadglory 2597 udp Homestead Glory John Tokash John Tokash
oce-snmp-trap 2697 tcp Oce SNMP Trap Port Peter Teeuwen Peter Teeuwen
oce-snmp-trap 2697 udp Oce SNMP Trap Port Peter Teeuwen Peter Teeuwen
esp-encap 2797 tcp esp-encap Jorn Sierwald Jorn Sierwald
esp-encap 2797 udp esp-encap Jorn Sierwald Jorn Sierwald
msrp 2855 tcp MSRP over TCP 2014-04-09 RFC 4976
citrix-rtmp 2897 tcp Citrix RTMP Myk Willis Myk Willis
citrix-rtmp 2897 udp Citrix RTMP Myk Willis Myk Willis
index-net 2970 tcp INDEX-NET Chris J. Wren Chris J. Wren
index-net 2970 udp INDEX-NET Chris J. Wren Chris J. Wren
netclip 2971 tcp NetClip clipboard daemon Rudi Chiarito Rudi Chiarito
netclip 2971 udp NetClip clipboard daemon Rudi Chiarito Rudi Chiarito
pmsm-webrctl 2972 tcp PMSM Webrctl Markus Michels Markus Michels
pmsm-webrctl 2972 udp PMSM Webrctl Markus Michels Markus Michels
svnetworks 2973 tcp SV Networks Sylvia Siu Sylvia Siu
svnetworks 2973 udp SV Networks Sylvia Siu Sylvia Siu
signal 2974 tcp Signal Wyatt Williams Wyatt Williams
signal 2974 udp Signal Wyatt Williams Wyatt Williams
fjmpcm 2975 tcp Fujitsu Configuration Management Service Hiroki Kawano Hiroki Kawano
fjmpcm 2975 udp Fujitsu Configuration Management Service Hiroki Kawano Hiroki Kawano
cns-srv-port 2976 tcp CNS Server Port Ram Golla Ram Golla
cns-srv-port 2976 udp CNS Server Port Ram Golla Ram Golla
ttc-etap-ns 2977 tcp TTCs Enterprise Test Access Protocol - NS
ttc-etap-ns 2977 udp TTCs Enterprise Test Access Protocol - NS
ttc-etap-ds 2978 tcp TTCs Enterprise Test Access Protocol - DS Daniel Becker Daniel Becker
ttc-etap-ds 2978 udp TTCs Enterprise Test Access Protocol - DS Daniel Becker Daniel Becker

Contact Information

Name Organization Contact URI Last Updated
Allan Panitch allanp&tcosoft.com
Allen Briggs briggs&access.rrinc.com
Ashit Patel Ashit.Patel&eng.sun.com
Bill Bishop bil&rfx.rfx.com
Chris J. Wren C.Wren&lucent.com
Daniel Becker beckerd&ttc.com
Gerry Dubois gdubois&carriustech.com 2005-08
Hiroki Kawano kawano&saint.nm.fujitsu.co.jp
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
James Falkner james.falkner&sun.com
Jeff Rosenthal jrosenthal&quad-sys.com
JG Heithcock Retrospect, Inc. JG.Heithcock&retrospect.com 2012-02-02
John Kelly johnk&bellhow.com
John Tokash jtokash&homestead.com
Jorn Sierwald joern.sierwald&datafellows.com
Keith Yarbrough kyarbro&windtraveller.com
Marie-France Dubreuil Marie-France.Dubreuil&evidian.com 2002-11
Mark Hanson markh&intersys.com
Markus Michels mmi&pmsmicado.com
Martin Kirk m.kirk&opengroup.org
Maurice R. Turcotte mailrus!uflorida!rm1!dnmrt%25rmatl@uunet.uu.net
Myk Willis myk.willis&citrix.com
NetOp Technical Support support&danware.dk
Peter Pramberger peter.pramberger&telering.co.at 2004-11
Peter Teeuwen ptee&oce.nl
Raimond Diederik rdiederik&descartes.com
Ram Golla rgolla&cisco.com
Retrospect, Inc. JG.Heithcock&retrospect.com 2012-02-02
Richard Alan Johnson raj&cisco.com
Robert A. Kukura kukura&apollo.hp.com
Robert Wiebe crw010&email.mot.com
Rudi Chiarito nutello&sweetness.com
Soumitra Sarkar sarkar&vnet.ibm.com
Steve T. Chiang schiang&cisco.com
Sylvia Siu ssiu&svnetworks.com
Wyatt Williams wyattw&icall.com
Yuri Machkasov yuri&ptc.com
Zygmunt Wiercioch zyg&jetform.com