Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| udrive | 1867 | udp | UDRIVE | Robby Walker | Robby Walker | ||||||
| sunscalar-dns | 1870 | tcp | SunSCALAR DNS Service | Sanjay Radia | Sanjay Radia | ||||||
| sunscalar-dns | 1870 | udp | SunSCALAR DNS Service | Sanjay Radia | Sanjay Radia | ||||||
| canocentral0 | 1871 | tcp | Cano Central 0 | ||||||||
| canocentral0 | 1871 | udp | Cano Central 0 | ||||||||
| canocentral1 | 1872 | tcp | Cano Central 1 | Mark McNamara | Mark McNamara | ||||||
| canocentral1 | 1872 | udp | Cano Central 1 | Mark McNamara | Mark McNamara | ||||||
| fjmpjps | 1873 | tcp | Fjmpjps | ||||||||
| fjmpjps | 1873 | udp | Fjmpjps | ||||||||
| fjswapsnp | 1874 | tcp | Fjswapsnp | Y. Ohiwa | Y. Ohiwa | ||||||
| fjswapsnp | 1874 | udp | Fjswapsnp | Y. Ohiwa | Y. Ohiwa | ||||||
| westell-stats | 1875 | tcp | westell stats | Thomas McCabe | Thomas McCabe | ||||||
| westell-stats | 1875 | udp | westell stats | Thomas McCabe | Thomas McCabe | ||||||
| ewcappsrv | 1876 | tcp | ewcappsrv | Howard Yin | Howard Yin | ||||||
| ewcappsrv | 1876 | udp | ewcappsrv | Howard Yin | Howard Yin | ||||||
| hp-webqosdb | 1877 | tcp | hp-webqosdb | Kim Scott | Kim Scott | ||||||
| hp-webqosdb | 1877 | udp | hp-webqosdb | Kim Scott | Kim Scott | ||||||
| drmsmc | 1878 | tcp | drmsmc | Katsuhiko Abe | Katsuhiko Abe | ||||||
| drmsmc | 1878 | udp | drmsmc | Katsuhiko Abe | Katsuhiko Abe | ||||||
| nettgain-nms | 1879 | tcp | NettGain NMS | Dr. Yair Shapira | Dr. Yair Shapira | ||||||
| nettgain-nms | 1879 | udp | NettGain NMS | Dr. Yair Shapira | Dr. Yair Shapira | ||||||
| filex-lport | 1887 | tcp | FileX Listening Port | Megan Woods | Megan Woods | ||||||
| filex-lport | 1887 | udp | FileX Listening Port | Megan Woods | Megan Woods | ||||||
| metaagent | 1897 | tcp | MetaAgent | Marie-France Dubreuil | Marie-France Dubreuil | ||||||
| metaagent | 1897 | udp | MetaAgent | Marie-France Dubreuil | Marie-France Dubreuil | ||||||
| intrastar | 1907 | tcp | IntraSTAR | Peter Schoenberger | Peter Schoenberger | ||||||
| intrastar | 1907 | udp | IntraSTAR | Peter Schoenberger | Peter Schoenberger | ||||||
| noagent | 1917 | tcp | nOAgent | Martin Bestmann | Martin Bestmann | ||||||
| noagent | 1917 | udp | nOAgent | Martin Bestmann | Martin Bestmann | ||||||
| videte-cipc | 1927 | tcp | Videte CIPC Port | Videte IT | Videte IT | ||||||
| videte-cipc | 1927 | udp | Videte CIPC Port | Videte IT | Videte IT | ||||||
| jwserver | 1937 | tcp | JetVWay Server Port | ||||||||
| jwserver | 1937 | udp | JetVWay Server Port | ||||||||
| sentinelsrm | 1947 | tcp | SentinelSRM | Michael Zunke | Michael Zunke | 2010-07-23 | Unauthorized Use Known on port 1947 | ||||
| sentinelsrm | 1947 | udp | SentinelSRM | Michael Zunke | Michael Zunke | 2010-07-23 | Unauthorized Use Known on port 1947 | ||||
| unix-status | 1957 | tcp | unix-status | Thomas Erskine | Thomas Erskine | ||||||
| unix-status | 1957 | udp | unix-status | Thomas Erskine | Thomas Erskine | ||||||
| sns-quote | 1967 | tcp | SNS Quote | Robert Ellman | Robert Ellman | ||||||
| sns-quote | 1967 | udp | SNS Quote | Robert Ellman | Robert Ellman | ||||||
| netop-rc | 1970 | tcp | NetOp Remote Control | ||||||||
| netop-rc | 1970 | udp | NetOp Remote Control | ||||||||
| netop-school | 1971 | tcp | NetOp School | NetOp Technical Support | NetOp Technical Support | ||||||
| netop-school | 1971 | udp | NetOp School | NetOp Technical Support | NetOp Technical Support | ||||||
| intersys-cache | 1972 | tcp | Cache | Mark Hanson | Mark Hanson | ||||||
| intersys-cache | 1972 | udp | Cache | Mark Hanson | Mark Hanson | ||||||
| dlsrap | 1973 | tcp | Data Link Switching Remote Access Protocol | Steve T. Chiang | Steve T. Chiang | ||||||
| dlsrap | 1973 | udp | Data Link Switching Remote Access Protocol | Steve T. Chiang | Steve T. Chiang | ||||||
| drp | 1974 | tcp | DRP | Richard Alan Johnson | Richard Alan Johnson | ||||||
| drp | 1974 | udp | DRP | Richard Alan Johnson | Richard Alan Johnson | ||||||
| tcoflashagent | 1975 | tcp | TCO Flash Agent | ||||||||
| tcoflashagent | 1975 | udp | TCO Flash Agent | ||||||||
| tcoregagent | 1976 | tcp | TCO Reg Agent | ||||||||
| tcoregagent | 1976 | udp | TCO Reg Agent | ||||||||
| tcoaddressbook | 1977 | tcp | TCO Address Book | Allan Panitch | Allan Panitch | ||||||
| tcoaddressbook | 1977 | udp | TCO Address Book | Allan Panitch | Allan Panitch | ||||||
| unisql | 1978 | tcp | UniSQL | ||||||||
| unisql | 1978 | udp | UniSQL | ||||||||
| unisql-java | 1979 | tcp | UniSQL Java | Keith Yarbrough | Keith Yarbrough | ||||||
| unisql-java | 1979 | udp | UniSQL Java | Keith Yarbrough | Keith Yarbrough | ||||||
| tr-rsrb-p1 | 1987 | tcp | cisco RSRB Priority 1 port | ||||||||
| tr-rsrb-p1 | 1987 | udp | cisco RSRB Priority 1 port | ||||||||
| gdp-port | 1997 | tcp | cisco Gateway Discovery Protocol | ||||||||
| gdp-port | 1997 | udp | cisco Gateway Discovery Protocol | ||||||||
| dectalk | 2007 | tcp | |||||||||
| raid-am | 2007 | udp | |||||||||
| cypress-stat | 2017 | tcp | |||||||||
| bootclient | 2017 | udp | |||||||||
| shadowserver | 2027 | tcp | |||||||||
| shadowserver | 2027 | udp | |||||||||
| applus | 2037 | tcp | APplus Application Server | Alfred Weindl | Marcus Schairer | 2008-06-06 | 2021-07-20 | Unauthorized Use Known on port 2037 | Formerly was P2plus Application Server | ||
| applus | 2037 | udp | APplus Application Server | Alfred Weindl | Marcus Schairer | 2008-06-06 | 2021-07-20 | Unauthorized Use Known on port 2037 | Formerly was P2plus Application Server | ||
| dls | 2047 | tcp | |||||||||
| dls | 2047 | udp | |||||||||
| rich-cp | 2057 | tcp | Rich Content Protocol | Ronen Vainish | Ronen Vainish | ||||||
| rich-cp | 2057 | udp | Rich Content Protocol | Ronen Vainish | Ronen Vainish | ||||||
| dlswpn | 2067 | tcp | Data Link Switch Write Port Number | Amir Peless | Amir Peless | ||||||
| dlswpn | 2067 | udp | Data Link Switch Write Port Number | Amir Peless | Amir Peless | ||||||
| ah-esp-encap | 2070 | tcp | AH and ESP Encapsulated in UDP packet | Amy Weaver | Amy Weaver | ||||||
| ah-esp-encap | 2070 | udp | AH and ESP Encapsulated in UDP packet | Amy Weaver | Amy Weaver | ||||||
| acp-port | 2071 | tcp | Axon Control Protocol | Christiaan Simons | Christiaan Simons | ||||||
| acp-port | 2071 | udp | Axon Control Protocol | Christiaan Simons | Christiaan Simons | ||||||
| msync | 2072 | tcp | GlobeCast mSync | Piers Scannell | Piers Scannell | ||||||
| msync | 2072 | udp | GlobeCast mSync | Piers Scannell | Piers Scannell | ||||||
| gxs-data-port | 2073 | tcp | DataReel Database Socket | Douglas M. Gaer | Douglas M. Gaer | ||||||
| gxs-data-port | 2073 | udp | DataReel Database Socket | Douglas M. Gaer | Douglas M. Gaer | ||||||
| vrtl-vmf-sa | 2074 | tcp | Vertel VMF SA | Alan Akahoshi | Alan Akahoshi | ||||||
| vrtl-vmf-sa | 2074 | udp | Vertel VMF SA | Alan Akahoshi | Alan Akahoshi | ||||||
| newlixengine | 2075 | tcp | Newlix ServerWare Engine | ||||||||
| newlixengine | 2075 | udp | Newlix ServerWare Engine | ||||||||
| newlixconfig | 2076 | tcp | Newlix JSPConfig | Jean-Serge Gagnon | Jean-Serge Gagnon | ||||||
| newlixconfig | 2076 | udp | Newlix JSPConfig | Jean-Serge Gagnon | Jean-Serge Gagnon | ||||||
| tsrmagt | 2077 | tcp | Old Tivoli Storage Manager | ||||||||
| tsrmagt | 2077 | udp | Old Tivoli Storage Manager | ||||||||
| tpcsrvr | 2078 | tcp | IBM Total Productivity Center Server | Justin R. Bendich | Justin R. Bendich | ||||||
| tpcsrvr | 2078 | udp | IBM Total Productivity Center Server | Justin R. Bendich | Justin R. Bendich | ||||||
| idware-router | 2079 | tcp | IDWARE Router Port | Zdenek Kolba | Zdenek Kolba | ||||||
| idware-router | 2079 | udp | IDWARE Router Port | Zdenek Kolba | Zdenek Kolba | ||||||
| radsec | 2083 | udp | Secure Radius Service | IESG | IETF Chair | 2005-05 | 2014-07-14 | RFC 7360 | The UDP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC. | ||
| eli | 2087 | tcp | ELI - Event Logging Integration | Maya Zimerman | Maya Zimerman | ||||||
| eli | 2087 | udp | ELI - Event Logging Integration | Maya Zimerman | Maya Zimerman | ||||||
| jetformpreview | 2097 | tcp | Jet Form Preview | Zygmunt Wiercioch | Zygmunt Wiercioch |