Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
tr-rsrb-p1 1987 tcp cisco RSRB Priority 1 port
tr-rsrb-p1 1987 udp cisco RSRB Priority 1 port
tr-rsrb-p2 1988 tcp cisco RSRB Priority 2 port
tr-rsrb-p2 1988 udp cisco RSRB Priority 2 port
tr-rsrb-p3 1989 tcp cisco RSRB Priority 3 port
tr-rsrb-p3 1989 udp cisco RSRB Priority 3 port
mshnet 1989 tcp MHSnet system Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
mshnet 1989 udp MHSnet system Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
stun-p1 1990 tcp cisco STUN Priority 1 port
stun-p1 1990 udp cisco STUN Priority 1 port
stun-p2 1991 tcp cisco STUN Priority 2 port
stun-p2 1991 udp cisco STUN Priority 2 port
stun-p3 1992 tcp cisco STUN Priority 3 port
stun-p3 1992 udp cisco STUN Priority 3 port
ipsendmsg 1992 tcp IPsendmsg Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
ipsendmsg 1992 udp IPsendmsg Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
snmp-tcp-port 1993 tcp cisco SNMP TCP port
snmp-tcp-port 1993 udp cisco SNMP TCP port
stun-port 1994 tcp cisco serial tunnel port
stun-port 1994 udp cisco serial tunnel port
perf-port 1995 tcp cisco perf port
perf-port 1995 udp cisco perf port
tr-rsrb-port 1996 tcp cisco Remote SRB port
tr-rsrb-port 1996 udp cisco Remote SRB port
gdp-port 1997 tcp cisco Gateway Discovery Protocol
gdp-port 1997 udp cisco Gateway Discovery Protocol
x25-svc-port 1998 tcp cisco X.25 service (XOT)
x25-svc-port 1998 udp cisco X.25 service (XOT)
tcp-id-port 1999 tcp cisco identification port
tcp-id-port 1999 udp cisco identification port
news 2009 tcp
whosockami 2009 udp
whosockami 2019 tcp
about 2019 udp
hsrpv6 2029 tcp Hot Standby Router Protocol IPv6 Ian Wilson Ian Wilson 2004-11
hsrpv6 2029 udp Hot Standby Router Protocol IPv6 Ian Wilson Ian Wilson 2004-11
prizma 2039 tcp Prizma Monitoring Service Dotan Ofek Dotan Ofek 2005-12
prizma 2039 udp Prizma Monitoring Service Dotan Ofek Dotan Ofek 2005-12
shilp 2049 tcp <== NOTE Conflict on 2049 !
shilp 2049 udp <== NOTE Conflict on 2049 !
nfs 2049 tcp Network File System - Sun Microsystems Brent Callaghan Brent Callaghan Defined TXT keys: path=<path to mount point>
nfs 2049 udp Network File System - Sun Microsystems Brent Callaghan Brent Callaghan Defined TXT keys: path=<path to mount point>
nfs 2049 sctp Network File System RFC 5665 Defined TXT keys: path=<path to mount point>
bmc-messaging 2059 tcp BMC Messaging Service Portnoy Boxman Portnoy Boxman
bmc-messaging 2059 udp BMC Messaging Service Portnoy Boxman Portnoy Boxman
event-port 2069 tcp HTTP Event Port Larry Emlich Larry Emlich
event-port 2069 udp HTTP Event Port Larry Emlich Larry Emlich
idware-router 2079 tcp IDWARE Router Port Zdenek Kolba Zdenek Kolba
idware-router 2079 udp IDWARE Router Port Zdenek Kolba Zdenek Kolba
sep 2089 tcp Security Encapsulation Protocol - SEP Maya Zimerman Maya Zimerman
sep 2089 udp Security Encapsulation Protocol - SEP Maya Zimerman Maya Zimerman
lrp 2090 tcp Load Report Protocol Amir Peless Amir Peless
lrp 2090 udp Load Report Protocol Amir Peless Amir Peless
prp 2091 tcp PRP Amir Peless Amir Peless
prp 2091 udp PRP Amir Peless Amir Peless
descent3 2092 tcp Descent 3 Kevin Bentley Kevin Bentley
descent3 2092 udp Descent 3 Kevin Bentley Kevin Bentley
nbx-cc 2093 tcp NBX CC
nbx-cc 2093 udp NBX CC
nbx-au 2094 tcp NBX AU
nbx-au 2094 udp NBX AU
nbx-ser 2095 tcp NBX SER
nbx-ser 2095 udp NBX SER
nbx-dir 2096 tcp NBX DIR Henry Houh Henry Houh
nbx-dir 2096 udp NBX DIR Henry Houh Henry Houh
jetformpreview 2097 tcp Jet Form Preview Zygmunt Wiercioch Zygmunt Wiercioch
jetformpreview 2097 udp Jet Form Preview Zygmunt Wiercioch Zygmunt Wiercioch
dialog-port 2098 tcp Dialog Port Joseph Mathew Joseph Mathew
dialog-port 2098 udp Dialog Port Joseph Mathew Joseph Mathew
h2250-annex-g 2099 tcp H.225.0 Annex G Signalling ITU-T ITU-T TSB 2013-01-31
h2250-annex-g 2099 udp H.225.0 Annex G Signalling ITU-T ITU-T TSB 2013-01-31
ergolight 2109 tcp Ergolight Jindra Ryvola Jindra Ryvola
ergolight 2109 udp Ergolight Jindra Ryvola Jindra Ryvola
gsigatekeeper 2119 tcp GSIGATEKEEPER Steve Tuecke Steve Tuecke
gsigatekeeper 2119 udp GSIGATEKEEPER Steve Tuecke Steve Tuecke
cs-live 2129 tcp cs-live.com Matt Lachance Matt Lachance
cs-live 2129 udp cs-live.com Matt Lachance Matt Lachance
ias-auth 2139 tcp IAS-AUTH
ias-auth 2139 udp IAS-AUTH
acptsys 2149 tcp ACPTSYS Michael Lekias Michael Lekias
acptsys 2149 udp ACPTSYS Michael Lekias Michael Lekias
gdbremote 2159 tcp GDB Remote Debug Port Nigel Stephens Nigel Stephens
gdbremote 2159 udp GDB Remote Debug Port Nigel Stephens Nigel Stephens
brain 2169 tcp Backbone for Academic Information Notification (BRAIN) Archishmat Gore Archishmat Gore 2004-11
brain 2169 udp Backbone for Academic Information Notification (BRAIN) Archishmat Gore Archishmat Gore 2004-11
vmrdp 2179 tcp Microsoft RDP for virtual machines Brian Henry Brian Henry 2007-03
vmrdp 2179 udp Microsoft RDP for virtual machines Brian Henry Brian Henry 2007-03
radware-rpm-s 2189 tcp Secure Radware Resource Pool Manager Radware LTD. Samuel Bercovici 2011-08-05
2189 udp Reserved
tivoconnect 2190 tcp TiVoConnect Beacon Jeffrey J. Peters Jeffrey J. Peters 2002-08
tivoconnect 2190 udp TiVoConnect Beacon Jeffrey J. Peters Jeffrey J. Peters 2002-08
tvbus 2191 tcp TvBus Messaging Brian W. Beach Brian W. Beach 2003-01
tvbus 2191 udp TvBus Messaging Brian W. Beach Brian W. Beach 2003-01
asdis 2192 tcp ASDIS software management ASDIS Support ASDIS Support 2005-08
asdis 2192 udp ASDIS software management ASDIS Support ASDIS Support 2005-08
drwcs 2193 tcp Dr.Web Enterprise Management Service Eugeny Gladkih Eugeny Gladkih 2008-01-31
drwcs 2193 udp Dr.Web Enterprise Management Service Eugeny Gladkih Eugeny Gladkih 2008-01-31
2194-2196 Unassigned Unauthorized Use Known on ports 2194-2196
mnp-exchange 2197 tcp MNP data exchange Peter Pramberger Peter Pramberger 2004-11
mnp-exchange 2197 udp MNP data exchange Peter Pramberger Peter Pramberger 2004-11
onehome-remote 2198 tcp OneHome Remote Access

Contact Information

Name Organization Contact URI Last Updated
ASDIS Support support&asdis.de 2005-08
Amir Peless amirp&radware.co.il
Archishmat Gore archisgore&yahoo.com 2004-11
Bob Kummerfeld bob&sarad.cs.su.oz.au
Brent Callaghan brent&terra.eng.sun.com
Brian Henry brian.henry&microsoft.com 2007-03
Brian W. Beach brian&tivo.com 2003-01
Dotan Ofek dotan.ofek&prizmasoft.com 2005-12
Eugeny Gladkih john&drweb.com 2008-01-31
Henry Houh hhouh&nbxcorp.com
ITU-T tsbsg16&itu.int 2013-01-31
ITU-T TSB ITU-T tsbsg16&itu.int 2013-01-31
Ian Wilson hsrp-info&cisco.com 2004-11
Jeffrey J. Peters jpeters&tivo.com 2002-08
Jindra Ryvola jryvola&ledalite.com
Joseph Mathew mjoseph&dosa.cisco.com
Kevin Bentley Kevin&outrage.com
Larry Emlich larry.emlich&compaq.com
Matt Lachance matt&cs-live.com
Maya Zimerman mayaz&radware.co.il
Michael Lekias admin&psdesign.com.au
Nigel Stephens nigel&algor.co.uk
Peter Pramberger peter.pramberger&telering.co.at 2004-11
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Radware LTD. samuelb&radware.com 2011-08-05
Samuel Bercovici samuelb&radware.com 2011-08-05
Steve Tuecke tuecke&mcs.anl.gov
Zdenek Kolba zdenek.kolba&id-karta.cz
Zygmunt Wiercioch zyg&jetform.com