Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| cft-4 | 1765 | udp | cft-4 | Martine Marchand | Martine Marchand | ||||||
| cft-5 | 1766 | tcp | cft-5 | Martine Marchand | Martine Marchand | ||||||
| cft-5 | 1766 | udp | cft-5 | Martine Marchand | Martine Marchand | ||||||
| vdab | 1775 | tcp | data interchange between visual processing containers | MJA Technology LLC | Mark J. App | 2014-04-23 | |||||
| 1775 | udp | Reserved | |||||||||
| windlm | 1785 | tcp | Wind River Systems License Manager | Will Dere | Will Dere | ||||||
| windlm | 1785 | udp | Wind River Systems License Manager | Will Dere | Will Dere | ||||||
| dpi-proxy | 1795 | tcp | dpi-proxy | Charles Gordon | Charles Gordon | ||||||
| dpi-proxy | 1795 | udp | dpi-proxy | Charles Gordon | Charles Gordon | ||||||
| enl-name | 1805 | tcp | ENL-Name | Brian Olson | Brian Olson | ||||||
| enl-name | 1805 | udp | ENL-Name | Brian Olson | Brian Olson | ||||||
| radius | 1812 | tcp | RADIUS | RFC 2865 | |||||||
| radius | 1812 | udp | RADIUS | RFC 2865 | |||||||
| mmpft | 1815 | tcp | Manufacturing messaging protocol for factory transmission | Ralf Muckenhirn | Ralf Muckenhirn | 2024-06-12 | |||||
| mmpft | 1815 | udp | Manufacturing messaging protocol for factory transmission | Ralf Muckenhirn | Ralf Muckenhirn | 2024-06-12 | |||||
| direcpc-video | 1825 | tcp | DirecPC Video | Chris Kerrigan | Chris Kerrigan | ||||||
| direcpc-video | 1825 | udp | DirecPC Video | Chris Kerrigan | Chris Kerrigan | ||||||
| ardusmul | 1835 | tcp | ARDUS Multicast | Toshikatsu Ito | Toshikatsu Ito | ||||||
| ardusmul | 1835 | udp | ARDUS Multicast | Toshikatsu Ito | Toshikatsu Ito | ||||||
| netopia-vo5 | 1843 | tcp | netopia-vo5 | Marc Epard | Marc Epard | ||||||
| netopia-vo5 | 1843 | udp | netopia-vo5 | Marc Epard | Marc Epard | ||||||
| altalink | 1845 | tcp | altalink | Alberto Raydan | Alberto Raydan | ||||||
| altalink | 1845 | udp | altalink | Alberto Raydan | Alberto Raydan | ||||||
| gsi | 1850 | tcp | GSI | William Mullaney | William Mullaney | ||||||
| gsi | 1850 | udp | GSI | William Mullaney | William Mullaney | ||||||
| ctcd | 1851 | tcp | ctcd | John Ryan | John Ryan | ||||||
| ctcd | 1851 | udp | ctcd | John Ryan | John Ryan | ||||||
| virtual-time | 1852 | tcp | Virtual Time | Angie S. Morner | Angie S. Morner | ||||||
| virtual-time | 1852 | udp | Virtual Time | Angie S. Morner | Angie S. Morner | ||||||
| vids-avtp | 1853 | tcp | VIDS-AVTP | Sascha Kuemmel | Sascha Kuemmel | ||||||
| vids-avtp | 1853 | udp | VIDS-AVTP | Sascha Kuemmel | Sascha Kuemmel | ||||||
| buddy-draw | 1854 | tcp | Buddy Draw | Marvin Shin | Marvin Shin | ||||||
| buddy-draw | 1854 | udp | Buddy Draw | Marvin Shin | Marvin Shin | ||||||
| fiorano-rtrsvc | 1855 | tcp | Fiorano RtrSvc | ||||||||
| fiorano-rtrsvc | 1855 | udp | Fiorano RtrSvc | ||||||||
| fiorano-msgsvc | 1856 | tcp | Fiorano MsgSvc | Albert Holt | Albert Holt | ||||||
| fiorano-msgsvc | 1856 | udp | Fiorano MsgSvc | Albert Holt | Albert Holt | ||||||
| datacaptor | 1857 | tcp | DataCaptor | Steven M. Forrester | Steven M. Forrester | ||||||
| datacaptor | 1857 | udp | DataCaptor | Steven M. Forrester | Steven M. Forrester | ||||||
| privateark | 1858 | tcp | PrivateArk | Ronen Zoran | Ronen Zoran | ||||||
| privateark | 1858 | udp | PrivateArk | Ronen Zoran | Ronen Zoran | ||||||
| gammafetchsvr | 1859 | tcp | Gamma Fetcher Server | Cnaan Aviv | Cnaan Aviv | ||||||
| gammafetchsvr | 1859 | udp | Gamma Fetcher Server | Cnaan Aviv | Cnaan Aviv | ||||||
| entp | 1865 | tcp | ENTP | Seiko Epson | Seiko Epson | ||||||
| entp | 1865 | udp | ENTP | Seiko Epson | Seiko Epson | ||||||
| westell-stats | 1875 | tcp | westell stats | Thomas McCabe | Thomas McCabe | ||||||
| westell-stats | 1875 | udp | westell stats | Thomas McCabe | Thomas McCabe | ||||||
| vrtstrapserver | 1885 | tcp | Veritas Trap Server | Russell Thrasher | Russell Thrasher | ||||||
| vrtstrapserver | 1885 | udp | Veritas Trap Server | Russell Thrasher | Russell Thrasher | ||||||
| 1895 | tcp | unassigned | Microsoft (unoffically) using 1895 | ||||||||
| 1895 | udp | unassigned | Microsoft (unoffically) using 1895 | ||||||||
| sugp | 1905 | tcp | Secure UP.Link Gateway Protocol | Peter King | Peter King | ||||||
| sugp | 1905 | udp | Secure UP.Link Gateway Protocol | Peter King | Peter King | ||||||
| facelink | 1915 | tcp | FACELINK | J.H. Hermans | J.H. Hermans | ||||||
| facelink | 1915 | udp | FACELINK | J.H. Hermans | J.H. Hermans | ||||||
| discovery-port | 1925 | tcp | Surrogate Discovery Port | Keith Thompson | Keith Thompson | ||||||
| discovery-port | 1925 | udp | Surrogate Discovery Port | Keith Thompson | Keith Thompson | ||||||
| macromedia-fcs | 1935 | tcp | Macromedia Flash Communications Server MX | Pritham Shetty | Pritham Shetty | ||||||
| macromedia-fcs | 1935 | udp | Macromedia Flash Communications server MX | Pritham Shetty | Pritham Shetty | ||||||
| dialogic-elmd | 1945 | tcp | dialogic-elmd | Roger Kay | Roger Kay | ||||||
| dialogic-elmd | 1945 | udp | dialogic-elmd | Roger Kay | Roger Kay | ||||||
| ismaeasdaqtest | 1950 | tcp | ISMA Easdaq Test | Stephen Dunne | Stephen Dunne | ||||||
| ismaeasdaqtest | 1950 | udp | ISMA Easdaq Test | Stephen Dunne | Stephen Dunne | ||||||
| bcs-lmserver | 1951 | tcp | bcs-lmserver | Andy Warner | Andy Warner | ||||||
| bcs-lmserver | 1951 | udp | bcs-lmserver | Andy Warner | Andy Warner | ||||||
| mpnjsc | 1952 | tcp | mpnjsc | Takenori Miyahara | Takenori Miyahara | ||||||
| mpnjsc | 1952 | udp | mpnjsc | Takenori Miyahara | Takenori Miyahara | ||||||
| rapidbase | 1953 | tcp | Rapid Base | Antoni Wolski | Antoni Wolski | ||||||
| rapidbase | 1953 | udp | Rapid Base | Antoni Wolski | Antoni Wolski | ||||||
| abr-api | 1954 | tcp | ABR-API (diskbridge) | ||||||||
| abr-api | 1954 | udp | ABR-API (diskbridge) | ||||||||
| abr-secure | 1955 | tcp | ABR-Secure Data (diskbridge) | Graham Wooden | Graham Wooden | ||||||
| abr-secure | 1955 | udp | ABR-Secure Data (diskbridge) | Graham Wooden | Graham Wooden | ||||||
| vrtl-vmf-ds | 1956 | tcp | Vertel VMF DS | Alan Akahoshi | Alan Akahoshi | ||||||
| vrtl-vmf-ds | 1956 | udp | Vertel VMF DS | Alan Akahoshi | Alan Akahoshi | ||||||
| unix-status | 1957 | tcp | unix-status | Thomas Erskine | Thomas Erskine | ||||||
| unix-status | 1957 | udp | unix-status | Thomas Erskine | Thomas Erskine | ||||||
| dxadmind | 1958 | tcp | CA Administration Daemon | John Birrell | John Birrell | ||||||
| dxadmind | 1958 | udp | CA Administration Daemon | John Birrell | John Birrell | ||||||
| simp-all | 1959 | tcp | SIMP Channel | Tim Hunnewell | Tim Hunnewell | ||||||
| simp-all | 1959 | udp | SIMP Channel | Tim Hunnewell | Tim Hunnewell | ||||||
| tivoli-npm | 1965 | tcp | Tivoli NPM | Ivana Cuozzo | Ivana Cuozzo | ||||||
| tivoli-npm | 1965 | udp | Tivoli NPM | Ivana Cuozzo | Ivana Cuozzo | ||||||
| tcoflashagent | 1975 | tcp | TCO Flash Agent | ||||||||
| tcoflashagent | 1975 | udp | TCO Flash Agent | ||||||||
| hsrp | 1985 | tcp | Hot Standby Router Protocol | RFC 2281 | |||||||
| hsrp | 1985 | udp | Hot Standby Router Protocol | RFC 2281 | |||||||
| perf-port | 1995 | tcp | cisco perf port | ||||||||
| perf-port | 1995 | udp | cisco perf port | ||||||||
| x25-svc-port | 1998 | tcp | cisco X.25 service (XOT) | ||||||||
| x25-svc-port | 1998 | udp | cisco X.25 service (XOT) | ||||||||
| berknet | 2005 | tcp | |||||||||
| oracle | 2005 | udp | |||||||||
| cypress | 2015 | tcp | |||||||||
| raid-cs | 2015 | udp | |||||||||
| ellpack | 2025 | tcp | |||||||||
| xribs | 2025 | udp | |||||||||
| imsldoc | 2035 | tcp | |||||||||
| imsldoc | 2035 | udp | |||||||||
| cdfunc | 2045 | tcp | |||||||||
| cdfunc | 2045 | udp |