Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| jetformpreview | 2097 | tcp | Jet Form Preview | Zygmunt Wiercioch | Zygmunt Wiercioch | ||||||
| jetformpreview | 2097 | udp | Jet Form Preview | Zygmunt Wiercioch | Zygmunt Wiercioch | ||||||
| bintec-admin | 2107 | tcp | BinTec Admin | Thomas Schmidt | Thomas Schmidt | ||||||
| bintec-admin | 2107 | udp | BinTec Admin | Thomas Schmidt | Thomas Schmidt | ||||||
| mentaclient | 2117 | tcp | MENTACLIENT | ||||||||
| mentaclient | 2117 | udp | MENTACLIENT | ||||||||
| index-pc-wb | 2127 | tcp | INDEX-PC-WB | James David Fisher | James David Fisher | ||||||
| index-pc-wb | 2127 | udp | INDEX-PC-WB | James David Fisher | James David Fisher | ||||||
| connect | 2137 | tcp | CONNECT | Reid Ligon | Reid Ligon | ||||||
| connect | 2137 | udp | CONNECT | Reid Ligon | Reid Ligon | ||||||
| tdmoip | 2142 | tcp | TDM OVER IP | Yaakov Stein | Yaakov Stein | 2016-09-21 | RFC 5087 | ||||
| tdmoip | 2142 | udp | TDM OVER IP | Yaakov Stein | Yaakov Stein | 2016-09-21 | RFC 5087 | ||||
| lv-auth | 2147 | tcp | Live Vault Authentication | Ted Hess | Ted Hess | ||||||
| lv-auth | 2147 | udp | Live Vault Authentication | Ted Hess | Ted Hess | ||||||
| xnds | 2157 | tcp | Xerox Network Document Scan Protocol | William R. Lear | William R. Lear | 2008-03-06 | |||||
| xnds | 2157 | udp | Xerox Network Document Scan Protocol | William R. Lear | William R. Lear | 2008-03-06 | |||||
| raw-serial | 2167 | tcp | Raw Async Serial Link | Benjamin Green | Benjamin Green | ||||||
| raw-serial | 2167 | udp | Raw Async Serial Link | Benjamin Green | Benjamin Green | ||||||
| eyetv | 2170 | tcp | EyeTV Server Port | Elgato Systems | Elgato Systems | 2004-11 | |||||
| eyetv | 2170 | udp | EyeTV Server Port | Elgato Systems | Elgato Systems | 2004-11 | |||||
| msfw-storage | 2171 | tcp | MS Firewall Storage | ||||||||
| msfw-storage | 2171 | udp | MS Firewall Storage | ||||||||
| msfw-s-storage | 2172 | tcp | MS Firewall SecureStorage | ||||||||
| msfw-s-storage | 2172 | udp | MS Firewall SecureStorage | ||||||||
| msfw-replica | 2173 | tcp | MS Firewall Replication | ||||||||
| msfw-replica | 2173 | udp | MS Firewall Replication | ||||||||
| msfw-array | 2174 | tcp | MS Firewall Intra Array | Itai Greenberg | Itai Greenberg | 2004-11 | |||||
| msfw-array | 2174 | udp | MS Firewall Intra Array | Itai Greenberg | Itai Greenberg | 2004-11 | |||||
| airsync | 2175 | tcp | Microsoft Desktop AirSync Protocol | ||||||||
| airsync | 2175 | udp | Microsoft Desktop AirSync Protocol | ||||||||
| rapi | 2176 | tcp | Microsoft ActiveSync Remote API | Jon Xu | Jon Xu | 2005-08 | |||||
| rapi | 2176 | udp | Microsoft ActiveSync Remote API | Jon Xu | Jon Xu | 2005-08 | |||||
| qwave | 2177 | tcp | qWAVE Bandwidth Estimate | Gabe Frost | Gabe Frost | 2005-08 | |||||
| qwave | 2177 | udp | qWAVE Bandwidth Estimate | Gabe Frost | Gabe Frost | 2005-08 | |||||
| bitspeer | 2178 | tcp | Peer Services for BITS | Jeff Roberts | Jeff Roberts | 2005-11 | |||||
| bitspeer | 2178 | udp | Peer Services for BITS | Jeff Roberts | Jeff Roberts | 2005-11 | |||||
| vmrdp | 2179 | tcp | Microsoft RDP for virtual machines | Brian Henry | Brian Henry | 2007-03 | |||||
| vmrdp | 2179 | udp | Microsoft RDP for virtual machines | Brian Henry | Brian Henry | 2007-03 | |||||
| ssmc | 2187 | tcp | Sepehr System Management Control | ||||||||
| ssmd | 2187 | udp | Sepehr System Management Data | Shahriar Pourazin | Shahriar Pourazin | 2008-12-02 | |||||
| mnp-exchange | 2197 | tcp | MNP data exchange | Peter Pramberger | Peter Pramberger | 2004-11 | |||||
| mnp-exchange | 2197 | udp | MNP data exchange | Peter Pramberger | Peter Pramberger | 2004-11 | |||||
| 2200 | tcp | Reserved | This entry has been removed on 2019-07-05. | ||||||||
| 2200 | udp | Reserved | This entry has been removed on 2019-07-05. | ||||||||
| hpssd | 2207 | tcp | HP Status and Services | Donald Welch | Donald Welch | 2006-05 | |||||
| hpssd | 2207 | udp | HP Status and Services | Donald Welch | Donald Welch | 2006-05 | |||||
| gotodevice | 2217 | tcp | GoToDevice Device Management | John Lisek | John Lisek | 2006-01 | |||||
| gotodevice | 2217 | udp | GoToDevice Device Management | John Lisek | John Lisek | 2006-01 | |||||
| di-msg | 2227 | tcp | DI Messaging Service | Sean Ni | Sean Ni | 2006-02 | |||||
| di-msg | 2227 | udp | DI Messaging Service | Sean Ni | Sean Ni | 2006-02 | |||||
| optech-port1-lm | 2237 | tcp | Optech Port1 License Manager | Gerard Cannie | Gerard Cannie | ||||||
| optech-port1-lm | 2237 | udp | Optech Port1 License Manager | Gerard Cannie | Gerard Cannie | ||||||
| antidotemgrsvr | 2247 | tcp | Antidote Deployment Manager Service | Rod Waltermann | Rod Waltermann | 2006-02 | |||||
| antidotemgrsvr | 2247 | udp | Antidote Deployment Manager Service | Rod Waltermann | Rod Waltermann | 2006-02 | |||||
| simple-tx-rx | 2257 | tcp | simple text/file transfer | Daniel Kilsdonk | Daniel Kilsdonk | 2006-08 | |||||
| simple-tx-rx | 2257 | udp | simple text/file transfer | Daniel Kilsdonk | Daniel Kilsdonk | 2006-08 | |||||
| ontobroker | 2267 | tcp | OntoBroker | Dr. Michael Erdmann | Dr. Michael Erdmann | 2004-12 | |||||
| ontobroker | 2267 | udp | OntoBroker | Dr. Michael Erdmann | Dr. Michael Erdmann | 2004-12 | |||||
| amt | 2268 | tcp | AMT | IESG | IETF Chair | 2004-12 | 2014-12-17 | RFC 7450 | |||
| amt | 2268 | udp | AMT | IESG | IETF Chair | 2004-12 | 2014-12-17 | RFC 7450 | |||
| starschool | 2270 | tcp | starSchool | Adam Ernst | Adam Ernst | 2004-12 | |||||
| starschool | 2270 | udp | starSchool | Adam Ernst | Adam Ernst | 2004-12 | |||||
| mmcals | 2271 | tcp | Secure Meeting Maker Scheduling | ||||||||
| mmcals | 2271 | udp | Secure Meeting Maker Scheduling | ||||||||
| mmcal | 2272 | tcp | Meeting Maker Scheduling | Andrew H Derbyshire | Andrew H Derbyshire | 2004-12 | |||||
| mmcal | 2272 | udp | Meeting Maker Scheduling | Andrew H Derbyshire | Andrew H Derbyshire | 2004-12 | |||||
| mysql-im | 2273 | tcp | MySQL Instance Manager | Petr Chardin | Petr Chardin | 2004-12 | |||||
| mysql-im | 2273 | udp | MySQL Instance Manager | Petr Chardin | Petr Chardin | 2004-12 | |||||
| pcttunnell | 2274 | tcp | PCTTunneller | ProControl Technology AB | ProControl Technology AB | 2004-12 | |||||
| pcttunnell | 2274 | udp | PCTTunneller | ProControl Technology AB | ProControl Technology AB | 2004-12 | |||||
| ibridge-data | 2275 | tcp | iBridge Conferencing | ||||||||
| ibridge-data | 2275 | udp | iBridge Conferencing | ||||||||
| ibridge-mgmt | 2276 | tcp | iBridge Management | Patrick Fisher | Patrick Fisher | 2004-12 | |||||
| ibridge-mgmt | 2276 | udp | iBridge Management | Patrick Fisher | Patrick Fisher | 2004-12 | |||||
| bluectrlproxy | 2277 | tcp | Bt device control proxy | Mark de Rooi | Mark de Rooi | 2004-12 | |||||
| bluectrlproxy | 2277 | udp | Bt device control proxy | Mark de Rooi | Mark de Rooi | 2004-12 | |||||
| s3db | 2278 | tcp | Simple Stacked Sequences Database | David Brandon | David Brandon | 2006-08 | |||||
| s3db | 2278 | udp | Simple Stacked Sequences Database | David Brandon | David Brandon | 2006-08 | |||||
| xmquery | 2279 | tcp | xmquery | Niels Christiansen | Niels Christiansen | ||||||
| xmquery | 2279 | udp | xmquery | Niels Christiansen | Niels Christiansen | ||||||
| dna | 2287 | tcp | DNA | Tung Nguyen | Tung Nguyen | ||||||
| dna | 2287 | udp | DNA | Tung Nguyen | Tung Nguyen | ||||||
| d2k-datamover1 | 2297 | tcp | D2K DataMover 1 | ||||||||
| d2k-datamover1 | 2297 | udp | D2K DataMover 1 | ||||||||
| pehelp | 2307 | tcp | pehelp | Jens Kilian | Jens Kilian | ||||||
| pehelp | 2307 | udp | pehelp | Jens Kilian | Jens Kilian | ||||||
| attachmate-g32 | 2317 | tcp | Attachmate G32 | Bryce Bhatnagar | Bryce Bhatnagar | ||||||
| attachmate-g32 | 2317 | udp | Attachmate G32 | Bryce Bhatnagar | Bryce Bhatnagar | ||||||
| ansysli | 2325 | tcp | ANSYS Licensing Interconnect | Suzanne Lorrin | Suzanne Lorrin | Modified: 27 October 2008 | |||||
| ansysli | 2325 | udp | ANSYS Licensing Interconnect | Suzanne Lorrin | Suzanne Lorrin | Modified: 27 October 2008 | |||||
| xingcsm | 2327 | tcp | xingcsm | Dave Spencer | Dave Spencer | ||||||
| xingcsm | 2327 | udp | xingcsm | Dave Spencer | Dave Spencer | ||||||
| ideesrv | 2337 | tcp | ideesrv | Marazzi | Marazzi | ||||||
| ideesrv | 2337 | udp | ideesrv | Marazzi | Marazzi | ||||||
| redstorm-find | 2347 | tcp | Game Announcement and Location IANA assigned this well-formed service name as a replacement for "redstorm_find". |
||||||||
| redstorm_find | 2347 | tcp | Game Announcement and Location | This entry is an alias to "redstorm-find". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||||
| redstorm-find | 2347 | udp | Game Announcement and Location IANA assigned this well-formed service name as a replacement for "redstorm_find". |
||||||||
| redstorm_find | 2347 | udp | Game Announcement and Location | This entry is an alias to "redstorm-find". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||||
| unihub-server | 2357 | tcp | UniHub Server | Tim Kenyon | Tim Kenyon | ||||||
| unihub-server | 2357 | udp | UniHub Server | Tim Kenyon | Tim Kenyon | ||||||
| service-ctrl | 2367 | tcp | Service Control | Humberto Sanchez | Humberto Sanchez |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adam Ernst | cosmicsoft&cosmicsoft.net | 2004-12 | |
| Andrew H Derbyshire | ahd&meetingmaker.plus.kew.com | 2004-12 | |
| Benjamin Green | ben&lh.co.nz | ||
| Brian Henry | brian.henryµsoft.com | 2007-03 | |
| Bryce Bhatnagar | BRYCEBH&attachmate.com | ||
| Daniel Kilsdonk | dan&prospeed.net | 2006-08 | |
| Dave Spencer | dspencer&xingtech.com | ||
| David Brandon | dade&smoolabs.net | 2006-08 | |
| Donald Welch | donald.welch&hp.com | 2006-05 | |
| Dr. Michael Erdmann | erdmann&ontoprise.de | 2004-12 | |
| Elgato Systems | portinfo&elgato.com | 2004-11 | |
| Gabe Frost | gfrostµsoft.com | 2005-08 | |
| Gerard Cannie | jcannie&opticaltech.com | ||
| Humberto Sanchez | Humberto_Sanchez&hp.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Itai Greenberg | itaigµsoft.com | 2004-11 | |
| James David Fisher | jfisher1&avaya.com | ||
| Jeff Roberts | jrobertsµsoft.com | 2005-11 | |
| Jens Kilian | jensk&hpbeo82.bbn.hp.com | ||
| John Lisek | jl&gotodevice.com | 2006-01 | |
| Jon Xu | jonxuµsoft.com | 2005-08 | |
| Marazzi | fmarazzi&ideetique.com | ||
| Mark de Rooi | derooi&xs4all.nl | 2004-12 | |
| Niels Christiansen | nchris&austin.ibm.com | ||
| Patrick Fisher | pfisher&hns.com | 2004-12 | |
| Peter Pramberger | peter.pramberger&telering.co.at | 2004-11 | |
| Petr Chardin | petr&mysql.com | 2004-12 | |
| ProControl Technology AB | info&pctworld.com | 2004-12 | |
| Reid Ligon | reid&connectrf.com | ||
| Rod Waltermann | walterma&us.lenovo.com | 2006-02 | |
| Sean Ni | seanni&digitalinstinct.com.tw | 2006-02 | |
| Shahriar Pourazin | pourazin&sepehrs.com | 2008-12-02 | |
| Suzanne Lorrin | suzanne.lorrin&ansys.com | ||
| Ted Hess | thess&livevault.com | ||
| Thomas Schmidt | ts&bintec.de | ||
| Tim Kenyon | Tim_Kenyon&csicontrols.com | ||
| Tung Nguyen | dash&ricochet.net | ||
| William R. Lear | william.lear&xerox.com | 2008-03-06 | |
| Yaakov Stein | yaakovjstein&gmail.com | 2022-02-04 | |
| Zygmunt Wiercioch | zyg&jetform.com |