Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
cdfunc 2045 udp
nfs 2049 sctp Network File System RFC 5665 Defined TXT keys: path=<path to mount point>
av-emb-config 2050 tcp Avaya EMB Config Port John Yeager John Yeager
av-emb-config 2050 udp Avaya EMB Config Port John Yeager John Yeager
epnsdp 2051 tcp EPNSDP Hiroyasu Ogata Hiroyasu Ogata
epnsdp 2051 udp EPNSDP Hiroyasu Ogata Hiroyasu Ogata
clearvisn 2052 tcp clearVisn Services Port Dave Lyons Dave Lyons
clearvisn 2052 udp clearVisn Services Port Dave Lyons Dave Lyons
lot105-ds-upd 2053 tcp Lot105 DSuper Updates Piers Scannell Piers Scannell
lot105-ds-upd 2053 udp Lot105 DSuper Updates Piers Scannell Piers Scannell
weblogin 2054 tcp Weblogin Port Diego Saravia Diego Saravia
weblogin 2054 udp Weblogin Port Diego Saravia Diego Saravia
iop 2055 tcp Iliad-Odyssey Protocol Bruce Lueckenhoff Bruce Lueckenhoff
iop 2055 udp Iliad-Odyssey Protocol Bruce Lueckenhoff Bruce Lueckenhoff
omnisky 2056 tcp OmniSky Port Oren Hurvitz Oren Hurvitz
omnisky 2056 udp OmniSky Port Oren Hurvitz Oren Hurvitz
rich-cp 2057 tcp Rich Content Protocol Ronen Vainish Ronen Vainish
rich-cp 2057 udp Rich Content Protocol Ronen Vainish Ronen Vainish
newwavesearch 2058 tcp NewWaveSearchables RMI Thomas Kerkau Thomas Kerkau
newwavesearch 2058 udp NewWaveSearchables RMI Thomas Kerkau Thomas Kerkau
bmc-messaging 2059 tcp BMC Messaging Service Portnoy Boxman Portnoy Boxman
bmc-messaging 2059 udp BMC Messaging Service Portnoy Boxman Portnoy Boxman
dlsrpn 2065 tcp Data Link Switch Read Port Number Amir Peless Amir Peless
dlsrpn 2065 udp Data Link Switch Read Port Number Amir Peless Amir Peless
newlixengine 2075 tcp Newlix ServerWare Engine
newlixengine 2075 udp Newlix ServerWare Engine
ada-cip 2085 tcp ADA Control Eugene Frenkel Eugene Frenkel 2005-11
ada-cip 2085 udp ADA Control Eugene Frenkel Eugene Frenkel 2005-11
nbx-ser 2095 tcp NBX SER
nbx-ser 2095 udp NBX SER
h2250-annex-g 2099 tcp H.225.0 Annex G Signalling ITU-T ITU-T TSB 2013-01-31
h2250-annex-g 2099 udp H.225.0 Annex G Signalling ITU-T ITU-T TSB 2013-01-31
minipay 2105 tcp MiniPay Amir Herzberg Amir Herzberg
minipay 2105 udp MiniPay Amir Herzberg Amir Herzberg
kdm 2115 tcp Key Distribution Manager Mike Little Mike Little
kdm 2115 udp Key Distribution Manager Mike Little Mike Little
lockstep 2125 tcp LOCKSTEP Karl Forster Karl Forster
lockstep 2125 udp LOCKSTEP Karl Forster Karl Forster
gris 2135 tcp Grid Resource Information Server Steve Tuecke Steve Tuecke
gris 2135 udp Grid Resource Information Server Steve Tuecke Steve Tuecke
tdmoip 2142 tcp TDM OVER IP Yaakov Stein Yaakov Stein 2016-09-21 RFC 5087
tdmoip 2142 udp TDM OVER IP Yaakov Stein Yaakov Stein 2016-09-21 RFC 5087
lv-pici 2145 tcp Live Vault Remote Diagnostic Console Support
lv-pici 2145 udp Live Vault Remote Diagnostic Console Support
dynamic3d 2150 tcp DYNAMIC3D Tobias Wegner Tobias Wegner
dynamic3d 2150 udp DYNAMIC3D Tobias Wegner Tobias Wegner
docent 2151 tcp DOCENT Hali Lindbloom Hali Lindbloom
docent 2151 udp DOCENT Hali Lindbloom Hali Lindbloom
gtp-user 2152 tcp GTP-User Plane (3GPP) Alessio Casati Alessio Casati
gtp-user 2152 udp GTP-User Plane (3GPP) Alessio Casati Alessio Casati
ctlptc 2153 tcp Control Protocol
ctlptc 2153 udp Control Protocol
stdptc 2154 tcp Standard Protocol
stdptc 2154 udp Standard Protocol
brdptc 2155 tcp Bridge Protocol Hideki Hatta Hideki Hatta 2007-09-27
brdptc 2155 udp Bridge Protocol Hideki Hatta Hideki Hatta 2007-09-27
trp 2156 tcp Talari Reliable Protocol John E. Dickey John E. Dickey 2007-09-27
trp 2156 udp Talari Reliable Protocol John E. Dickey John E. Dickey 2007-09-27
xnds 2157 tcp Xerox Network Document Scan Protocol William R. Lear William R. Lear 2008-03-06
xnds 2157 udp Xerox Network Document Scan Protocol William R. Lear William R. Lear 2008-03-06
touchnetplus 2158 tcp TouchNetPlus Service Brian Toothill Brian Toothill 2008-03-06
touchnetplus 2158 udp TouchNetPlus Service Brian Toothill Brian Toothill 2008-03-06
gdbremote 2159 tcp GDB Remote Debug Port Nigel Stephens Nigel Stephens
gdbremote 2159 udp GDB Remote Debug Port Nigel Stephens Nigel Stephens
x-bone-api 2165 tcp X-Bone API Joe Touch Joe Touch
x-bone-api 2165 udp X-Bone API Joe Touch Joe Touch
airsync 2175 tcp Microsoft Desktop AirSync Protocol
airsync 2175 udp Microsoft Desktop AirSync Protocol
onbase-dds 2185 tcp OnBase Distributed Disk Services Paul Tam Paul Tam 2004-12
onbase-dds 2185 udp OnBase Distributed Disk Services Paul Tam Paul Tam 2004-12
2200 tcp Reserved This entry has been removed on 2019-07-05.
2200 udp Reserved This entry has been removed on 2019-07-05.
jps 2205 tcp Java Presentation Server Leif Jakob Leif Jakob 2006-01
jps 2205 udp Java Presentation Server Leif Jakob Leif Jakob 2006-01
ipcore 2215 tcp IPCore.co.za GPRS Administrator Administrator 2005-12
ipcore 2215 udp IPCore.co.za GPRS Administrator Administrator 2005-12
rcip-itu 2225 tcp Resource Connection Initiation Protocol ITU TSB, Place des Nations, CH-1211 Geneva 20 ITU TSB, Place des Nations, CH-1211 Geneva 20
2225 udp Reserved
rcip-itu 2225 sctp Resource Connection Initiation Protocol ITU TSB, Place des Nations, CH-1211 Geneva 20 ITU TSB, Place des Nations, CH-1211 Geneva 20
sercomm-wlink 2235 tcp Sercomm-WLink Melinda Tsao Melinda Tsao
sercomm-wlink 2235 udp Sercomm-WLink Melinda Tsao Melinda Tsao
hao 2245 tcp HaO Panic Ride Panic Ride
hao 2245 udp HaO Panic Ride Panic Ride
remote-collab 2250 tcp remote-collab Richard Walters Richard Walters
remote-collab 2250 udp remote-collab Richard Walters Richard Walters
dif-port 2251 tcp Distributed Framework Port Sebastien Lambla Sebastien Lambla
dif-port 2251 udp Distributed Framework Port Sebastien Lambla Sebastien Lambla
njenet-ssl 2252 tcp NJENET using SSL Hans U Schmidt Hans U Schmidt
njenet-ssl 2252 udp NJENET using SSL Hans U Schmidt Hans U Schmidt
dtv-chan-req 2253 tcp DTV Channel Request Richard Hodges Richard Hodges
dtv-chan-req 2253 udp DTV Channel Request Richard Hodges Richard Hodges
seispoc 2254 tcp Seismic P.O.C. Port Robert Reimiller Robert Reimiller
seispoc 2254 udp Seismic P.O.C. Port Robert Reimiller Robert Reimiller
vrtp 2255 tcp VRTP - ViRtue Transfer Protocol Max Fudim Max Fudim
vrtp 2255 udp VRTP - ViRtue Transfer Protocol Max Fudim Max Fudim
pcc-mfp 2256 tcp PCC MFP Kunihiko Morota Kunihiko Morota 2005-08
pcc-mfp 2256 udp PCC MFP Kunihiko Morota Kunihiko Morota 2005-08
simple-tx-rx 2257 tcp simple text/file transfer Daniel Kilsdonk Daniel Kilsdonk 2006-08
simple-tx-rx 2257 udp simple text/file transfer Daniel Kilsdonk Daniel Kilsdonk 2006-08
rcts 2258 tcp Rotorcraft Communications Test System Terry Eldridge Terry Eldridge 2006-08
rcts 2258 udp Rotorcraft Communications Test System Terry Eldridge Terry Eldridge 2006-08

Contact Information

Name Organization Contact URI Last Updated
Administrator admin&ipcore.co.za 2005-12
Alessio Casati a.casati&computer.org
Amir Herzberg amirh&vnet.ibm.com
Amir Peless amirp&radware.co.il
Brian Toothill brian.toothill&touchstar.co.uk 2010-10-15
Bruce Lueckenhoff brucelu&cisco.com
Daniel Kilsdonk dan&prospeed.net 2006-08
Dave Lyons dlyons&dnpg.com
Diego Saravia dsa&unsa.edu.ar
Eugene Frenkel eugene&ada-usa.com 2005-11
Hali Lindbloom halil&docent.com
Hans U Schmidt schmidth&de.ibm.com
Hideki Hatta ponum&canon-is.co.jp 2007-09-27
Hiroyasu Ogata Ogata.Hiroyasu&exc.epson.co.jp
ITU-T tsbsg16&itu.int 2013-01-31
ITU-T TSB ITU-T tsbsg16&itu.int 2013-01-31
ITU TSB, Place des Nations, CH-1211 Geneva 20 tsbmail&itu.int 2006-06
Joe Touch touch&strayalpha.com 2020-02-07
John E. Dickey jdickey&talarinetworks.com 2007-09-27
John Yeager johnyeager&avaya.com
Karl Forster kforster&lockstep.com
Kunihiko Morota morota.kunihiko&jp.panasonic.com 2005-08
Leif Jakob leif+iana&cube.ch 2006-01
Max Fudim fudim&virtue3d.com
Melinda Tsao melinda&tpe1.sercomm.com.tw
Mike Little mike.little&gdc4s.com
Nigel Stephens nigel&algor.co.uk
Oren Hurvitz oren&omnisky.com
Panic Ride panicride&hao.org
Paul Tam ianaportmaster&onbase.com 2004-12
Piers Scannell iana-form&lot105.com
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Richard Hodges rh&matriplex.com
Richard Walters walters&cs.ucdavis.edu
Robert Reimiller bob&certsoft.com
Ronen Vainish ronen&digitalfountain.com
Sebastien Lambla lambla&bouygtel.com
Steve Tuecke tuecke&mcs.anl.gov
Terry Eldridge Terry.Eldridge&6pointn.com 2006-08
Thomas Kerkau Thomas.Kerkau&io-software.com
Tobias Wegner wegner&novagate.de
William R. Lear william.lear&xerox.com 2008-03-06
Yaakov Stein yaakovjstein&gmail.com 2022-02-04