Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
rcts 2258 udp Rotorcraft Communications Test System Terry Eldridge Terry Eldridge 2006-08
bid-serv 2259 tcp BIF identifiers resolution service Li Zhiping Zhang Bo 2023-03-06
bid-serv 2259 udp BIF identifiers resolution service Li Zhiping Zhang Bo 2023-03-06
apx500api-1 2264 tcp Audio Precision Apx500 API Port 1
apx500api-1 2264 udp Audio Precision Apx500 API Port 1
apx500api-2 2265 tcp Audio Precision Apx500 API Port 2 Robert Wright, Founder and Principal Engineer Robert Wright, Founder and Principal Engineer
apx500api-2 2265 udp Audio Precision Apx500 API Port 2 Robert Wright, Founder and Principal Engineer Robert Wright, Founder and Principal Engineer
amt 2268 tcp AMT IESG IETF Chair 2004-12 2014-12-17 RFC 7450
amt 2268 udp AMT IESG IETF Chair 2004-12 2014-12-17 RFC 7450
ibridge-data 2275 tcp iBridge Conferencing
ibridge-data 2275 udp iBridge Conferencing
lnvmailmon 2285 tcp LNVMAILMON John Payne John Payne
lnvmailmon 2285 udp LNVMAILMON John Payne John Payne
advant-lm 2295 tcp Advant License Manager Lars-Goran Magnusson Lars-Goran Magnusson
advant-lm 2295 udp Advant License Manager Lars-Goran Magnusson Lars-Goran Magnusson
mt-scaleserver 2305 tcp MT ScaleServer Paul Glaubitz Paul Glaubitz
mt-scaleserver 2305 udp MT ScaleServer Paul Glaubitz Paul Glaubitz
precise-sft 2315 tcp Precise Sft. Michael Landwehr Michael Landwehr
precise-sft 2315 udp Precise Sft. Michael Landwehr Michael Landwehr
ansysli 2325 tcp ANSYS Licensing Interconnect Suzanne Lorrin Suzanne Lorrin Modified: 27 October 2008
ansysli 2325 udp ANSYS Licensing Interconnect Suzanne Lorrin Suzanne Lorrin Modified: 27 October 2008
ace-proxy 2335 tcp ACE Proxy Riaz Zolfonoon Riaz Zolfonoon
ace-proxy 2335 udp ACE Proxy Riaz Zolfonoon Riaz Zolfonoon
dbm 2345 tcp dbm Dean Robson Dean Robson
dbm 2345 udp dbm Dean Robson Dean Robson
psbserver 2350 tcp Pharos Booking Server
psbserver 2350 udp Pharos Booking Server
psrserver 2351 tcp psrserver
psrserver 2351 udp psrserver
pslserver 2352 tcp pslserver
pslserver 2352 udp pslserver
pspserver 2353 tcp pspserver
pspserver 2353 udp pspserver
psprserver 2354 tcp psprserver
psprserver 2354 udp psprserver
psdbserver 2355 tcp psdbserver Paul Reddy Paul Reddy
psdbserver 2355 udp psdbserver Paul Reddy Paul Reddy
gxtelmd 2356 tcp GXT License Managemant Robert Hodgson Robert Hodgson
gxtelmd 2356 udp GXT License Managemant Robert Hodgson Robert Hodgson
unihub-server 2357 tcp UniHub Server Tim Kenyon Tim Kenyon
unihub-server 2357 udp UniHub Server Tim Kenyon Tim Kenyon
futrix 2358 tcp Futrix Peter Frankenberg Peter Frankenberg
futrix 2358 udp Futrix Peter Frankenberg Peter Frankenberg
flukeserver 2359 tcp FlukeServer Bill Marbaker Bill Marbaker
flukeserver 2359 udp FlukeServer Bill Marbaker Bill Marbaker
dbref 2365 tcp dbref Yoshihiro Yamazaki Yoshihiro Yamazaki
dbref 2365 udp dbref Yoshihiro Yamazaki Yoshihiro Yamazaki
docker 2375 tcp Docker REST API (plain text) DOCKER Christopher Liljenstolpe 2014-04-17
2375 udp Reserved
sd-data 2385 tcp SD-DATA Jason McManus Jason McManus
sd-data 2385 udp SD-DATA Jason McManus Jason McManus
lan900-remote 2395 tcp LAN900 Remote

IANA assigned this well-formed service name as a replacement for "lan900_remote".
Tom Quinlan Tom Quinlan
lan900_remote 2395 tcp LAN900 Remote Tom Quinlan Tom Quinlan This entry is an alias to "lan900-remote". This entry is now historic, not usable for use with many common service discovery mechanisms.
lan900-remote 2395 udp LAN900 Remote

IANA assigned this well-formed service name as a replacement for "lan900_remote".
Tom Quinlan Tom Quinlan
lan900_remote 2395 udp LAN900 Remote Tom Quinlan Tom Quinlan This entry is an alias to "lan900-remote". This entry is now historic, not usable for use with many common service discovery mechanisms.
iec-104 2404 tcp IEC 60870-5-104 process control over IP Walter K. Eichelburg Walter K. Eichelburg
iec-104 2404 udp IEC 60870-5-104 process control over IP Walter K. Eichelburg Walter K. Eichelburg
trc-netpoll 2405 tcp TRC Netpoll Bizhan Ghavami Bizhan Ghavami
trc-netpoll 2405 udp TRC Netpoll Bizhan Ghavami Bizhan Ghavami
codima-rtp 2415 tcp Codima Remote Transaction Protocol Sylvia Ross Sylvia Ross
codima-rtp 2415 udp Codima Remote Transaction Protocol Sylvia Ross Sylvia Ross
fjitsuappmgr 2425 tcp Fujitsu App Manager Hiroyuki Kawabuchi Hiroyuki Kawabuchi
fjitsuappmgr 2425 udp Fujitsu App Manager Hiroyuki Kawabuchi Hiroyuki Kawabuchi
optilogic 2435 tcp OptiLogic Clark Williams Clark Williams
optilogic 2435 udp OptiLogic Clark Williams Clark Williams
dtn1 2445 tcp DTN1 Bob Gaddie Bob Gaddie
dtn1 2445 udp DTN1 Bob Gaddie Bob Gaddie
netadmin 2450 tcp netadmin
netadmin 2450 udp netadmin
netchat 2451 tcp netchat Julian Mehnle Julian Mehnle
netchat 2451 udp netchat Julian Mehnle Julian Mehnle
snifferclient 2452 tcp SnifferClient Amy Weaver Amy Weaver
snifferclient 2452 udp SnifferClient Amy Weaver Amy Weaver
madge-ltd 2453 tcp madge ltd Mark Lyall Mark Lyall
madge-ltd 2453 udp madge ltd Mark Lyall Mark Lyall
indx-dds 2454 tcp IndX-DDS Paul Carmichael Paul Carmichael
indx-dds 2454 udp IndX-DDS Paul Carmichael Paul Carmichael
wago-io-system 2455 tcp WAGO-IO-SYSTEM Jörg Hoffmann Jörg Hoffmann
wago-io-system 2455 udp WAGO-IO-SYSTEM Jörg Hoffmann Jörg Hoffmann
altav-remmgt 2456 tcp altav-remmgt Gary M. Allen Gary M. Allen
altav-remmgt 2456 udp altav-remmgt Gary M. Allen Gary M. Allen
rapido-ip 2457 tcp Rapido_IP Man Shuen Cheung Man Shuen Cheung
rapido-ip 2457 udp Rapido_IP Man Shuen Cheung Man Shuen Cheung
griffin 2458 tcp griffin Tom Taylor Tom Taylor
griffin 2458 udp griffin Tom Taylor Tom Taylor
xrpl 2459 tcp Community David Schwartz David Schwartz 2019-08-09
xrpl 2459 udp Community David Schwartz David Schwartz 2019-08-09
lbm 2465 tcp Load Balance Management
lbm 2465 udp Load Balance Management
ace-server 2475 tcp ACE Server
ace-server 2475 udp ACE Server
netobjects1 2485 tcp Net Objects1
netobjects1 2485 udp Net Objects1
fast-rem-serv 2495 tcp Fast Remote Services Scott St. Clair Scott St. Clair
fast-rem-serv 2495 udp Fast Remote Services Scott St. Clair Scott St. Clair
rtsserv 2500 tcp Resource Tracking system server
rtsserv 2500 udp Resource Tracking system server
rtsclient 2501 tcp Resource Tracking system client Aubrey Turner Aubrey Turner
rtsclient 2501 udp Resource Tracking system client Aubrey Turner Aubrey Turner
kentrox-prot 2502 tcp Kentrox Protocol Anil Lakhwara Anil Lakhwara
kentrox-prot 2502 udp Kentrox Protocol Anil Lakhwara Anil Lakhwara

Contact Information

Name Organization Contact URI Last Updated
Amy Weaver amy_weaver&nai.com
Anil Lakhwara anil_lakhwara&kentrox.com
Aubrey Turner S95525ta%25etsuacad.bitnet@ETSUADMN.ETSU.EDU
Bill Marbaker wrm&fortenet.com
Bizhan Ghavami ghavami&telcores.com
Bob Gaddie bobg&dtn.com
Christopher Liljenstolpe iana&cdl.asgaard.org 2014-04-17
Clark Williams clark&wirespeed.com
David Schwartz davidjoelschwartz&gmail.com 2019-08-09
Dean Robson dean.robson&fujitsu.com.au
DOCKER iana&cdl.asgaard.org 2014-04-17
Gary M. Allen gallen&symantec.com
Hiroyuki Kawabuchi buchi&ael.fujitsu.co.jp
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jason McManus jasonm&sleepdep.net
John Payne jpayne&lotus.com
Jörg Hoffmann electronicc_rd&wago.com
Julian Mehnle julian&mehnle.net
Lars-Goran Magnusson lars-goran.magnusson&seisy.mail.abb.com
Li Zhiping CAICT lizhiping&caict.ac.cn 2023-06-29
Man Shuen Cheung man_shuen_cheung&wamnet.co.uk
Mark Lyall mark.lyall&madge.com
Michael Landwehr mikel&precisesoft.co.il
Paul Carmichael paulcarmichael&indx.net
Paul Glaubitz Paul.Glaubitz&mt.com
Paul Reddy preddy&pharos.com
Peter Frankenberg pcfberg&ibm.net
Riaz Zolfonoon rzolfonoon&securitydynamics.com
Robert Hodgson rrh&gxt.com
Robert Wright, Founder and Principal Engineer Audio Precision Inc. ianaports&ap.com 2006-05
Scott St. Clair stclair&ntc.adaptec.com
Suzanne Lorrin suzanne.lorrin&ansys.com
Sylvia Ross sross&codimatech.com
Terry Eldridge Terry.Eldridge&6pointn.com 2006-08
Tim Kenyon Tim_Kenyon&csicontrols.com
Tom Quinlan tquinlan&digitechinc.com
Tom Taylor Tom.Taylor&unisys.com
Walter K. Eichelburg walter.eichelburg&sat-automation.com
Yoshihiro Yamazaki yamazaki&ael.fujitsu.co.jp
Zhang Bo CAICT zhangbo3&caict.ac.cn 2023-06-29